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Welcome to the Vectorworks Fundamentals 
2012 Getting Started Guide! This guide is 
designed to provide you with a strong base as 
you learn to use Vectorworks Fundamentals 
to design, communicate, and document the 
designs that you are passionate about.

This guide cuts to the heart of Vectorworks, 
explaining the concepts, and methodologies 
needed to develop improvisational skills 
so that you can be efficient, and perhaps 
most important, you can be successful 
at realizing your most inspired visions.

This guide presents the tools, commands, 
and other details of the software in the context 
of workflows which are the discreet steps 
taken with the software that accomplish 
a specific architectural or design task. 
A workflow takes a familiar design task, 
such as creating a massing model from 
a series of planar elements, and present 
commentary, demonstration, and example 

steps to accomplish the task in a way that 
can be mastered, and used to accomplish 
real tasks that you encounter in the course 
of your practice. This concept forms the 
bridge from traditional design processes 
to the software implementation details, 
and best practices used to model these 
processes in Vectorworks Fundamentals.

The workflows used in this guide are 
selected for the learning opportunities they 
present. There are often multiple workflows 
that deliver the desired result. A unique 
feature of this guide is the examination of 
the benefits, and drawbacks of alternate 
workflows. This discussion will help you 
develop workflow strategies of your own.

The Vectorworks Fundamentals Getting 
Started Guide is essential required reading 
for all design professionals; from first-
time users to the most experienced.

How this guide is organized

As with most tools this capable, a familiarity 
with multiple disparate topics is needed 
before enough skills can be mustered 
to work effectively with Vectorworks 
Fundamentals. This guide has several 
features that make it unique in it's ability 
to deliver information about these skills.

The topics are integrated into the exercise 
so that the workflow can be seen as a 
whole. But it is also necessary to factor 
out each topic at times so that it can be 
examined on its own so that it's purpose, 
and benefits can be recognized as it 
is used throughout the exercise.

4 | Vectorworks Architect 2012 Getting Started Guide

Special Cases ........................................................................................................................................46
Managing Resources .............................................................................................................................46
Default content system ..........................................................................................................................47

Section 5: Glossary ................................................................................................................ 49

Section 1
Preface



6 | Vectorworks Architect 2012 Getting Started Guide Vectorworks Architect 2012 Getting Started Guide | 7

Vectorworks Fundamentals user who would 
like some insight into well-established 
best practices so that you can consider 
updating your use of the software.

What if I don't understand one of 
the steps?
After each chunk of steps there is a 
video thumbnail that shows a movie of 
the steps just explained. Just click on 
the thumbnail, and watch the movie. 
There is no audio on these clips.

Terms Used in this Manual
Cursor, and Pointer

The cursor is the mark on the display that 
indicates where the next thing will happen. 
Most of the time the cursor looks like a skewed 
arrow. The cursor location is controlled by 
you with an input device. We use the term 
pointer to collectively refer to your mouse 
or any other device that you might be using 
for input. These would include the track-ball, 
tablet, track-pad, etc. Fingers may well be the 
only commonly used pointer, eventually; just 
as they were originally, before computers.

In Vectorworks, the cursor icon changes 
according to the context, so as you move 
the pointer, the cursor will change its form 
to give you information about any objects 
nearby. Each icon tells you something very 
specific. Although the cursor seems to change 
constantly as you move it around, we will 
only point out particular cursor icons when 
we need them. Just watch the cursor as we 
go, and you will learn to use the information it 
displays to create fast, and accurate models.

Pointer Gesture Terms
Pointer gestures are the ways that the 

pointer is used in Vectorworks to position 
the cursor, and issue commands.

• Point-To move the cursor over an 
object, usually to acquire a smart 
point. We'll get to this in a bit.

• Press-Hold the pointer left button down 
without releasing it. This is sometimes 
necessary when there is a short delay

• Click-Press the left pointer button, 
and immediately release it. In this 
guide, when you see the instruction 
to 'click' without modifiers, it means 
to click the left pointer button.

• Right-Click-Press the right pointer button, 
and immediately release it. If you have 
a single button mouse, this is done by 
pressing the Control key down on the 
keyboard before you click, and holding 
it down as you click the mouse button. 

• Double–click To press, and release 
the pointer button twice quickly in rapid 
succession. Be sure to hold the pointer 
absolutely still while you are clicking.

• Drag-point the cursor, press the button, 
move the pointer to another location with 
the pointer button held down, and then 
release the button in the other location. 
There are only a few circumstances 
that this is done in Vectorworks.

The benefit to you is that if you want to focus 
on any of this topical material, you may work 
through the guide by following the topic that 
interests you using a system of linked icons. 
We will explain these in the next section. Of 
course, we recommend that you work through 
this guide straight through at some point.

This guide explains the hows, and whys of 
Vectorworks Fundamentals in the commentary 
through the Example. The heart of the Guide 
is the Example section which puts into 
context usage of the tools with the emphasis 
on best practice workflows in a complete 
project. Embedded videos follow each 
group of written steps exactly, but without 
the important tips, and notes in the text. In 
case you have ended up with an unexpected 
result after one of the steps, you can review 
the video immediately. At the end is the 
Further Exploration section which highlights 
common workflow variations which may not 
have been encountered in the Example.

This Guide is written as a companion to 
the help system, which does not contain 
step-by-step procedures. The help system 
serves as a comprehensive reference for the 
tools, commands, and dialog boxes that you 
will encounter here in this guide, and layer 
as you use Vectorworks Fundamentals for 
your projects. Indeed, you are encouraged 
to read through the parallel material in the 
Vectorworks 2012 Help application when 

you want more information about a specific 
element being used in this guide. A link 
to the help system is provided at each 
tool, and command for this purpose.

The workflows in this guide have been 
developed to give you the experience of 
using Vectorworks' Fundamentals integrated 
snapping, hybrid, cursor, and other systems 
to draw fast, and accurately as you solve 
visual, and geometric design problems. 
It's a lot to digest all at once, yet it can be 
quite unsatisfying if you aren't using these 
features in concert. So, as you practice 
with Vectorworks, imagine improvising a 
solution to the tasks before you using various 
combinations of these features together. 
Those who succeed always embrace the 
tools to enhance their personal approach. 

Still, it often is quite overwhelming to 
beginners at first, so take it in small pieces: 
Watch the videos that accompany the steps 
to see a practiced hand doing them. Then try 
the step over again so you'll get the sense of 
how the different parts are used together.

Also, it may help to think of using the 
various features linearly to get the job 
done. For instance, drawing a few extra 
guidelines can go a long way toward 
building the workflow in your mind as you 
work. The main thing is to understand, and 
embrace the goal of using Vectorworks' 
Fundamentals systems efficiently.

So, from where did you come to Vectorworks?

This guide provides distinct paths through the 
material for use by different types of learners 
as well as by individuals who want to explore 
certain facets of Vectorworks separately. 
Of course, you can start at the beginning, 
and traverse sequentially until you get to 
the end, the necessary commentary will 

be presented at the appropriate time in the 
workflow; but your situation may be different.

You may be a user coming to Vectorworks 
Fundamentals from another software, 
who simply would like to know what's 
different. Or perhaps you are a self-taught 
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Interface Elements
Lets begin with a quick description of the interface elements in Vectorworks Fundamentals.

Document Window 
 
The largest region in the center of the display 
is the Document window. The Document 
window is tinted with subtle colors to indicate 
the projection. For example, the Document 
window is cream for Top/Plan, and light 
green for 3D views. You'll see a pure white 
background for sheet layers. The Document 
window also (optionally) displays various 
types of coordinate grids, which identify 

working planes as they are projected in the 
Document window. The print page boundary 
is shown as a light gray rectangle, and can 
show additional divisions to indicate the tiling 
that will be performed when printing an area 
that is too small to fit on a single page.

 

Section 2
Commentary
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be found in the User Guide located 
in the Vectorworks Help menu.

Workspace
The general look of the controls around 
the document window is determined by the 
workspace. In Vectorworks, a workspace is 
an arrangement of tools, menus, and perhaps 
most importantly, the customizable shortcuts, 
and hot keys assigned to select menus, tools, 
and certain other functionality, without having 
to use the pointer. For some users, using 
the keyboard more can streamline many 
tasks. You can customize your workspace 
with the Workspace Editor, so you can adapt 
parts of Vectorworks’ interface to suit.

We will be using the shipping workspace 
throughout this guide, however, so please 
don’t change it at this time. It is worth noting 
that the shipping workspaces have been 
developed over time, and have been given 
a substantial amount of thought by folks 
who are intimately familiar with the use of 
the software. Therefore you might want to 
continue using your workspace for a while 
to discover the logic behind its layout.

If you are coming to Vectorworks after 
using other software, you will find that, 
while the result that you expect from either 
product is identical, ideally the way that 
you use Vectorworks to achieve this result 
is substantially different. This is because 
Vectorworks, as with any software, presents a 
unique user model. This makes applying the 
approach of other software inefficient at best. 
A classic notion is to come to Vectorworks 
expecting to use the methods learned on other 
systems. So, bring your high expectations, but 
make sure you leave your old methods behind 
while you get up to speed in Vectorworks. 

Palettes
The figure at the beginning of this section 
is a screenshot of the Vectorworks 
Fundamentals workspace. To the far left are 
the tool palettes where you’ll see rows of 
tool icons. All those little tool icons can be 
intimidating when you’re first starting out, 
but we’ll get you up to speed in short order. 

At the top is the Basic Tool palette. This is 
the palette that we’ll be using mostly, at first. 
Notice the black arrow in the upper left of 
the Basic Tool palette, which when you click 
on it, makes the cursor look like the normal 
system cursor. This is the Selection tool. 
Vectorworks always has a tool selected, even 
if it is the Selection tool. The modes of the 
selected tool will be visible in the Tool bar. 
Below the Basic Tool palette is a special 
palette called Tool sets, which is a pallet of 
pallets organized by task. We will visit this 
palette occasionally in the Exercise. Which 
palettes, and tools that you see here depends 
on which Vectorworks product is installed.

To the right of the drawing window is the 
Object Info palette. This palette reports 
the parameters, such as the size or 
location of the selected object(s). You 
can edit the parameters of a selected 
object with the Object Info palette as 
well, which causes the selected objects 
to adjust according to the new values.

 

Menu Bar, View bar, Tool bar, and 
Message bar
Immediately above the Document Window 
are three horizontal control strips. At the 
very top is the Menu bar, and below that, 
the Title bar, which displays the file name 
of the Document window contents.

Below these two bars is the View bar, which 
is the “status dashboard” of Vectorworks 
Fundamentals. Always check the View 
bar to help understand the context of what 
you’re looking at in the Document window. 
The visible controls in the View bar are 
shown with a checkmark in the list of View 
bar elements under the small arrow in the 
right-most position of the View bar. You can 
customize what is shown in the View bar with 
this list, but for now, we’ll leave it alone.

Below the View bar is the Tool bar. Whenever 
a tool is selected, the Tool bar offers mode 
buttons that control how the active tool will 
work. In addition, check for instructions to the 
right of the mode buttons, which explain what 
to do before each step as you use the tool.

Framing the Document window vertically to 
the left, and horizontally below the Tool bar, 
are rulers to help you understand the size of 
the area displayed in the Document window as 
you zoom, and pan about within the Document 
window. The rulers can be hidden with a 
preference setting to save screen “real estate.”

Across the bottom of the Document window 
is a gray strip where general help appears 
to the left, and the coordinates of the cursor, 
to the right. Watch the right part of this bar 
for minor alerts in red, and the progress 
bar to estimate time remaining during long 
operations such as rendering, and importing.

Tool Hot Keys/Menu Shortcuts
Tool hot keys are listed in the tool tip that 
appears when you mouse over any tool. 
A hot key is one or more keys without 
the command key (Mac) or Control key 
(Windows) modifier. For example, to activate 
the rectangle tool, simply press the “4”; to 
activate the selection tool press the “x” key. 
(This is the “4” key in the row of numbers 
across the top of the keyboard, not the “4” 
in the numeric keypad, if you have one.

Menu shortcuts are listed across from the 
menu name each time you issue a command 
in the menu bar. Similar to the tool hot 
keys, are the menu shortcuts which can be 
entered on your keyboard to invoke menu 
commands without moving the cursor.

In this guide, the term pointer is used to 
select the menus, and tools throughout 
the instructions. We feel that this method 
gives you more obvious feedback as you 
become acquainted with the software. Even 
self-taught folks generally start out with 
the interactive input methods used in this 
book. You can use the tool hot keys, and 
menu shortcuts interchangeably with the 
pointer methods described in this guide.

Many hard-core users incorporate the 
menu shortcuts, and tool hot keys at 
some point along the way, once they are 
more familiar with the software. Either 
way, or a mixture of each method, can be 
best for you. The results are identical.

The complete list of all the shipping 
tool hot keys, and Menu Shortcuts can 
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• drawing navigation; zoom, pan; 
flyover, walkthru, views, etc.

• Layers, and other drawing 
organization tools

• snapping, constraints
• xyz coordinate space
• duplicating, processing, pattern creation

Vectorworks Key Concepts

Container Objects
Container objects make creating, and editing 
some types of representations more flexible 
because the simpler defining objects that 
comprise the container are stored as part 
of, or within the container. The benefit of the 
container concept is that you can revise or 
later replace simple defining objects inside the 
container without having to rebuild the object 
represented by the container from scratch. 
So, container objects store easy-to-edit 
objects as parameters, that can be used to 
refine or redefine the container at any time.

For example, to make a curb around a patio, 
you might imagine creating straight lengths 
of stock, and somehow mitering the strips 
at each bend. Following a curve presents a 
challenge, as does the prospect of making 
a change later to the shape of the patio. 

Instead, a container object called Extrude 
Along Path can be used to store a path 
representing the shape that the curb follows, 
and a profile, which is a planar object in 
the form of a section through the curb. 
The Extrude Along Path container object 
uses these definitions to compute how 
the section looks as it follows the path. 
At any time later, you can access either 
the path or the profile independently to 
greatly simplify making design changes 
that the container will subsequently use.

This concept is incorporated into all sorts 
of objects in Vectorworks, and once you 
become familiar with the behavior of one 
type of container object, you’ll know what to 
expect whenever you encounter other types.

Stacking Order
As objects are drawn, the program keeps 
track of their stacking order within the 
design layer. The first object created is at 
the back of the stack, and the most recent 
object created is at the front of the stack.

The send commands change the stacking 
order of objects within a layer. Objects 
can be sent forward to be in front of an 
overlapping object or sent backward to 
be behind an overlapping object. Also, 
objects can be sent all the way to the 
front or back of the stack in one step.

Although this applies to all objects, the 
stacking effect is only seen when the 
projection is Top/Plan, and only with planar 
objects having a fill attribute other than none. 
Nevertheless, this feature is used to great 
effect throughout the design process to 
construct, create, and edit figures for details, 
plan projections, and viewport annotations

Working, Automatic, and Layer 
Planes (Screen)
In Vectorworks, when manipulating objects 

Preferences
In Vectorworks, you can use a category 
of preferences called Vectorworks 
Preferences to change the way the program 
interacts with you. In fact, many of the 
settings, are used to let Vectorworks work the 
way it used to work in previous versions. It 
is worth noting that the shipping preference 
set has been developed over time, and has 
been given a substantial amount of thought by 
folks who are intimately familiar with the use 
of the software, so you might consider using 
most preferences the way they are installed, 
at least for a while, to take advantage of 
this collective experience. Nevertheless, 

these preferences are provided so that you 
can adjust them to your preference.

All Vectorworks Preferences apply to your 
account on a specific machine. Vectorworks 
writes separate preference sets for 
each account on the same machine.

Another category of preferences is Document 
Preferences that apply to individual files. 
This preference set has items that you 
may need to adjust so that certain special 
purpose files behave appropriately. Once 
you have identified the need for any of these 
preferences, you can make a template or 
stationary file with any document preferences, 
which opens a copy of the template with the 
document preferences already applied.

Common Computer Conventions in Vectorworks

Many conventions common to most software 
are found in Vectorworks. As in word 
processors, email clients, and spreadsheets 
everywhere, these functions work as 
expected in Vectorworks Architect, as well:

• Delete: Select an object, and press 
the backspace or delete key.

• Undo: If you make a mistake, 
choose Edit->Undo

• Copy, Cut, Paste: All of these conventions 
are present, and work in Vectorworks 
in a familiar, reassuring way.

• 

Common CAD Concepts 
 
Selection: Use the Selection tool to select objects, to move, and resize objects in any view, 
and to insert objects in or next to a wall. From the Basic Tool palette, select the Selection 
tool, move the cursor into the document window, and click on an edge of an object. While 
you are puttering about in the Document window, each time the cursor crosses the edge of a 
selectable object, Pre-selection Highlighting indicates any objects that would be selected. To 
deselect or select more than one object at a time, click the pointer while holding the Shift key.

An additional method, marquee selection, 
allows you to select any number of objects 
within a region on the screen. Press the 
Option (Macintosh) or Alt (Windows) key 

while dragging with the pointer button 
depressed. This will toggle the selection 
state of all objects that are within the 
region or that intersect the marquee.
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Section 3
Example
Initial Setup

To ensure consistency when doing these 
exercises please take a movement to setup 
your workspace, and Vectorworks 
Preferences. This way we can all start with the 
same base line. 

Click the play button below to view a video 
of the following steps.  

1. First, open a new blank document by 
going to File > New. Choose Create 
Blank Document, and click OK.  

2. Go to Tools > Workspaces and select 
Fundamentals.

3. Go to Tools > Options > Vectorworks 
Preferences, and click the Reset 
button. Accept the “Are you sure…?” 
dialogue box, and select General in the 
Category list on the left. 

4. Next return to the Vectorworks 
Preferences (Tools > Options > 
Vectorworks Preferences), and 
choose the Display tab. Then check the 
option Center on objects after view 
change. 

5. Click OK to close the Vectorworks 
Preferences. 

6. Now we’ll adjust the constraints 
categories. Go to Tools > SmartCursor 
Settings. 

7. Dismiss the “Did you know…?” dialogue 
box, and click the Reset button. Accept 
the “Are you sure…?” dialogue box, and 
select General in the Category list on 
the left. 

in space, snap points of existing 3D objects 
always override the other alignment, and 
positioning mechanisms described here. 
This is desirable most of the time, so this 
is the default. Otherwise, Vectorworks 
requires a plane in space so that clicking 
on the “flat” display can be calculated 
to intersect somewhere before infinity. 
Therefore, all object creation, editing, and 
moving is aligned to a working plane.

A working plane is an elevation of any height 
on a plane of three points at any orientation 
defined by the user. Often, the user will 
define a working plane to make aligning, and 
positioning tasks easier, and more accurate. 
If the working plane is not explicitly defined by 
the user, then the location of the working plane 
defaults to that of the Active Layer plane.

Every Vectorworks layer has a horizontal 
plane, and elevation associated with it that 
you can set relative to the internal fixed 
plane known as the Ground Plane.

The Ground plane is a fixed horizontal plane 
with its origin at the center of the drawing 
space, and at the level of the printed paper. 
Ultimately, the Ground plane determines 
how the location of any point is listed.

There are several functions that can affect 
this behavior, however. Objects in layers 
with an offset to the ground plane report 
their height relative to their layer plane 
whether or not the layer plane is offset from 
the ground plane. So, when not defined by 
you, the working plane defaults to the Active 
Layer plane, which may be 0, when the 
working plane is called the Ground plane.

As you are working in Vectorworks, you 
may want an object to respond to a working 
plane that is not horizontal or defined by 
any other saved planes. For example, you 
may want to align solar panels to a sloped 
roof. In this case, you can define a working 

plane that is parallel to the roof face, and 
when it is active, all creation, editing, and 
movement is observed relative to the active 
working plane. Once it has been defined, it 
can be saved, and reused later. Working in 
3D requires a plane in space so that clicking 
on the “flat” display can be calculated to 
intersect somewhere before infinity.

So, in summary:

• All editing, and creation in 3D space 
happens in the Working plane.

• The Working plane may be aligned with an 
Active Layer plane or the Ground plane

• Snap points of existing 3D objects always 
override the Working Plane, otherwise, 
there will always be an active plane.

• Working in 3D requires a plane in 
space so that clicking on the “flat” 
display can be calculated to intersect 
somewhere before infinity.

• All 3D tools, and most planar tools can 
dynamically set working planes for the next 
drawing operation. This makes controlling 
the working plane very manageable.

• The Screen plane is a legacy concept 
that continues to have narrowly 
defined uses, but is not used in the 
everyday modeling workflow.
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8. Uncheck Snap to Combined Page 
Area. 

9. Click Ok to close the SmartCursor 
setting dialogue box. 

10. Go to File > Page Setup, and uncheck 
the option Show Page Boundary, and 
click Ok to close the Page Setup up 
dialogue box. 

11. Set the document units. Go to File > 
Document Settings > Units… 

12. Set the Units drop down menu to 
Inches and also check the Show Unit 
Mark option.

13. Enable Fractional for the Rounding 
Style. 

14. Set the Fractional Display for 
Dimensions to the second style by 
ticking the second button. 

15. Choose 1/16 from the Fraction 
Precision drop menu. 

16. Then set the Units drop down menu 
under the Area section to Square 
Inches. 

17. From the Volume section set the Unit 
drop down menu to Cubic Inches, and 
click OK to close the Units dialogue 
box. 

18. Go to File > Save, and save this file to 
your desktop (or wherever you would 
like) with the name “Preferences-file-
setup” 

CPU Case

Now that the file is setup properly, we’ll create 
the bottom portion of the clamshell. From this 
point forward we’ll refer to it as the CPU case. 

 
 
 

Click the play button below to view 
a video of the following steps.

1. In the Basic Tool palette, double click 
the Rounded Rectangle tool. This will 
open the Create Object dialogue box. 

2. Input 15 1/12 for the Width, and 10 1/12 
for the Height. 

3. Be sure Position At Next Click is 
checked, and choose Symmetrical 
from the Corner drop down menu.  

4. Set the Diam X, and Diam Y fields to 
1”, and then click OK. 
 
This rounded rectangle is the overall 
size of the CPU case. Now’s lets add 
some depth. 

5. Since Position at Next Click was 
checked you will need to click 
somewhere near the origin (0,0) to 
create the Rounded Rectangle.

This rounded rectangle is the overall size of 
the CPU case. Now’s lets add some depth. 

6. Go to the Standard Views menu in the 
View Bar, and choose Right Isometric.

7. From the 3D Modeling tool set select 
the Push/Pull tool, and be sure the first 
mode, Extrude Face mode is enabled 
in the tool bar.

8. Move the pointer towards the center of 
the rounded rectangle.

9. Once the rounded rectangle is 
highlighted click to begin extruding the 
rounded rectangle face. Notice the 
pointer has changed to a double-
headed arrow.

10. Now press the Tab key to enter the 
Distance field in the floating data bar, 
and input 3/8. Press enter to lock in the 
value.

11. Then click anywhere in the drawing 
area to create the extrude.

Trackpad

With the overall shape of the CPU case 
completed, we can now add the overall 
shapes for the trackpad, keyboard, and 
speakers.  

 

Click the play button below to view a video 
of the following steps. 

 

To do this we first need to create a working 
plane on the top face of the CPU face.

1. From the 3D Modeling tool set, select 
the Set Working Plane tool. Be sure 
the second mode, Planar Face mode, 
is enabled in the tool bar. 









18 | Vectorworks Architect 2012 Getting Started Guide Vectorworks Architect 2012 Getting Started Guide | 19

2. Move the pointer to the center of the 
CPU case. Once the cursor cue Center 
is displayed, click once to set the 
working plane. Use the blue highlighting 
as a visual reference so as to not set 
the working plane to the bottom face of 
the extrude.

3. To create the trackpad, double click the 
Rounded Rectangle tool in the Basic 
Tool palette.

4. In the Create Object dialogue box, set 
the Width field to 4.5”, and the Height 
field to 3”

5. Notice the box position control is rotated 
to reflect the current view (Right 
Isometric). Choose the bottom center 
point from the box position controls, 
which is the center point closest to the 
W.

6. Then, choose Symmetrical from the  
corner drop down menu. Set the Diam 
X field to .25”, and the Diam Y value 
will update to match it, since the corners 
are set to be symmetrical.

7. Check Position At Next Click, if it is 
not already selected, and click OK.

8. To place the rounded rectangle, move 
you cursor along the bottom left edge 
on the top surface of the CPU case until 
you see the Midpoint Cursor cue.

9. Click to set the rounded rectangle. This 
is the overall shape for the trackpad.

At the moment the trackpad, and the CPU 
have a common edge but realistically the 
trackpad bottom edge would be offset from the 
CPU case’s edge. So lets move the trackpad 
away from the edge some. 

10. Switch to the Selection tool in the 
Basic Tool palette, and select the 
trackpad if it is not already selected.

11. Now move the pointer along the 
common edge of the CPU case, and 
trackpad until the pointer changes to a 
cross, and the cursor cue Midpoint is 
displayed.

12. Press, and hold your mouse button to 
pick up, and move the trackpad based 
on the selected point.

13. We are going to move the trackpad 1” 
away from the CPU case edge. With the 
mouse button still depressed press the 
Tab key until your enter the ∆Y field. 
Then enter 1” and press Enter to lock 
in the value.

14. Move the pointer along the green 
dashed axis (Y Axis) until the cursor cue 
Object / Y / Align Y is displayed. 
Release the mouse button to move the 
trackpad.

Keyboard

Create the Keyboard Based on the 
Geometry of the Trackpad.

Click the play button below to view 
a video of the following steps.

 

1. Move your pointer along the trackpad 
edge located closest to the working 
plane origin (point where the red, blue, 
and green axis meet) until the cursor 
changes to a cross, and the cursor cue 
Midpoint is displayed.

2. Press, and hold the mouse button to 
pick up the Rectangle by the selected 
point. 

3. Press, and hold the Option key (Mac) 
or Alt key (Win), and drag the rectangle 
along the Y Axis (green line). Be sure 
your cursor stays on the top surface of 
the CPU case.

Notice there is a small plus (+) beside the 
cursor when the Option or Alt key is held. This 
indicates that you will be creating a duplicate. 

4. When you reach the top edge of the 
CPU case, the cursor cue Midpoint will 
be displayed.

5. Release the mouse button to create the 
duplicate. Release the Option key.

6. In the Object Info palette choose the 
top center point from the box position 
controls, which is the center point 
opposite of the current point.

7. Now change the Width field to 11 3/8”, 
and the Height field to 4 ¾”. Then 
press Enter.

It is important to choose the position point 
from the box position controls before changing 
before entering the new width, and height as 
the set point will be constrained during the 
resizing of an object. In this case it keeps the 
rounded rectangle centered.  

8. Choose Symmetrical from the Corner 
drop down menu, and set the Diam X 
field to ¼”, and press Enter. Remember 
the Diam Y will update automatically 
because all corners are set to be 
symmetrical. This rectangle is the 
overall shape for the keyboard.

Just as with the trackpad, realistically the 
keyboard should be offset slightly from the top 
edge of the CPU case. Let’s do this now. 

9. With the keyboard selected go to 
Modify > Move > Move 3D. Since we 
are currently using a working plane, tick 
the Working Plane option.

10. Input a value of -1 ¼” in the Y’ 
Offset field, and then press OK. 
The keyboard will be moved from 
the CPU edge along the same 
green axis as the trackpad.
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Speakers

Create the Speakers.

Click the play button below to view 
a video of the following steps.

 

1. Select the Zoom tool from the Basic 
Tool palette.

2. First, click near the center of the 
keyboard. Then move your cursor 
downward, and to the right until the right 
side of the keyboard, and part of the 
CPU are inside the marquee.

3. Click once, to zoom in on the area 
inside the marquee.

4. Select the Rectangle tool from the 
Basic Tool palette. Be sure the first 
mode Rectangle mode is enabled.

5. Move the cursor upward along the right 
edge of the keyboard until the cursor 
cue Arc is displayed. If you still have 
not zoomed in close enough press the Z 
key to evoke the Snap Loupe, and find 
the Arc point.

The Snap Loupe feature zooms in temporary 
on an area around the current mouse 
position, to make snapping more precise. 
Regardless of the tool once the mouse button 
is depressed the Snap Loupe revoked.

6. Click to set the first point of the 
rectangle.

7. Move the mouse cursor along the right 
edge of the keyboard, but this time 
move downward until you receive the 
Arc cursor cue near the bottom right 
corner. Again, use the Snap Loupe if 
necessary.

8. Do not click on this point, but hold your 
cursor over the point until the smart 
point is acquired. Once a small red box 
appears around the point the smart 
point is acquired. You can also manually 
acquire the smart point by pressing the 
T key.

9. Now, move your cursor away from the 
smart point horizontally towards the 
right edge of the CPU case. Notice the 
red dashed line extending from the 
smart point. This is called the extension 
line. 

10. Continue to move along the extension 
line until you reach the CPU edge. 
Once the cursor cue Object / Align Y / 
Align Start Z is displayed, click to set 
the rectangle.

Next, we need to decrease the size 
of the speaker slightly, and also 
offset it from the CPU edge.

11. Switch the Offset tool in the Basic Tool 
palette. Be sure the first mode,  

Offset by Distance, and the fourth 
mode, Offset Original Object mode is 
enabled in the tool bar.

12. Input a value of ¼” in the Distance field 
located in the tool bar.

13. Click once inside the selected rectangle 
to create the offset. This is the overall 
shape of the right speaker.

The left speaker can be created 
quickly by using the Mirror tool.

14. First tap the X key twice to deselect the 
right speaker, and switch to the 
Selection tool.

15. Go to View > Zoom > Fit to Objects or 
click the Fit to Objects shortcut in the 
View Bar. You should now see all of the 
CPU case in the drawing area.

16. Re-select the right speaker, and then 
choose the Mirror tool from the Basic 
Tool palette. Be sure the second mode, 
Duplicate and Mirror is selected. 

17. Move the cursor to the top edge of the 
CPU case at the point where it 
intersects with the working plane Y Axis 
(Green Axis line). 

18. When the cursor cue Midpoint is 
displayed, click to set the first point of 
the mirror axis line.

19. Hold the Shift key, and move the cursor 
along the Y-axis. 

20. Once the cursor cue Y is displayed, 
click to set the mirror axis. The speaker 
is then mirrored to the left side. Now we 
have our overall shape for the left 
speaker.

CPU Detailing

The shapes we’ve created to represent the 
trackpad, keyboard, and speakers would 
not set flush against the CPU top surface, 
on most laptops these objects are indented 
in the CPU case. So we’ll do this now, and 
create a cutout for the display hinge as well.

 
 

Click the play button below to view a video 
of the following steps.
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Cutout Trackpad, Keyboard, and 
Speakers
1. First, select the Push/ Pull tool from the 

3D Modeling tool set. Be sure the first 
mode, Extrude Face mode is enabled.

2. Then click the left speaker to start 
extruding the object.

3. Press tab so enter the Distance field in 
the floating data bar.

4. Input -1/16”, and press enter to lock in 
the value.

5. Click to create the extrude.
6. Repeat these steps for the right 

speaker, trackpad, and keyboard.
Now we are going to subtract these 
extrudes from the CPU case.

7. Tap the X key once to switch to the 
Selection tool.

8. Go to Edit > Select All. Now all of the 
objects are selected.

9. Right click on the CPU case, and 
choose Subtract Solids.

10. In the Select Object dialogue box, use 
the arrows to highlight the CPU case. 
Click OK.

This means the other extrudes will be 

subtracted from the highlighted object. After 
clicking OK, notice the CPU case which 
was an extrude is now a solid subtraction. 
Let’s cutout a space for the display hinge.

11. Select the Rectangle tool from the 
Basic Tool palette. Then select the 
third mode, Side Center and Opposite 
Corner Rectangle mode.

12. Now choose Automatic from the Layer 
Plane drop down menu in the View Bar.

13. Then move your cursor to the midpoint 
of the top edge of the CPU case.

14. Once the top face of the case is 
highlighted blue, and the cursor cue 
Midpoint is displayed click to start 
drawing the rectangle.

We need the width of the hinge to match 
the keyboard width, which is 11 3/8”. With 
the current mode we are using to draw the 
rectangle we need to input half of this width.

15. Press the tab key to enter the ∆ X field, 
and input (11 3/8)/2.

16. Press tab key once more to enter the ∆ 
Y field, and input -1/2, and then press 
the Enter key.

17. Click in the drawing to set the rectangle.
18. Move your cursor inside the newly 

created rectangle, and once the 
rectangle is highlighted red click to start 
you extrude.

19. Since we need to subtract this rectangle 
from the CPU case, hold the Option 
key (Mac) or the Alt key (Windows), 
and move the cursor downward.

20. Be sure the solid is extruded past the 
bottom surface of the CPU case, and 
while still holding the Option key (Mac) 
or Alt key (Windows) click to subtract 
this solid from the CPU case.

CPU Case—Fillets

Add a Few Fillets to the Corners 
to Give the Case a Sleeker 
Appearance.
Click the play button below to view 
a video of the following steps.

 

1. Change the view to the Lower Right 
Isometric by choosing this option from 
the Standard Views drop down menu 
in the View Bar.

2. Choose the Extract tool from the 3D 
Modeling tool set. Be sure the Extract 
Surface mode is enabled in the Tool bar.

3. Click the Extract Preferences button in 
the Tool bar.

4. Check the option Select Faces, and 
click OK to close the dialogue box.

5. Now select the bottom face of the CPU 
case. Use the red highlighting a visual 
reference to verify you are selecting the 
bottom face, and not the top face. 

6. Once the correct face is selected, click 
the green checkmark in the tool bar to 
complete the action. There should now 
be a NURBS surface on the bottom of 
the CPU case.

7. Select the Push/Pull tool from the 3D 
Modeling tool set. Make sure the first 
mode, Extrude Face mode, is enabled.

8. Then move your cursor to the NURBS 
Curve at the bottom of the CPU case, 
and click once it is highlighted to start 
the extrude.

9. Press the Tab to enter the Distance 
field, and input a value of 3/16”, and 
then press the Enter key to lock in the 
value.

10. Now click anywhere in the drawing to 
complete the extrude. This is the part of 

the CPU case we are going to fillet.
11. Use the Zoom tool in the Basic Tool 

palette to zoom in on one of the corners 
of the CPU case. 

12. From the 3D Modeling tool set, choose 
the Fillet Edge tool, and click the Fillet 
Edge Preferences button in the Tool 
bar.

13. In the Fillet Edge Preferences, check 
the options Select Tangent Entities, 
and Select Faces.

14. Also change the Radius field to 3/16”. 
Then click OK to close the dialogue 
box.
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15. Select the bottom face of the latest 
extrude we created.

16. Once the surface is highlighted, click 
the green checkmark in the Tool bar to 
complete the operation. The Object 
Info palette should now display Fillet.

17. Press the X key twice to deselect the 
Fillet.

18. Then click Fit to Objects in the View 
bar (Or use the Cmd + 6 (Mac) or Ctrl + 
6 (Windows) keyboard shortcut.) to view 
the whole CPU case in the drawing 
area.

19. Go back to the View bar, and select 
Right Isometric from the Standard 
Views drop down menu.

20. Again use the Zoom tool in the Basic 
Tool palette to zoom in on any corner of 
the keyboard.

21. Next, select the Fillet Edge tool from 
the 3D Modeling tool set, and click the 
Fillet Edge Preferences button in the 
Tool bar.

22. This time, make sure Select Faces is 
unchecked, but Selected Tangent 
Entities is checked.

23. Set the Radius field to 1/8” to as well, 
and then Click OK to close the 
Preferences.

24. Select the bottom edge of the 
Keyboard.

25. Now click the green checkmark in the 
Tool bar to complete the operation.

Display Case 2D Geometry

The CPU case is nearly complete, with the 
exception of the keys, which we’ll come 
back to later. Let’s move on to creating 
the general shapes for the display case.

Click the play button below to view a video 
of the following steps.

 

Creating the Display.
To keep things organized we’re going to create 
the display on a separate design layer.

1. Go to Tools > Organization and 
choose the Design Layers tab or select 
the Layers button from the View bar.

2. Also to help with organization let’s name 
the active layer. Select Design Layer-1, 
and click the Edit button.

3. In the Edit Design Layers dialogue box 
type “CPU laptop” in the Name field, 
and click OK.

4. Now let’s create a new design layer. To 
do so, click the New button in the 
Organization dialogue box.

5. Name this layer “Screen laptop”, and 
Click OK once to return to the 
Organization dialog box.

6. Change the visibility of the CPU laptop 
layer by clicking the middle visibility 
column to the left of the design layer 
name. The icon will change to an X to 
indicate the layer is invisibile.

7. Click OK to close the Organization 
dialog box.

8. Go to View > Standard Views > Top/ 
Plan.

9. Select the Rectangle tool, and create a 

rectangle of any size anywhere in the 
current drawing area.

10. Go to the Object Info palette, and input 
a value of 15 ½” in the Width field, and 
10 ½” in the Height field.

11. Click the Fit to Objects button in the 
View Bar

12. Select the Fillet tool in the Basic Tool 
palette, and select the third mode, Trim, 
and Fillet mode.

13. Set the Fillet Radius to ½” in the Tool 
bar.

14. Since all of the corners have the same 
fillet radius, we can just simply double 
click the Rectangle to fillet at 4 corners 
at once. Normally you would need to 
select the intersecting lines to indicate 
what corner to fillet. Notice in the 
Object Info palette the Rectangle is 
now a Polyline. 

15. Now switch to the Offset tool in the 
Basic Tool palette. Be sure the first 
mode, Offset by Distance mode, and 
the third mode, Duplicate, and Offset 
mode are selected.

16. Additionally, set the Distance field to 
1/16”.

17. We need to create two offsets, so move 
your cursor towards the center of the 
polyline, and click twice. You should 
now see three polylines.

18. If the smallest offset polyline is not 
already selected, press the X key to 
switch to the Selection tool, and select 
it now.

19. In the Object Info palette, select top 
center point in the box position controls.

20. Change the ∆Y field to 10”, and press 
enter.

21. Switch to the Zoom tool, and draw a 
marquee around the top left corners of 
the three polylines.

22. With the smallest offset polyline still 
selected, choose the Offset tool from 
the Basic Tool palette.

23. Set the Distance field to ½” in the Tool 
bar, and click in the area inside the 
selected polyline.

24. With the next offset selected, return to 
the Distance field in the Tool bar, and 
input 1/16”.

25. Click anywhere inside the current offset 
polyline to create one last polyline.
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Display Case 3D Geometry

Convert the 2D Geometry for the 
Display Case into 3D Geometry. 
Click the play button below to view 
a video of the following steps.

  

 
Before we begin, to make things easier to see, 
we’ll apply some colors to the current 2D 
geometry.

1. Press the X key to activate the 
Selection tool, and the select the 
smallest polyline, if it is not already 
highlighted.

2. Click the solid fill color box, and select 
any shade of green to apply to the 
polyline.

3. Select the next closest polyline, and 
apply a shade of blue.

4. Continue in sequential order with the 
polylines, and apply any shade of the 
following colors in order: red, dark gray, 
and then light gray.

If this display were to remain in 2D the 
visual representation seen here would 
be fine; however in 3D we will need to 
apply each colored polyline a different 
thickness. For this reason we cannot have 
the polylines overlapping each other. So, 
next we’ll clip the polylines to remove 
any unneeded or hidden geometry.

5. Hold the Shift key, and select two 
largest polylines (light gray, and dark 
gray polylines). Then go to Modify > 
Clip Surface.

The Clip Surface command trims the 
bottom object in a selection so that any 
areas overlapped by the top object are 
cut out of it. To see how the dark gray 
polyline was clipped from the light gray 
polyline, click, and drag the light gray 
polyline to left. Then press command + 
Z (Mac) or Control + Z (Win) to undo.

6. Hold the Shift key, and select the dark 
gray polyline, and the red polyline.

7. Go to Modify > Clip Surface.
8. Hold Shift, and select the red polyline, 

and the blue polyline. 
9. Then instead of using the menu 

command, right click on the red 
polyline, and choose Clip Surface.

10. One last time, hold Shift, and select the 
blue polyline, and the green polyline.

11. Right click on the blue polyline, and 
choose Clip Surface. Now each 
polyline has its own defined space 
without any overlapping.

Creating the 3D Geometry.
1. Select the light gray polyline, and go to 

Model > Extrude.
2. In the Create Extrude dialogue box, set 

the Extrusion field to 1/8”, and then 
click OK.

3. Select the green polyline, and go to 
Model > Extrude.

4. Set the Extrusion field to 1mm, and 
then click OK.

5. Select the blue polyline, and use the 
keyboard shortcut Command +E (Mac) 
or Control + E (Win) to extrude the 
polyline.

6. Input 1.5mm in the Extrusion field, and 
click OK.

7. Extrude to two remaining polylines. 
Extrude the red polyline 2mm, and 
extrude the dark gray polyline 2.5mm.

Now lets see the display in 
a rendered 3D view.

8. Tap the X key twice to deselect all 
objects. Then press the Fit to Objects 
button in the View Bar or use the 
Cmd+6/Ctrl+6 keyboard shortcut to fit 
the view to the whole screen.

9. Go to the Standard Views drop down 
menu, and choose Left Isometric.

10. Use the Zoom tool, and draw a 
marquee around one of the display 
corners.

11. To render this view, go to View > 
Rendering > Open GL

12. You can also improve the quality of the 
rendering by going to View > 
Rendering > Open GL Options.

13. Change the Detail drop down menu to 
High, and the check the option Use 
Anti-Aliasing.

14. Click Ok. You should notice the rounded 
edges appear much smoother.

Positioning the Display Case

Line Up the Display Case with the 
CPU Case. 

Click the play button below to view 
a video of the following steps.

 

1. First, return to a Wireframe rendering 
by going to View > Rendering > 
Wireframe

2. Go to Tools > Organization, and select 
the far left visibility column for design 
layer “CPU laptop” to make this layer 
visible again. Click OK to close the 
dialogue box.

3. Go to View > Standard Views > Top/
Plan to change the view of the active 
design layer, Screen laptop.
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4. Go to View > Align Layer Views to 
change the CPU laptop layer to match 
the Screen laptop layer.

5. So that we can see the entire CPU 
case, and Display case, click the Fit to 
Objects button in the View bar.

6. You should see that the Display case, 
and CPU case, and are not lined up 
properly. To fix this, go to Edit > Select 
All to select all parts of the Display 
case.

7. Go to Modify > Group. As a group all of 
the parts of the display case can be 
moved much easier.

8. Switch to the Selection tool in the 
Basic Tool palette.

9. Move the pointer to the top center of the 
smallest offset. When the cursor cue 
Midpoint is displayed click, and hold 
your mouse button to pick up the group 
by this point. You may need to use the 
Snap Loupe (Z key) to acquire this 
point. 

10. Then drag the group along top edge of 
the CPU case that is closest to the 
keyboard.

11. When the cursor cue Midpoint is 
displayed, release the mouse button to 
complete the move.

Now we need to line up the CPU case, and 
the Display case properly in the Z direction. 

12. Choose Right Isometric from the 
Standard Views drop down menu in the 
View bar.

13. Go to View > Align Layer Views to 
align the CPU case layer to the same 
view.

14. Press Fit to Objects in the View bar.
15. Use the Zoom tool to the zoom in on 

the laptop corner closest to you. 
The CPU case, and Display case are 
overlapping. In reality, only the top surface 
of the CPU case, and the bottom surface 
of the Display case should be touching.

16. To fix this, with the group still selected, 
go to Modify > Move > Move 3D.

17. In the Move dialogue box, set the X’, 
and Y’ fields to 0, and the Z’ field to 
3/8”. Remember 3/8” is the thickness of 
the CPU case was originally extruded.

18. Click OK to complete the move.

Display Case Fillet

We’re almost done with the display case, but 
just as we did with the CPU case, let’s fillet 
some of the edges for a sleeker appearance.

Click the play button below to view 
a video of the following steps.

 

1. Click the Fit to Objects icon in the View 
Bar so that the entire laptop is in the 
drawing area.

2. Switch to the Zoom tool, and draw a 
marquee around the top right corner of 
the laptop to zoom in on this area.

3. We’ll need to use the existing the 
geometry of the Display case to create 
the fillets. Press the X key to switch to 
the Selection tool, and double click 
the display to enter the Edit mode for 
this group.

So that we can see the different display case 
parts easier. Render this view in Open GL.

4. Select Open GL from the Render 
modes drop down menu in the View bar 

or use the keyboard shortcut Command 
+ Shift + G (Mac) or Control + Shift + 
G (Win).

5. Now choose the Extract tool from the 
3D Modeling tool set.

6. Enable the second mode, Extract 
Curve mode in the tool bar, and then 
click the Extract Preferences button.

7. Check the options Select Tangent 
Entities, and Create Planar Objects.

8. Uncheck Select Faces if it is checked, 
and then click OK to close the dialog 
box.

9. Select the top outermost edge of the 
dark gray extrude.

10. Then click the green checkmark in the 
tool bar to complete the operation

The resulting object should be a group. 
Since Create Planar Objects was checked 
in the Extract Preferences this group 
consist of objects like lines, and arcs 
to create this one shape. Will need to 
compose objects into one polyline.

11. Go to Modify > Ungroup. Notice the 
Object Info palette shows eight objects 
are selected.

12. To compose these objects into one 
polyline, go to Modify > Compose.

13. Now switch to the Push/ Pull tool in the 
3D Modeling tool set. Be sure the first 
mode Extrude Face mode is enabled.

14. Then move your cursor over the newly 
created polyline. Once the surface is 
highlighted click to start extruding.
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15. Press the tab key to enter the Distance 
field, and enter a value of 1/16”. Then 
press the Enter key to lock in the value.

16. Click anywhere in the drawing to create 
the extrude. This will be the top of the 
display case.

17. To fillet this extrude, from the 3D 
Modeling tool set select the Fillet Edge 
tool, and set the Radius field in the 
Tool bar to 1/8”.

18. Click the Fillet Preferences button in 
the Tool bar, make sure Select Tangent 
Entities is checked. Click OK.

19. Select the top edge of the highlighted 
extrude.

20. Click the green checkmark in the Tool 
bar to complete the operation.

21. To return to the design layer click the 
Exit Group button. 

Rotating the Display Case

The Display case is completed, so its time to 
rotate it an open position.

Click the play button below to view 
a video of the following steps.

 

1. So that the entire laptop is visible in the 
drawing area, click the Fit to Objects 
icon the View bar.

2. Next, choose Right from the Standard 
Views drop down menu in the View bar.

3. Go to View > Align Layer Views to 
align the CPU laptop layer to same 
view.

4. Select the Zoom tool, and draw a 
marquee around the right corner of the 
laptop.

5. Now switch to the Selection tool, and 
select the Display case if it is not 
already highlighted.

6. Then select the Rotate tool from the 
Basic Tool palette. Be sure the first 
mode, Rotate mode is enabled in the 
tool bar. 

7. Move your cursor to the bottom right 
corner of the display case, and click 
when the cursor cue Endpoint is 
displayed to set the point for the rotation 
axis. Hold the Shift key move your 
cursor upward, once the cursor cue Y is 
displayed click again to set the rotation 
axis.

8. To rotate the display to an open 
position, hold the Shift key, and move 
cursor to the right until you see the 
cursor cue X.

9. Click once to complete rotating the 
display case to an open position.

The laptop is opened to the correct angle but 
it sitting above the hinge location. The bottom 

edge of the display needs to be move down 
to match the bottom edge of the hinge.

10. With the display case still selected, go 
to Modify > Move > Move…

11. In the Move Selection dialogue box set 
the X Offset to 0, and the Y Offset to 
-3/8”, and click ok to move the display 
case.

Creating the Hinge

Click the play button below to view 
a video of the following steps.

 

The Display case is rotated in reference 
to the hinge, so we need to return to the 
CPU case to create the hinge quickly.

1. In the View Bar click the Layers icon to 
open the Organization dialogue box.

2. Click in the blank area just to the left of 
the CPU laptop design layer to make 
the CPU laptop layer the active layer.

3. Click in the middle visibility column for 
the Screen laptop layer, so that is 
invisible. Click OK to return to the 
drawing area.

4. Now choose Rear Right Isometric from 
the Standard Views drop down menu on 
the View Bar, and click the Fit to 
Objects icon in the View Bar as well.  
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5. We need to be a little closer on the 
hinge area so manually input 100% in 
the Zoom field in the View bar. This will 
give us the best angle of the CPU case 
to create the hinge.

6. Choose the Rectangle tool from the 
Basic Tool palette. Be sure the second 
mode, Center, and Corner Rectangle 
mode is enabled in the Tool bar.

7. Set the Active Plane drop down menu 
to Automatic if it is not already set.

8. Click OK to the Did You Know dialogue 
box.

9. Move your cursor to towards the center 
of the open face for the hinge cutout .

10. Click once the face is highlighted blue, 
and the Center cursor cue is displayed 
to start the rectangle.

11. Move the cursor to the right along 
bottom edge of the highlighted face until 
the Endpoint cursor cue is displayed.

12. Click once to set the rectangle.
13. Move the cursor towards the center of 

the newly created rectangle, and click 
once the face is highlighted to begin the 
extrusion.

14. Press the tab key to enter the Distance 
field for the floating data bar, and input 
a value of ½”, and then press the Enter 
key to lock in the value.

15. Click once to complete the extrusion.
16. With the hinge still selected, click the 

Fill Style color box in the Attributes 
palette, and apply a medium gray color 
to the hinge.

17. To see how the hinge looks, choose 
Open GL from the Render modes drop 
down menu.

Keys 2D Geometry

Click the play button below to view 
a video of the following steps.

 

The laptop is almost completed but we need 
to add actual, and speakers to the CPU case.

1. From the View bar choose Top/Plan 
from the Standard Views drop down 
menu.

2. Press the X key twice to deselect all 
objects. Click the Fit to Objects icon in 
the view bar as well.

3. Click the Layers icon in the View Bar to 
access Organization dialogue box. 

4. We will be putting the keys on a 
separate design layer, so click the New 
button.

5. In the New Design Layer dialogue box, 
name the new layer Keys, and click OK 
button twice to return on the drawing 
area.

6. Select the Zoom tool, and draw a 
marquee around the cutout for the 
keyboard on the CPU case.

7. Select the Rectangle tool, and be sure 
the first mode, Rectangle mode is 
enabled in the Tool bar.

8. Next, move your cursor to the top left 
corner of the keyboard cutout.

9. Press the Z key to evoke the Snap 
Loupe, just inside of the actual corner 
of the keyboard cut out should be find 
an Arc Center Snapping point.

10. Click once you have located this point 
to start the rectangle. Notice the Snap 
Loupe is revoked as soon as the 
mouse button is depressed.

11. Move your cursor to the bottom right 
corner of the keyboard cutout, and 
repeat the last two steps to find the Arc 
Center point. Once you click on the Arc 
Center point the rectangle is created.

12. Choose the Fill Style color box in the 
Attributes palette, and apply any shade 
of purple to this rectangle.

The majority of the keys on a keyboard 
have the same measurements so we 
can use the Even Divide command 
to give us a good starting point.

13. Press the X key, and select the purple 
rectangle if it is not already selected.

14. Go to Modify > Drafting Aides > Even 
Divide

15. Set the Number of Divisions in Width 
field to 14, and the Number of 
Divisions in Height field to 6, and then 
click OK. Notice the Object Info palette 
now displays 84 rectangles.

Now we can start to combine some 
of these rectangles to create the 
large keys on the keyboard.

16. Tap the X key twice to switch to 
Selection tool, and deselect all the 
rectangles.

17. On the bottom row of rectangles select 
the fifth rectangle from the left.

18. Hold the Shift key, and select the next 
four rectangles to the right of the 
rectangle you just selected.

19. Go to Modify > Add Surface. This is 
the space bar.

20. In the row that is second from the 
bottom, hold the Shift key, and select 
the first two rectangles on the left side.

21. Go to Modify > Add Surface.
22. Repeat the last two steps for the first 

two rectangles on the right side of the 
same row. These are the Shift keys.

23. Once more repeat these steps for the 
first two rectangles on the right side in 
the row above the Shift keys. This is the 
Enter key.

The basic shape of the keys is now defined 
but we need to add some spacing between 
these keys to make there look more realistic.

24. Use the keyboard shortcut Command + 
A (Mac) or Control + A (Windows) to 
select all objects on the active layer.

25. Now hold the Shift key, and click the 
space bar, shift keys, and enter key to 
deselect these objects. The Object Info 
palette should display 73 Rectangles. 
We are now going to add spaces for all 
73 rectangles at once.

26. In the Object Info palette, be sure the 
Center point is the select point in the 
box position controls.

27. Next, input a value of 11/16” in the 
Width field, and value of 5/8” in the 
Height field. Then press the Enter key.

The measurements for the Space bar, Shift 
keys, and Enter keys must be set individually.
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28. Select all four of the keys mentioned 
above, and verify the center point is 
selected in the box position controls.

29. Select each key individually, and input 
the following values in the Object Info 
palette: Shift keys, and Enter key: ∆X = 
1 1/2”, ∆Y = 5/8”, Space bar: ∆X = 3 
13/16”, ∆Y = 5/8”

Keys 3D Geometry

OK, the 2D geometry for the keys is 
completed. Now we need to create the 3D 
geometry, and position them correctly on the 
CPU case.

Click the play button below to view 
a video of the following steps.

 

1. Press Command + A (Mac) or Control 
+ A (Win) to select all of the keys.

2. Go to Model > Tapered Extrude.
3. In the Create Tapered Extrude 

dialogue box set the Height field to 

1/16”, and the Taper Angle field to 45 
degrees. Click OK to create the tapered 
extrude object.

Notice that all of the keys are now one object. 
This is because all of the keys were selected 
at the time of the operation. That quickly we 
created the 3D geometry for the keys now we 
just need to move the keys to correct Z height.

4. From the Standard Views drop down 
menu in the View bar select Right 
Isometric.

5. Go to View > Align Layer Views so the 
CPU laptop layer is aligned with Keys 
layer.

6. With the keys still selected go to Modify 
> Move > Move 3D.

7. Input 0” in the X’, and Y’ Offset fields, 
and ¼” in the Z’ Offset field. Then click 
OK to move the keys into their proper 
position.

Speakers Detailing

The last thing that needs to be 
done to complete this laptop 3D 
model is create the speakers.

Click the play button below to view 
a video of the following steps.

 

1. First switch to a Top/Plan View by 
going to View > Standard Views > 
Top/Plan.

2. Go to View > Align Layer Views so 
that the CPU case is now in Top/Plan 
View as well.

3. Press the X key twice to deselect all 
objects, then click the Fit to Objects 
button on the View bar.

As we have done throughout this exercise 
we will place the speakers on their 
own layer to help with organization.

4. Click the Layer button in the View Bar, 
and then click the New button.

5. Name this new design layer, 
“Speakers”. Click OK twice to return to 
the drawing area.

6. Use the Zoom tool, and draw a 
marquee around the left speaker cutout 
to zoom to this area.

7. Switch to the Rectangle tool in the 
Basic Tool palette. Be sure the first 
mode, Rectangle mode is enabled.

8. Click the top left corner of the speaker 
cutout when the Endpoint cursor cue 
appears to start the rectangle.

9. Then  Click the bottom right corner of 
the speaker cutout when the Endpoint 
cursor appears to complete the 
rectangle.

10. Now select Circle tool from the Basic 
Tool palette, and be sure the first mode, 
Circle by Radius mode is enabled.

11. Click anywhere in the inside the newly 
created rectangle to start drawing the 
circle

12. Press the tab key to enter the Length 
field, and input 1/16”. Then press the 
Enter key to lock in the value.

13. Now click anywhere in the drawing to 
place the circle.

14. With the circle still selected, go to Edit > 
Duplicate Array.

15. In the Duplicate Array dialogue box, 
set the Shape drop down menu to 
Rectangular Array.

16. Set the Number of Columns field to 6, 
and Number of Rows field to 15.

17. Then input ¼” for the Distance 
Between Columns field, and -1/4” for 
the Distance Between Rows field. 

18. Make sure Retain, and Leave Selected 
are both checked on the bottom right.

19. Then click OK to create the Array.
20. So that these Circles are easier to move 

as unit, go to Modify > Group.
Most likely at the moment your group 
does not sit inside the rectangle we 
drew earlier. It will only take a few 
steps to align these objects exactly.

21. Your group of circles should already be 
highlighted, so press the X key to switch 
to the Selection tool. Then hold Shift 
key, and click rectangle behind the 
group.

22. Go to Modify > Align > Align/ 
Distribute.
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23. To the right of the Preview box check 
the Align option, and tick the option 
Center.

24. Below the Preview box, you also want 
to check the Align option, and tick the 
Center option.

25. Click OK to align the two objects.
26. Hold the Shift key, and click the 

rectangle to deselect this object.
27. With just the group selected, go to 

Modify > Ungroup.
28. Hold the Shift key, and re-select the 

rectangle.
29. Right click on any of the highlighted 

objects, and choose Clip Surface from 
the context menu. 

30. Press the Delete key to remove the 
unneeded circles. Now we have just 
one polyline. Select this polyline.

31. Go to Model > Extrude, and set the 
Extrusion field to 1/16” to add depth to 
the speaker.

Now the speakers just to need to be 
positioned properly on the CPU case, and 
mirrored to the other side of the CPU case.

32. Switch to a Right Isometric View by 
selecting Right Isometric from the 
Standard Views drop down menu.

33. Go to View > Align Layer Views so 
that the other visible layers are changed 
to a Right Isometric View as well.

34. Press the X key switch to the Selection 
tool, and select the speaker if it is not 
already highlighted.

35. Go Modify > Move > Move 3D, and set 
the X’, and Y’ Offset fields to 0. Set the 
Z’ Offset field to 5/16”, and click OK to 
move the speaker to its correct position.

All we have left to do is mirror the speaker, 
and laptop model is complete.

36. Choose Top/Plan from the Standard 
View drop down menu.

37. Go to View > Align Layer Views to 
change the other visible layers as well.

38. Press X twice to deselect the speaker. 
Additionally click the Fit to Objects 
button on the View bar.

39. With the speaker once again selected, 
choose the Mirror tool from the Basic 
Tool palette. Be sure the second mode, 
Mirror, and Duplicate mode is enabled 
in the tool bar.

40. Now, move your cursor towards the 
center of the top edge of the CPU case.

41. Click once the cursor cue Midpoint is 
displayed.

42. Hold the Shift key, and move your 
cursor downward, and click again when 
the cursor cue Vertical is shown to 
place the duplicate speaker on the right 
side of the CPU case.

Viewports

That’s it! Our laptop model is complete. 
Now let’s make change the colors to 
something more appropriate for a laptop, 
and create one Open GL viewport, and 
one Hidden Line rendering viewport.

Click the play button below to view 
a video of the following steps.

 

1. Click the Layer button in the View bar.
2. In the Organization dialog box, set the 

“Screen laptop” layer to visible by 
clicking the far left visibility column for 
that design layer.

3. Next, click the New button, and the 
name this name Laptop complete.

4. Then click OK twice to return to the 
drawing layer.

5. Go to View > Layer Options, and 
choose Show/Snap/Modify Others.

6. Go to Edit > Select All
7. In the Object Info palette choose 

Laptop complete from the layer drop 
down menu.

8. Switch to a Right Isometric View from 
the Standard Views drop down menu in 
the View bar.

Lets see when our laptop looks like rendered, 
and apply some appropriate colors

9. Click Fit to Objects in the View bar.

10. Select Open GL from the Render 
Modes drop down menu in the View bar.

As you can see the display still has several 
colors to it. If you choose can keep these 
color or you may change the color of any 
of the part of the laptop using the attributes 
palette. Remember some of these objects 
are in groups so you will need to double 
click the group first to enter the editing 
mode, and apply different colors to different 
object within the group. Once you have 
your colors set. We can 2 quick viewports

11. Go to View > Create Viewport. Click 
OK twice to close the dialogue boxes. 

12. You should one large viewport on a 
Sheet layer. This viewport is too large 
for the page boundary. So with the 
viewport selected, change the scale 
drop down menu in the Object Info 
palette to 1:4

13. Then position the viewport so that it sits 
within the page boundary in the top half 
of the page.

14. Now lets duplicate this viewport. Hold 
the Option key (Mac) or Alt key (Win), 
and click, and drag the current viewport 
downward, making sure its still within 
the page boundary.

15. When are happy with the placement, 
release the mouse button.

16. In the Object Info for the duplicate 
viewport change the View drop down 
menu to Left Isometric, and the 
Background Render drop down menu 
to Hidden Line.
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17. Hold the Shift key, and select both 
viewports.

18. In the Object Info palette click the 
Update button.

Here’s the final product.
Section 4
Further Exploration

Drawing Organization

Introduction
Layers, and classes provide a way to specify 
certain objects in a drawing to be members of 
a collection of related things. Once assigned, 
it’s easy to make all the members of the 
group visible, gray, or hidden in a drawing.

Layers, and classes also help make a 
complicated drawing easier to use by 
distinguishing editable objects from those 
that are either only visible or snappable.

A drawing structured with layers, and 
classes makes it easy to produce various 
views suitable for printing or review. Each 
view can refer to different combinations of 
the data model parts without the need for 
duplication. This method can also be used 
to organize the project in other ways, such 
as to assign materials for 3D representation, 
and to extract quantities from a data model.

Layers as Pieces of Paper
When creating small projects in a CAD 
system, there’s usually no need to pay 
much attention to layers, and classes 
because in a small project, you draw 
what you need, and then print it.

When transitioning from drafting on a 
board with a pencil to using a CAD system, 
some folks draw onto the screen as if it 
were an electronic piece of paper. They 

use line objects to represent the graphite 
counterparts from their real world days 
with a pencil, and a piece of vellum. One 
file produces one piece of paper.

Once they are drafting like this for awhile, 
some folks begin to store multiple drawings in 
a single project file by placing each drawing 
onto a new layer. At least initially, these folks 
might copy the parts of the drawing that repeat 
from one layer to the other to use as a base 
for the next drawing. Using this slightly more 
efficient approach, you can get more than 
one piece of paper out of a single CAD file, 
displaying one layer at a time while printing.

Systems Drafting Approach
For now, let’s think of layers as clear sheets 
of paper that can hold scaled figures. 
Sometimes folks discover that you can use 
the layer feature like the clear mylar sheets 
of Systems Drafting, which promoted the 
reuse of common elements on more than 
one drawing by separating elements that 
repeated onto separate sheets of mylar.

Some folks use layers in their CAD drawings 
as clear sheets of paper. Using this strategy, 
you can reuse certain parts of your drawing 
that appear on more than one piece of paper. 
As an example, you can create layers for 
plan elements, overhead elements, and 
walls, which appear in both. By displaying 
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the walls layer with the plan, and overhead 
elements in succession, you can represent 
two pieces of paper with these three layers.

Building on this strategy, you can structure 
files to represent the pieces of paper for 
the plan, and overhead of each floor of a 
three-level building; for example with a wall, 
plan, and overhead layer for each floor. In this 
case, you can get six pieces of paper from the 
various permutations of the nine layers used.

But wait a minute, Architectural projects 
often have fifty or more sheets! That would 
necessitate layers for HVAC, plumbing, 
electrical, fire protection, and so on. Using 
a one-dimensional structural scheme such 
as this for large scale projects could easily 
produce a list of 300 or more layers. In fact, 
some CAD systems with a one-dimensional 
layer system do just this, as you may 
have experienced if you ever imported a 
drawing generated in one of these CAD 
systems, and examined the layer list.

A Second Dimension
Enter Classes as a second dimension of 
organization. With an array of layers, and 
classes available for organizing a drawing, 
it is possible to create files equivalent to the 
organization of 300 layers with just 10 layers, 
and 30 classes. This dramatically reduces 
list management, and provides for some 
interesting additional efficiencies as well.

So, how do I decide on a scheme for 
structuring a drawing? One question I 
hear often is: Should I put this object in a 
Layer or a Class? This of course, is a trick 
question because each object in Vectorworks 
is always on a layer, and assigned to a 
class. But seriously, how do I decide on 
an organizational scheme? Well, one 

approach to use is to note that layers, and 
classes have slightly different properties.

Layer, and Class Attribute 
Differences
The feature common to both layers, and 
classes is object visibility. I can show or 
hide members of a class or layer with a 
click. I can also instantly set all members 
of any layer or class to a muted or grayed 
look. Let’s look at the other properties to 
see how layers differ from classes.

We’ve already seen that layers can be 
assigned a scale. You can’t do that with 
classes. So, if the layout of one of your 
printed sheets has figures in more than one 
scale, then you can show multiple layers, 
with each layer set to the appropriate scale. 
Layers also have a height in Z space. So, this 
suggests that layers can be a place to put 
things that all reference the same height. So 
when I set the height of a layer, the heights 
of all 3D objects on that layer are changed. 
In particular, they become an excellent way 
to represent architecture because I can 
divide it into floors or slices of Z space. 

Since layers have this physical height 
quality, you can represent a myriad of over, 
and under relationships depending on the 
complexity of your project by stacking layers 
with the top of one layer exactly matching 
the bottom of the next layer. Remember, 
though, that layer heights can be specified 
in varying degrees of overlap. In fact, 
setting layer heights, and thicknesses to 
perfectly overlap is a common approach 
to structuring special types of projects, 
such as some of those in the landscape, 
and entertainment lighting industries. 

Classes, on the other hand, don’t have this 
physical height quality among their properties, 
but it does have the ability to display all of 
its members with the same graphic property, 
such as color or line thickness. This is not 

always needed, but as the project size 
becomes larger, it becomes more useful.

Showing all members of a class in a 
particular line size or color makes it possible 
to review a drawing visually for its structure. 
For example, if I see a green door, and 
my exterior door class is supposed to 
be displaying in blue, I can recognize 
visually that it is in the wrong class.

 Putting the Differences to Use
A question that frequently comes up at this 
point is: Are classes part of a specific layer?, 
and the answer is No. While layers have a 
location in Z space, and can be considered 
a container for its members, classes are 
more like attributes that are assigned to 
each member. A class can be applied to an 
object that is in any layer. Class members 
on a layer are not visible if the layer is turned 
off, even if the class visibility is turned on.

Thus, a simple class, Door, for example, 
can apply to objects on the first floor, the 
second floor, and so on, instead of having 
to have a Door First Floor class, a Door 
Second Floor class, and so on. So, for larger 
projects, classes can differentiate among 
objects in the same layer in order to define 
the separation needed to display different 
pieces of paper referring to the same floor.

For example, in order to set up a drawing 
with a first-floor electrical plan, and a first 
floor mechanical plan, I would define a 
layer—first floor—to contain the objects, and 
one or more classes for each of the needed 
sheets electrical, and mechanical, plus one 
or more classes for the elements that are 
shared between sheets, such as the walls. 
If I need to add a floor to the package, I just 
add a layer—second floor—to the file, and 
now I have all of the structure that I need to 
produce a set of electrical, and mechanical 
sheets for the second floor as well.

Since class graphic attributes can also apply 

to the 3D representation of objects, classes 
become an efficient way to categorize objects 
in the file by material. Using this feature, 
I can define a texture to be used for each 
member of a class, for example, to represent 
the finish of all of the millwork in a project.

When structured this way, it becomes 
a simple matter to dramatically update 
the look of the 3D rendering, even late 
in the design process, by changing the 
classes’ texture attribute, and having each 
of the members reflect that change after 
updating the images with Renderworks.

Adding on—A Scaleable Approach
This scheme is scaleable to describe more 
complex models or larger projects by dividing 
the floor volumes more finely. In a larger 
architectural project, for example, each layer 
representing the space between floors could 
be broken down into Slab, Walls, and Plenum. 

This makes it possible to manage more 
types of drawings a little more easily.

Slab layers can be set up to handle space 
planning, egress plans, area calculations, 
usage analyses, and other schematic tasks.

If the size of the project warrants it, 
Plenum layers can be set up to handle 
drawings such as mechanical plans, 
lighting plans, fire protection plans, 
reflected ceiling plans, and so forth.

This can simplify the use of classes 
when used to separate project parts 
in a large drawing package.

How to Develop Standards
Review existing standards
The problem of drawing organization has been 
addressed in countless ways. Find out how 
others have approached this problem. There 
are a number of resources, and links provided 
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in the Review the published standards, such 
as the AIA CAD layer guidelines to see how 
they might be adapted to your needs.

Conduct a needs analysis

• Determine what features you need 

• Characterize the nature 
of your projects...

• Draft!

It may be that the easiest way for you to begin 
this process is to open up a blank document 

with Design layer 1, and class None, and 
start drafting. Once you run into the need 
for separation, add layers, and classes 
as you go. After the project is complete, 
there will be a valuable set of layers, and 
classes with which to start other projects.

This initial standard should be considered 
a work in progress in that regular 
review, and use of the template will 
improve over time, and in time, will 
become a perfectly tailored solution that 
represents all needed presentation, and 
is adaptable, and flexible for the future.

Creating Layouts with Sheet Layer Viewports

Introduction
One of the main purposes of drafting is 
to provide a way to describe a design 
to someone, who is not familiar with the 
project. With a 3D project, such as an 
architectural building, a landscape, or a 
scenic design, several views are necessary 
to adequately describe the project on 
a flat piece of paper. These views may 
include different types of plans, elevations, 
isometric views, and enlarged details.

When drafting was done with pencil, and 
paper, the required views meant that a 
completely independent drawing had to be 
developed for each of the views. Each view 
was, in essence, a duplication of some part of 
model. Anytime that a change was introduced, 
each of the affected views had to be corrected 
to accommodate the change. Correcting the 
same part of the model in multiple views is 
more work than changing the model once. 
Also, the possibility of coordination errors 
is present each time duplicated information 
has to be corrected. One of the reasons that 
drafting systems were developed was to 
reduce the amount of duplication that these 
traditional drafting techniques required.

Drafting with a computer makes it possible 
to describe a design once as a model, and 
project the information in various ways using 
the processing power of the machine to 
compute each view from the single model. 
Computers also build on this capability by 
providing efficient ways of organizing the 
model such as with layers, and classes. 
This brings us to the need for Sheet Layer 
Viewports, which are a way to present multiple 
views simultaneously as they are needed on 
a sheet of paper, ready to send to the printer.

What is a Viewport?
A viewport is an object that can present 
various views, and information on Sheet 
layers from a model on Design layers.

What are the benefits of Sheet 
Layer Viewports?
Sheet Layer Viewports allow us to 
create presentations that were difficult 
or impossible to create previously.

For example, two side-by-side views of a 
floorplan, and reflected ceiling plan almost 
certainly required duplication of objects.

Using Sheet Layer Viewports, it is possible 

to combine multiple views of the design, 
at different scales, different orientations, 
and with different graphical looks.

Viewports increase drawing 
efficiency, and reduce errors.

They are the perfect illustration of one of the 
basic rules of CAD, which is “draw it once.” 
Instead of creating an unconnected drawing 
for every view of the design, Sheet Layer 
Viewports allow us to project information from 
a single model in many different ways., and, 
because Viewports are dynamic projections, 
any changes that we make to the model are 
applied to all the Sheet Layer Viewports.

The provide a simplified drawing structure. 
Sheet Layer Viewports can be embellished 
with annotations that are specific to the 
viewport. Without this method, information 
that is used only once in a viewport would 
have to be added to a Design Layer, and 
would have to be structured with additional 
classes to keep the information needed 
in each Viewport separately visible.

They provide a consistent place 
to manage your output
Sheet Layer Viewports, and Sheet 
Layers simplify the drafting task by 
providing a consistent organization for 
storing, and managing printed sheets. 
They also make it much easier for the 
software to provide features like the 
issue manager, and to batch print. 

They provide better DWG compatibility
With Sheet Layer Viewports, and Sheet 
Layers, Vectorworks has an organization 

schema that maps well to AutoCAD’s 
model/paper space. The result is much 
better compatibility with AutoCAD.

Viewport Requirements
In order to use Sheet Layer Viewports 
effectively, the file must be organized so 
that the project’s parts can be displayed 
independantly from one another. This means 
projects should be built using layers, and 
classes to locate, and categorize parts of 
the model so that they can be displayed 
in all of the ways that are needed to 
produce the various required views.

To make the most use of the viewport 
feature, files should be modeled 
using 3D or hybrid objects.

Sheet Layer Viewports can still be used 
in files that have not been set up in this 
way, but some features demonstrated 
here might not be available.

Viewport Details
Sheet Layer Viewports reside exclusively on 
Sheet Layers, which are a new type of layer 
created to be a repository for Sheet Layer 
Viewports. Multiple Sheet Layer Viewports 
can reside on one sheet layer, and multiple 
sheet layers can be created in any file. So 
a single file can have enough sheets to 
produce an entire set of drawing plans.

Sheet Layer Viewports can display each 
of the required views of a project without 
duplicating the model. If the model 
changes, the Sheet Layer Viewports can 
be updated easily to reflect the changes.
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Managing Drawing Resources

Basic Concepts of Resources, and 
the Browser
To increase efficiency, you can import re-
sources into a file when it is first created. 
This increases efficiency because the 
resources are available for later use.
 
Instances, and Definitions
There are two parts to most resources, the 
definition, which is imported from file to 
file, and the instance, which is a reference 
to the definition, that is usually a part of the 
active file but also refers to a resource that is 
workgroup referenced from a different file.

Two Main Parts to the Resource Browser
The two main parts of the Resource Browser 
are (1) the part associated with the files, 
and folders functionality, and (2) the part 
associated with the resources functionality.

In the top part of the Resource 
Browser there are two labels 
corresponding to these two parts. 

The Files, and Folders menu is used 
for navigation, and the Resources 
menu is used for viewing.

The Browser is a two-way concept. It 
imports from, and exports to library files.

Using the Resource Browser
Open the Formatting Worksheets 
file. The Resource Browser opens 
wide to show resources.

The Resource Browser brings with it 
the concept of Favorites, which are 
designated files also known as Libraries, 

which contain resources. These resources 
are available to any active file.

The top drop-down menu shows open 
files above the divider in a list, and below 
the divider are the designated favorites.

Select one of these files to make it current.

The second popup shows the 
hierarchy of resources within the 
current favorite or open file.

To quickly access a resource, click 
in the resource display window, and 
begin typing the resource’s name. The 
resource display window scrolls to the 
first resource using the letters entered.

The currently active symbol is identified at 
the bottom of the Resource Browser. Be 
aware that the symbol highlighted in the 
window may not be the active symbol.

To make sure the selected resource 
activates double-click the Resource or 
right click, and select Make Active.

Once active, depending upon resource 
type, the resource can be inserted into an 
object or anywhere else in the drawing.

Resources can also be inserted without 
being the active resource. Simply click, and 
drag the resource to its desired location.

Editing Resource Definitions
Resources must be imported into the 
current document in order to be edited.

Once you have done so in the current 
document, right click the Resource, and select 
Edit. An Edit dialog will populate depending 
upon which resource type is selected.

Mapping Instances
Select the object(s) to texture. If more 
than one object is selected, only the 
texture resource can be selected. 
Mapping parameters can only be set 
for individually selected objects.

From the Render tab, select the desired 
Texture from either the default resources 
or the current file’s resources, and then set 
the texture parameters, which apply only to 
the selected object. Because Object Info 
palette changes apply only to the selected 
object, one texture can be applied with 
different parameters to many objects.

 Instances may also be mapped by 
simply clicking, and dragging the desired 
instance onto the appropriate object, 
and then making changes to mapping 
parameters as necessary through the 
Render tab in the Object Info palette.

Additionally, instances can be mapped by 
selecting the appropriate object(s), and 
right-clicking the desired resource, and 
selecting apply. Again changes can be made 
via the Object Info palette as desired.

The basic mapping parameters display in the 
Object Info palette. Click Mapping to access 
advanced mapping items, and dialog box. 

Once a record format has been created, it 
can be attached to any object or symbol in the 
same drawing file as the record format. The 
Data tab of the Object Info palette indicates 
all record formats currently available to attach.

Methods
Attach a record format to a single symbol 
instance or to an object in the drawing without 
affecting previous or future instances.

With the desired object selected, click the 
Data tab from the Object Info palette. The 
Object Info palette lists all record formats 
in the drawing. Place an X in the desired 
record format box to attach the record.

The record can also be applied by 
selecting the desired objects, and then 
from the Resource Browser selecting 
the record format to be applied. From 
the context menu, select Apply.

Alternatively, double-click the record 
format resource to apply it to the 
selection or drag the record format 
resource onto a symbol or object.

Attaches a record format to a symbol 
definition that applies to each symbol 
added to the drawing afterwards. 
Existing instances remain unaffected.

Select a resource definition, and 
then select Edit. Select the symbol 
component to edit, and click Edit. 

With nothing selected, click the Data 
tab in the Object Info palette. When 
no items are selected, the Data tab 
displays *SYMBOL DEFAULTS* at the 
top. Select the record to attach. Click on 
the exit symbol button when complete.

The attached record(s) is included 
with the symbol each time the symbol 
is placed in the drawing or imported 
into another drawing. Symbols already 
present in the drawing are unaffected.

.Creating a resource
Create from the resource browser
To create a new resource select New 
Resource in <current document> from the 
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can be imported from other libraries or 
documents or new resources can be created.

Once the changes are saved to the library file, 
the new resources are visible in the library.

Default content system
The more commonly used resources are 
available at the point of use while drawing, 
without having to first add them to the 
current file through the Resource Browser.

Default libraries are found at: My Computer 
> Local Disk(C:) > Program Files > 
Vectorworks > Libraries > Defaults, 
and HD > Applications > Vectorworks 
> Libraries > Defaults respectively. 

The ability to use default resources is a 
preference contained on the Session tab 
of Vectorworks Preferences, and can be 
disabled if default resource use is not desired

Default resources are available from a variety 
of dialog boxes that contain parameters 
allowing resource access. They are also 
available from the Attributes, and Object 
Info palettes. Once a default resource 
is selected for use, it is automatically 
imported into the current file, and displays 
in the Resource Browser. It can then be 
shared among other drawing files.

Creating custom default content
To make a custom resource available as a 
default resource: Import custom resources 
to a default resource file, add a custom 
resource file to a default resource folder, or 
create a custom resource file, and place an 
alias of (Macintosh) or shortcut to (Windows) 
that file in a default resource folder.

Resources menu, or right-click in the Resource 
browser window to access the same menu.

Select the Resource type to make 
from the list, and the resource-type 
specific dialog box will open. 

Once created, the resource appears 
in the Resource Browser.

For quick resource creation, right-click 
in an area of the Resource Browser that 
is associated with an existing resource 
type. The context menu contains an 
additional option for quickly creating 
another resource of the same type.

Symbols must be created by using the Modify 
> Create Symbol command with the desired 
object to be created into a symbol selected.

The Create Symbol command creates 
symbols from 2D, and/or 3D objects, 
including text. Symbols can also be 
created from other symbols, from plug-
in objects, groups, and worksheets..

Special Cases
Hybrid symbols
A hybrid symbol contains both a 2D 
object, and a 3D component, and displays 
correctly according to the view.

To create a hybrid symbol, select both the 
2D, and 3D objects. In Top/Plan view, align 
the objects first, and then select Modify > 
Create Symbol. The resulting symbols will 
be displayed in the Resource Browser.

Red symbols
A red symbol when placed is converted 
into a plug-in object. It has a specific 
insertion behavior, and set parameters, 
and it can be modified, with many 
variations of the same object in the file.

At symbol creation, select Convert 
to Plug-in Object in the insertion 
options to specify a red symbol.

Changes to a red symbol definition affect 
future instances, but not existing ones.

Blue Symbols
A blue symbol when placed is 
converted into a group.

Any changes made to the symbol definition 
later have no effect on the group.

At symbol creation, select Convert 
to Group in the insertion options 
to specify a blue symbol.

Green Symbols
Green symbols are designated as Page 
Scale when created. They display, and print 
the same size no matter the scale of the 
layer. They are used primarily to maintain 
consistency of page graphics such as 
drawing labels across the entire project.

Managing Resources
Getting resources into the active file
To move resources into the active 
file, right-click on the resource from 
the library file, and select Import.

Resources are also added to the active 
document as they are used in the document.

Getting resources into libraries
To add resources to a specific library, 
select the desired library to add the 
resource to from the Top drop-down 
menu. Select Open current favorite 
from the Files, and Folders menu.

Once the desired library file is open, resources 
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Section 5
Glossary 

Glossary

Planes
Any surface defined by any three points. In 
Vectorworks, plane is the term used to identify 
the surface where 3D operations take place.

Automatic Working Plane
Attribute of 3D, and most planar creation 
tools that identifies object faces as potential 
working planes for the next drawing operation. 
As the user gestures in the document window 
with a tool selected, faces under the cursor 
highlight as alignment candidates to be 
used if the user begins the tool operation. 
Active plane must be set to Automatic. 

Container Objects
Hybrid (adj.)
Capability of certain objects to provide 
a distinct plan view graphic when the 
projection is Top/Plan. This allows, for 
example, a schematic representation of 
a door with the symbolic door swing arc 
graphic when displayed in plan view. A 
concept in Vectorworks in which objects 
have 2D, and 3D parts so that the same 
object can have a look in a 2D plan view 
that is different from it’s look in 3D views.

Resource
A structured drawing component in the active 

file or in a library, which provides consistency 
across projects, and individual users as 
well as within large multiple-file projects. 
Resources provide a means of sharing 
objects to multiple members of a workgroup. 

A shareable drawing component that can be 
imported to the active file with the Resource 
Browser from any Vectorworks file created 
with the same version. Resources can only 
be edited if they are part of the active file. 
Some resources specify actual objects, such 
as a symbol resource. Other resources are 
essentially attributes that define properties 
objects, such as hatch resources. Still 
other resources are a series of settings that 
can save time, and enable consistency.

Resource Browser
The central repository for all Vectorworks 
resources. It is a window into the resources 
in the active file, and any other Vectorworks 
files on a computer or network. 

Sheet Layer Viewports
An object that can calculate various views 
of a model, by using layer, and class 
visibilities, projection, rendering, scale, and 
orientation parameters. Viewports are ideal 
for creating presentations from your model.
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Viewport Annotations
Any viewport specific embellishment that is 
added to a special group within the Viewport. 
This can be notes, and dimensions specific 
to the Viewport, as well as graphic objects to 
clarify or correct the Viewport calculation.

Design Layer
A place to draw the model. Design Layers 
have height, thickness, and scale among 
their most important attributes. Multiple 
Design Layers are often used in the 
development of the project model.

Sheet Layer
Sheet Layers make it easy to create 
printable plates that make up a hardcopy 
project package. They are the place to put 
Sheet Layer Viewports along with pasted 
graphics, and Title Blocks in Vectorworks. 
Sheet Layers have an independent origin, an 
assignable resolution, and printer definition. 
Sheet Layers always display, and print in 
a scale of 1:1. The Sheet Layer Viewports 
residing on Sheet Layers each have their own 
independent scale, and other parameters. 

Project
The design that you are developing, and 
documenting in Vectorworks. Anything 
that you are designing or drafting.

Model
n. All of the information you need to describe 
your project. v. The process of building a 
digital representation of your project that 
efficiently documents all aspects of your 
project, and quickly gives you flexibility, and 
accuracy across the entire timeline. The 
guiding principal for constructing a well-formed 
model is to use structures that ensure there 
are no duplications of model components 
or assemblies at any level. Vectorworks 
uses Stories, Design Layers, Sheet Layers, 

Classes, Viewports, and References at the 
conceptual level to organize the model. 

The collection of objects, geometry, text, 
and other elements that make up a project. 
Generally, the preliminary purpose of the 
model is to eliminate duplications. When 
there are repeating elements in a project, the 
repeating elements are defined as instances, 
which reference a single element definition.

Presentation
The collective calculations of the model, 
created either with the aid of a computer or 
otherwise that, with value added clarifications, 
comprise the contracted specified deliverables 
among the project stakeholders. In 
Vectorworks, the presentation is made up of 
annotated Viewports on Sheet Layers. Lists, 
tables, and catalogs of parts, pieces, takeoffs, 
and details are similarly calculated from the 
model, and verified expert review. The model 
itself is not the presentation, although each 
of the stakeholders in a project readily share 
their parts of the model as a means of in-
progress communication, and documentation. 
The presentation can resemble traditional 
plates in a drawing package, or may adhere 
to another standard as specified by the client.
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