Vectorworks 2011
Your Guide to What’s New

Cover imagery courtesy of (left to right) © DECC S.C. Project by Legoretta + Legoretta; DATENLAND, Erik Recke, www.datenland.de; Modo Forma; Jim Woodward of Exhibit Logic LLC; © Michael Schanné, www.av1architekten.de
Vectorworks is a registered trademark of Nemetschek Vectorworks, Inc. in the U.S. and other countries. Windows is a registered trademark of Microsoft Corporation in the U.S. and other countries. Macintosh is a trademark of Apple Computer, Inc., registered in the U.S. and other countries. Adobe, Acrobat and Reader are registered trademarks of Adobe Systems in the U.S. and other countries.

The information in this book is distributed on an “as is” basis, without warranty. While every precaution has been taken in the preparation of this book, neither the author nor Nemetschek Vectorworks, Inc. shall have any liability to any person or entity with respect to any loss or damage caused or alleged to be caused directly or indirectly by the information contained in this book or by the computer software described in it.

For more Vectorworks training information, or to purchase more copies of this book, please visit www.Vectorworks.net/training or call us at (410) 290-5114.
# Table of Contents

## Introduction

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Make 3D as Easy as 2D</td>
<td>7</td>
</tr>
<tr>
<td>1.01 Improved 3D Environment</td>
<td>8</td>
</tr>
<tr>
<td>1.02 Push/Pull Tool</td>
<td>9</td>
</tr>
<tr>
<td>1.03 Extract Planar Objects</td>
<td>10</td>
</tr>
<tr>
<td>1.04 Improved Face Selection Feedback</td>
<td>11</td>
</tr>
<tr>
<td>1.05 SmartCursor™ Relative Angles</td>
<td>11</td>
</tr>
<tr>
<td>1.06 New Snap Settings</td>
<td>11</td>
</tr>
<tr>
<td>1.07 Back Face Selection Control</td>
<td>12</td>
</tr>
<tr>
<td>1.08 Extrude Along Path Improvements</td>
<td>13</td>
</tr>
<tr>
<td>2. Architect: Do BIM Better</td>
<td>14</td>
</tr>
<tr>
<td>2.01 Improved Space Object</td>
<td>14</td>
</tr>
<tr>
<td>2.02 New Slab Tool</td>
<td>15</td>
</tr>
<tr>
<td>2.03 New 3D Wall Components</td>
<td>17</td>
</tr>
<tr>
<td>2.04 Wall End Caps</td>
<td>19</td>
</tr>
<tr>
<td>2.05 Design Layer Section Viewport</td>
<td>20</td>
</tr>
<tr>
<td>2.06 Open Database Connectivity (ODBC)</td>
<td>21</td>
</tr>
<tr>
<td>2.07 Multi-File Batch Print</td>
<td>23</td>
</tr>
<tr>
<td>2.08 Improved Window and Door Settings</td>
<td>24</td>
</tr>
<tr>
<td>2.09 Create Wall Using Core Component for the Control Line</td>
<td>24</td>
</tr>
<tr>
<td>2.10 IFC Support Improvements</td>
<td>24</td>
</tr>
<tr>
<td>2.11 Improved Stairs</td>
<td>25</td>
</tr>
<tr>
<td>2.12 Connect Roof Faces</td>
<td>26</td>
</tr>
<tr>
<td>2.13 Style Class Removal</td>
<td>27</td>
</tr>
<tr>
<td>3. Exceptional Text Features</td>
<td>28</td>
</tr>
<tr>
<td>3.01 “Perfect Preview” Text Editing</td>
<td>28</td>
</tr>
<tr>
<td>3.02 Text Styles</td>
<td>28</td>
</tr>
<tr>
<td>3.03 Improved Text</td>
<td>29</td>
</tr>
<tr>
<td>3.04 Viewport Text Scale Support</td>
<td>30</td>
</tr>
<tr>
<td>4. Tap into Power Tools</td>
<td>31</td>
</tr>
<tr>
<td>4.01 New Scalable Symbols</td>
<td>31</td>
</tr>
<tr>
<td>4.02 New Tile Fills for 2D Objects</td>
<td>32</td>
</tr>
<tr>
<td>4.03 Quick Prefs</td>
<td>33</td>
</tr>
<tr>
<td>4.04 New Select Connected Objects Command</td>
<td>33</td>
</tr>
</tbody>
</table>

---

Vectorworks 2011 Version 3
4.05 General Dimension Improvements .......................................................... 34
4.06 Improved Dimension Leader Line.......................................................... 34
4.07 Saved Settings for the Eyedropper Tool .................................................. 34
4.08 Line from Center Mode........................................................................ 35
4.09 New Even Divide Command................................................................. 35
4.10 New Create Dividing Lines Command.................................................... 35
4.11 Scaled Line Creation .......................................................................... 36
4.12 New Triangle Tool .............................................................................. 36
4.13 New Roof Slope Preference................................................................... 36
4.14 Saving Render Settings in Saved Views .................................................. 37
4.15 Improved Witness Line Length Control.................................................. 37
4.16 Improved Nudge for Objects in Walls .................................................... 37
4.17 Offset Group Improvements.................................................................... 38
4.18 Rename Referenced Resources .............................................................. 38
4.19 New Option to Replace Existing Classes During Class Import .............. 39
4.20 Thousands Separators in Dimension Text ............................................ 39
4.21 Number-Aware String Sorting............................................................... 39
4.22 New Worksheet Inquiry Functions........................................................ 40
4.23 Improved Mirror Tool for Objects in Walls .......................................... 40
4.24 Resource Browser Library Access Improvements .................................. 40
4.25 Disassociate Dimensions Context Menu Command ............................ 41
4.26 Delete Symbol Completely .................................................................. 41
4.27 Prevent In Place Duplications ............................................................... 41
4.28 Closed Checkbox for Polylines .............................................................. 42
4.29 New Adjust Flipped Text Document Preference ..................................... 42
4.30 Double Line Marker .......................................................................... 42
4.31 Improve Section Line Instances Dialog ............................................... 42

5. Simplify File Exchange ............................................................................. 43
   5.01 Improved File Sizes ......................................................................... 43
   5.02 Improved Support of Hatches ........................................................... 43
   5.03 Improved Export of Planar Objects ................................................... 43
   5.04 DXF/DWG Export of Design Layer Viewports ................................ 43
   5.05 Import/Export Support for Arc Length Dimensions ........................ 44
   5.06 ISO Dash Styles ............................................................................ 44

6. Landmark .................................................................................................. 45
   6.01 New Retaining Wall Site Modifier .................................................... 45
6.02 New Existing Tree Tool .......................................................... 46
6.03 New Grade Tool .................................................................... 48
6.04 New Create Stepped Wall Command .................................... 49
6.05 New Stake Object from 3D Locus Command ...................... 50
6.06 Site Model Image Mapping .................................................. 50
6.07 Improved Site Model Grade Display .................................... 51
6.08 New Cut and Fill Site Model Display ................................. 51
6.09 Improved 2D Site Model Plans ............................................ 52
6.10 Improved Site Model Update ............................................... 52
6.11 New Site Model Volume List ................................................. 53
6.12 Hardscape Component Classing ......................................... 53
6.13 Improved Hardscape Settings ............................................. 54
6.14 New Apply Saved Hardscapes to Existing Hardscapes ....... 54
6.15 Improved Display of Site Modifiers in 3D ......................... 55

7. Spotlight .................................................................................. 56
7.01 Better Focus Point Support for Lighting Instruments ........ 56
7.02 Lightwright Data Exchange Improvements .................... 57
7.03 Ganging Tool Preference Dialog Box ................................. 57
7.04 Automatic Position Sensing Preferences ......................... 57
7.05 New Options for Seating Layout ....................................... 58
7.06 New Default Event Seating Content ................................. 58
7.07 Improved Focus Point Object Graphics ............................ 58

8. Renderworks .......................................................................... 59
8.01 New Renderworks with Cinema 4D Engine ...................... 59
8.02 Linking Camera and Viewports ........................................ 59
8.03 Attribute Mapping Tool Improvements ............................ 61

Additional Training Materials .................................................. 62
Introduction

Vectorworks 2011 new features are presented in the following sections:

- Make 3D as Easy as 2D (pg 7)
- Architect: Do BIM Better (pg 14)
- Exceptional Text Features (pg 28)
- Tap into Power Tools (pg 31)
- Simplify File Exchange (pg 43)
- Landmark (pg 45)
- Spotlight (pg 56)
- Renderworks (pg 59)
- Additional Training Materials (pg 62)

1. Make 3D as Easy as 2D

Vectorworks 2011 further consolidates the 2D and 3D drawing environments with the following enhancements:

- You can now use more tools and commands to intuitively create and edit 2D objects—which now retain most of their display attributes—in any view or orientation.
- New direct modeling capabilities let you quickly create 3D objects directly from 2D planar objects, and you can now extract 2D planar objects from planar faces of 3D objects.
- Snapping improvements and better methods for selecting 3D faces let you draw faster and more accurately.
1.01 Improved 3D Environment

Product: Fundamentals

In Vectorworks 2011, drawing, modeling, and navigation operations are much more intuitive and fluid in the 3D environment, which now integrates the look and feel of Vectorworks’ 2D environment.

Key new features of Vectorworks’ 3D environment are summarized as follows:

• 2D planar objects now retain most of their display attributes in any view or orientation. Also, new options for wireframe render mode let you optimize planar fill and text display in 3D and perspective views.

• Top/Plan view is no longer mandatory for many tools; you can now use common 2D and 3D tools to interactively create and edit all planar 2D and 3D objects (and profiles of 3D objects) in context of each other, in any view and on any working plane.

• 2D objects now temporarily display their creation (or working) plane during resizing and rotation operations. Also, you can now double-click a 2D object (including planar dimensions) to activate its creation plane.

• You can now change the active plane at any time from the View bar’s Active Plane drop-down list, and you can now move the currently selected object(s) to any plane: layer, screen, or working plane—depending on the current plane and the object’s (s’) creation plane(s).

• There is now only one Selection Tool and one Symbol Insertion tool; both of these tools now switch 2D and 3D modes based on the active view (Selection Tool) or symbol content (Symbol Insertion tool). Also, you can now insert a 2D (planar) symbol on any active plane.

• Standard views (such as Top, Front, Right, and others) are now either based on global coordinates (as before) when Active Layer Plane Mode is enabled in the View bar, or on working plane coordinates (new) when Working Plane Mode is enabled in the View bar.

Note: See also Push/Pull Tool (pg 9).

Animation

Click here to view an animation of these features.

Access

(Multiple tools, commands, editing modes, and view controls)

Tips and Considerations

Keep in mind the following tips and considerations when using 3D object creation tools and navigation controls:

• Click 2D objects once to display their reshape handles without activating their creation plane. When you double-click a 2D object, its creation plane will stay active after the editing operation(s). You can quickly activate another working plane from the View bar’s Active Plane drop-down list or by double-clicking another object.

• Click any working plane axis to activate the working plane manipulator. You can then move the working plane or change its orientation. Press the Esc key to turn off the working plane manipulator. Note that moving or re-orienting the working plane won’t affect the position or orientation of objects that were created on it; their creation plane is persistent.

• In the Working Planes palette, if you name working planes (by clicking the Add button), they are displayed in the Active Plane
drop-down list in the View bar. When any named or unnamed working plane is active, you can “move” 2D objects to it. To do this, select the 2D object(s), and then select Working Plane from the Object Info palette’s Plane drop-down list.

- To see 2D object fills in Wireframe rendering mode, enable the Show fills in planar objects in 3D views option—and adjust the Fill Opacity percentage as necessary—in the Wireframe Options dialog box (accessed from the View > Rendering > Wireframe Options or Current Render Mode menus).
- To see 2D object fills in OpenGL rendering mode, enable the Use Planar Attributes option in the OpenGL Options dialog box (accessed from the View > Rendering > OpenGL Options or Current Render Mode menus).
- When you edit the 2D component of legacy hybrid symbols, make sure that Screen Plane is selected for the Plane property of all added 2D objects to ensure proper display.

1.02 Push/Pull Tool

Product: Fundamentals

The Protrusion/Cutout tool has been renamed Push/Pull. It is now easier to use and adds the following direct modeling enhancements:

- You can now push or pull 2D planar objects to directly extrude them normal to their plane.
- Instead of selecting edges, you can now select faces (or back faces).
- Push and pull operations now result in more useful types of 3D objects; generic solids are now only created under certain conditions when Move Face Mode or Sub-Face Mode is active.
- The Complete, Add, and Subtract modes have been removed, as they are now implied by mouse movements or selection improvements.

New behaviors for the tool’s three modes are summarized as follows:

- **Extrude Face Mode** now also works with 2D planar objects and converts NURBS curves into tapered extrusions (instead of surfaces). Also, when you push or pull an extrusion’s top or bottom face, only the extrusion’s length is now changed (it is no longer converted to a solid addition or subtraction). Note that if you push or pull the side faces of an extrusion, the extrusion is changed to a solid addition or subtraction (as in previous versions).
- **Move Face Mode** now dynamically highlights the planar face to be edited.
- **Sub-Face Mode** (previously named Extrude Curve mode in earlier versions) now recognizes planar geometry as well as NURBS curves and now dynamically highlights regions defined by the planar geometry and the solid body.

*Note: See also Improved 3D Environment (pg 8).*

Animation

Click here to view an animation of these features.

Access

3D Modeling tool set: Push/Pull (or press Shift+R).
1.03 Extract Planar Objects

Product: Fundamentals

Vectorworks 2011 adds a new preference option for the Extract tool’s Extract Surface Mode that lets you create new 2D planar objects (polygons or polylines) by selecting planar faces of existing 3D objects.

Some examples of the many uses for extracted planar objects include:

- Creating custom details.
- Displaying hatch and tile fill styles—specified in the Attributes palette—in 3D views.
- Creating temporary polygons and polylines to quickly find the perimeter and/or surface area—displayed in the Shape tab of the Object Info palette—of a model face or straight wall segment.
- Permanently or temporarily hiding objects or edges behind a face in Wireframe view mode.
- Creating source objects that you can then use (as-extracted or modified) as the basis for creating other new objects, or for modifying existing objects.

Animation

Click here to view an animation of these features.

Access

You can toggle the new Create Planar Objects option in the Extract Preferences dialog box:

3D Modeling tool set: Extract (or press Shift+L). In the Tool bar, enable Extract Surface Mode, and then click Extract Preferences.

Tips and Considerations

Keep in mind the following tips and considerations when using extracted planar objects in your models:

- To see 2D object fills in Wireframe rendering mode, enable the Show fills in planar objects in 3D views option—and adjust the Fill Opacity percentage as necessary—in the Wireframe Options dialog box (accessed from the View > Rendering > Wireframe Options or Current Render Mode menus).
- To see 2D object fills in OpenGL rendering mode, enable the Use Planar Attributes option in the OpenGL Options dialog box (accessed from the View > Rendering > OpenGL Options or Current Render Mode menus).
- You can double-click a planar face to activate its working plane. You can then use other 2D drawing tools to draw coplanar objects.
- You can use the Push/Pull tool to dynamically extrude planar objects.
1.04 Improved Face Selection Feedback
Product: Fundamentals
Vectorworks 2011 removes the previous versions' limitation of selecting faces by their edges. You can now click anywhere on a 3D face to select it, which makes the face selection process more intuitive and accurate. You can confidently verify pre-selected or selected faces because the entire face is now highlighted (instead of just edges) for the following tools:

- Shell Solid tool
- Fillet Edge tool (when the Select Faces preference option is enabled)
- Chamfer Edge tool (when the Select Faces preference option is enabled)
- Extract tool (when Extract Iso-parametric Curve Mode or Extract Surface Mode is enabled, and you can now extract iso-parametric curves at any point on a 3D face)
- Push/Pull tool

Note: See also Back Face Selection Control (pg 12).

Access
3D Modeling tool set: (Multiple tools and editing modes).

1.05 SmartCursor™ Relative Angles
Product: Fundamentals
Vectorworks 2011 adds the new Angles relative to prior segment preference that enables or disables (default) angle snapping measured from the last segment drawn of a multi-segment object—such as a polygon or polyline—by the angle value(s) specified.

Access
You can toggle or specify angles for the new Angles relative to prior segment preference option in the SmartCursor Settings dialog box's Angle category:

Menu: Tools > SmartCursor Settings—or press Ctrl+8 (Windows), Cmd+8 (Macintosh)—and then select the Angle category. You can also toggle this option by pressing the forward slash hotkey (/).

1.06 New Snap Settings
Product: Fundamentals
New snap settings for Vectorworks 2011 are summarized as follows:

- Suspend Snapping hotkey: You can now temporarily disable all snaps—while preserving snap preference settings—by holding down the backquote key (`).
- Snap to Combined Page Area preference: Enables (default) or disables snapping to the rectangle surrounding all of the pages.
- Snap to Individual Pages preference: Enables or disables (default) snapping to the boundaries of each page.
- Angles From Axes preference: Enables (default) or disables snapping to the angle value(s) specified in the adjacent field.
• **Alternate Coordinate System at angle** preference: Enables or disables (default) four angle snaps offset from X, Y axes by the positive or negative angle value specified in the adjacent field.

• **Snap to line between Smart Points** preference: Enables (default) or disables the snap line displayed between two Smart Points when you move the cursor’s snap box anywhere directly between two Smart Points.

• **Suppress extensions from nearby Smart Points** preference: Suppresses (default) or allows extensions from Smart Points inside the current snap radius.

**Access**

You can modify the **Suspend Snapping** hotkey in the Workspace Editor Keys tab:

Menu: **Tools > Workspaces > Workspace Editor**.

You can toggle the new snap settings in the General, Angle (where you can also specify angle values), and Smart Point categories in the SmartCursor Settings dialog box:

Menu: **Tools > SmartCursor Settings**—or press Ctrl+8 (Windows), Cmd+8 (Macintosh).

**Tips and Considerations**

Keep in mind the following tips and considerations when using the new snap settings:

• While you hold down the backquote key (‘) to suspend snaps, you can still use the Shift key to constrain cursor angles.

1.07 Back Face Selection Control

**Product: Fundamentals**

Vectorworks 2011 now lets you quickly select back faces of 3D objects by pressing the Alt key (Windows) or Option key (Macintosh) for the following tools:

• **Shell Solid** tool (when the **Select Faces** preference option is enabled)

• **Fillet Edge** tool (when the **Select Faces** preference option is enabled)

• **Chamfer Edge** tool (when the **Select Faces** preference option is enabled)

• **Extract** tool (when **Extract Iso-parametric Curve Mode** or **Extract Surface Mode** is enabled)

• **Push/Pull** tool

*Note: See also *Improved Face Selection Feedback* (pg 11).*

**Access**

3D Modeling tool set: (Multiple tools and editing modes) When selecting faces, hold down the Alt key (Windows) or Option key (Macintosh), and then move the cursor slightly to select the back face.
1.08 Extrude Along Path Improvements

Product: Fundamentals

Vectorworks 2011 adds the following improvements for the Extrude Along Path command:

- A new Fix Profile option in the Extrude Along Path dialog box, when enabled, maintains the profile's position and orientation relative to the path, preventing translation and/or rotation of the profile during the extrude along path operation.
- You can now easily and accurately draw the profile in context of the path's curve and/or adjacent objects. To create a working plane perpendicular to the path's curve (normal to the curve tangent, with its origin directly on the curve), activate the Set Working Plane tool’s Planar Face Mode, and then click either end of the curve or any point on the curve. You can then draw the profile on the resultant working plane. In some cases, you may need to enable the Fix Profile option to achieve the desired extrude along path object.

Note: See also Improved 3D Environment (pg 8).

Access

Menu: Model > Extrude Along Path—or press Ctrl+Alt+X (Windows), Cmd+Option+X (Macintosh).

3D Modeling tool set: Set Working Plane (or press Shift+1), and then click Planar Face Mode in the Tool bar.
2. Architect: Do BIM Better

Vectorworks Architect 2011 makes BIM more accessible and introduces new state-of-the-art capabilities with the following design and documentation enhancements:

• Space objects are now more flexible and easier to create and customize with symbol-based tags, auto-numbering (with formulas, styles, and validation), extensive display and boundary controls, and new user-defined and IFC additional data fields.

• New slab objects, 3D wall components, and wall end caps interact intelligently with each other, enabling partial-height wall elements and structurally correct intersections at wall tops and bottoms that conform to standard graphical conventions and yield accurate material and cost reports.

• Section viewports can now be created on design layers to show live cutaway model views from any angle or to share 2D section geometry via referencing or exporting/importing.

• Data sharing improvements now provide full connectivity with ODBC databases, and increase interoperability with other IFC-enabled products.

• Batch printing now works across multiple files.

• Simplified window, door, and stair interfaces, plus more configuration and display options for stair objects.

• Roof face objects can now be connected, enabling quick and accurate creation of complex and irregular roof shapes.

2.01 Improved Space Object

Product: Architect

Vectorworks Architect 2011 significantly enhances space object flexibility and BIM intelligence with extensive new configuration, display, and data options.

Key improvements for space objects are summarized as follows:

• The redesigned user interface is now easier to navigate, streamlines the process of configuring space objects, and lets you choose which property controls are displayed in the Object Info palette.

• Graphic tags are now symbol-based. You can choose from a variety of standard tag symbols, or create your own custom tag symbols.

• Area boundary definitions and calculations are now much more flexible and compliant.

• You can now configure and create space numbers easily, based on formulas.

• The new versatile and simple auto-numbering system speeds up the process of creating space objects and reduces errors.

• You can now define your own attributes for all space object elements.

• There are now more BIM and facility-based data fields.

• You can now add and extract information for Zones and other IFC data.

Animation

Click here to view an animation of these features.

Access

Space Planning tool set: Space.
2.02 New Slab Tool

Product: Architect

Vectorworks Architect 2011 replaces the Floor command with the versatile new Slab tool that lets you create intelligent BIM-compliant horizontal slab objects based on styles with components (similar to wall styles and components). You can draw a slab directly as a polyline or click wall segments (in a closed wall network) to specify auto-boundaries that define and control the slab’s shape. You can optionally choose wall boundary options for auto-bounded slab components that automatically adjust wall component heights and/or slab component widths to create and maintain realistic and accurate junctions where walls meet floor and ceiling slab objects.

Standard slab styles are included as default content, or you can create your own slab styles and save them as resources in the current document (or in a template or library file), so you can share them with other files and users via importing/exporting, referencing, or placing them in default content files.

The new slab object also lets you:

- Choose which slab components are affected by add shape and clip shape operations when you create projections or cut-outs.
- Create more realistic 3D views and section viewports (on sheet layers or design layers).
- Assign textures for slab parts (top, bottom, and sides), or use options to either assign textures to individual slab components, or use the class texture of the slab component's class.
- Extract BIM data from slab components or extract accurate volume and surface area data with two new inquiry functions for worksheets: ComponentArea(#) and ComponentVolume(#) (“#” is the component number).

Animation

Click here to view an animation of these features.

Access

You can create and modify slab styles in the Slab Preferences and Edit Slab Style dialog boxes.

Building Shell tool set: Slab. From the Tool bar, you can then select Picked Walls Mode and create auto-bounded slabs by picking wall segments in a closed wall network, or you can select Polyline Entry Mode and draw slabs directly with various polyline modes.

You can alternately create slab objects with the Objects from Polyline command:

Menu: Modify > Convert > Objects from Polyline

To navigate directly to a slab object's style definition, right-click the slab object and select Locate Slab Style In Resource Browser from the context menu.
Process Overview

The following steps describe the general process for creating a floor slab auto-bounded by walls:

**Note:** See all Tips and Considerations below before continuing.

You start by verifying or creating an appropriate layer structure for the floor slab.

1. From the menu, select **Tools > Organization**. In the Organization palette:
   - Select the Design Layers tab.
   - If you want to create the floor slab on a different layer than the wall layer, verify that the layer exists (if not, create it). If necessary, adjust the slab layer’s Z elevation to match the elevation of the wall layer.
   - Activate the wall layer, and then click **OK** to close the Organization dialog box.

Next, you adjust Wall tool settings, and then you draw a closed wall network.

2. From the Building Shell tool set, click **Wall** or **Round Wall**. From the Tool bar:
   - Select or create a wall style with appropriately configured height and component parameters.
   - Make sure the Auto Join Walls Quick Pref is enabled.

3. Draw a closed wall network.

Next, you specify Slab tool settings, select or create a slab style, and then create the floor slab.

4. From the Building Shell tool set, click **Slab**. From the Tool bar:
   - Enable Picked Walls Mode.
   - Select the desired default content style from the Slab Style drop-down list. If the desired style exists, select it and then go to step 6. Otherwise, select the style that most closely resembles the style you want to use.

5. From the Tool bar, click **Slab Preferences**. In the Slab Preferences dialog box:
   - Add, delete, or modify components as required (use the default content’s existing component settings as a guide when changing settings).
   - If necessary, change the Datum component (to index the vertical height of the slab).
   - Click Save Preferences as Slab Style, assign a name, and then click OK twice to save the changes and activate the new style.

6. Pick all wall segments in the closed wall network, and then click **Press to Complete Operation** from the Tool bar to create the slab object.

Next, you optionally edit the slab’s properties and shape.

7. If necessary, you can now change the slab’s:
   - Properties in the Object Info palette.
   - Stacking order (using the Send to Back command) if the slab is on the same layer as its boundary walls.
   - Shape by drawing 2D objects for creating protrusions and cutouts with the Add Surface and Clip Surface commands (specify whether to apply the add or clip shape operation(s) to the entire slab or to the component(s) you select).

Tips and Considerations

Keep in mind the following tips and considerations when using the new Slab tool:

- Slabs are always created parallel to the world XY plane, regardless of the active working plane’s orientation.
- To reap maximum accuracy and productivity benefits for slabs that relate to walls, draw wall networks with walls based on styles with components, then create auto-bounded slabs based on styles with components that have auto-bound edge offsets specified.
- Slab auto-boundaries are ignored if you create a symbol from a slab.
• A slab’s auto-boundaries will be converted to manual boundaries if wall edits cause any of the wall network’s connections to break.
• You can use Virtual walls to create a flat edge auto-boundary for multi-component slabs or to maintain auto-boundaries when walls don’t otherwise exist.
• You can use the Extract tool’s Extract Surface Mode to extract a planar surface from a slab that you can then modify (for example, by offsetting) for use as an add or clip shape to create protrusions, holes, or recesses in the slab or any component(s).
• You can perform multiple add and clip shape operations on slabs. Note that the modifications won’t move when auto-boundaries change.
• You can optionally create components of the same “materials” to control depth of protrusions or cut-outs.
• More than one slab can be associated with a wall segment; you can create multiple slabs for multiple structural components.
• As a starting point for proper display of slab components in sheet layer and design layer section viewports, adjust the section viewport’s Advanced Properties settings as follows: In the Attributes tab, enable the Separate Cross Sections and Use Attributes of Original Objects options. In the Display tab, enable the Show Wall and Slab Components and Merge Adjacent Components with Same Fill options. Note that you may need to assign or modify the fill attribute of some slab components for proper display.

2.03 New 3D Wall Components

Product: Fundamentals

Vectorworks Architect 2011 adds new properties to wall components that let you control the height of a wall style’s components individually, so you can create realistic walls and accurate junctions where walls meet floor and ceiling slab objects.

Specifically, the new wall component properties let you:

• Control heights of individual components by specifying top and bottom offsets between the wall and component.
• Choose whether individual components will follow top and/or bottom wall peaks, or if they will always be flat.
• Create more realistic section viewports (on sheet layers or design layers) through automatic adjustment of component heights according to boundary options specified for components of slabs that are auto-bound to walls.
• Continue assigning textures for wall parts (which have been expanded to now include overall, left, right, start cap, end cap, top, bottom, and holes) or use new options to either assign textures to individual wall components, or use the class texture of the wall component’s class.
• Accurately display wall components in wall features, and you can optionally specify wrap options for wall components in wall features created from 2D objects. Note that for proper 3D component display, wrapping options were removed for wall features created from 3D objects.
• Extract more accurate volume and surface area data from wall components with two new inquiry functions for worksheets: ComponentArea(#) and ComponentVolume(#) (“#” is the component number).
Animation
Click [here](#) to view an animation of these features.

Access
Building Shell tool set: **Wall** ![Image](#) (or press 9), or **Round Wall** ![Image](#) or press Alt+9 (Windows), Option+9 (Macintosh). Then in the Tool bar, select a wall style (if applicable), and then click **Wall Preferences** ![Image](#). In the Definition tab of the Wall Tool Preferences dialog box, click **New** or **Edit** in the Components section. You can then specify wall offset distances and wall peak following options for the component’s top and bottom edges.

Tips and Considerations
Keep in mind the following tips and considerations when using the new 3D wall components:

- As a general rule for proper interaction with slab objects, set the top and/or bottom heights of wall components such that they reside within the top and/or bottom vertical limits of any associated slab(s). For example, avoid conditions where first floor wall components protrude into the vertical space of the second-floor slab(s) if they’re not associated with the second-floor slab(s).

- As an example of an exception to the general rule above, the first floor walls could extend into the vertical space above the next story’s slab if only a roof was above--and there are no other walls between the first floor and roof.

- As a starting point for proper display of wall components in sheet layer and design layer section viewports, adjust the section viewport’s Advanced Properties settings as follows: In the Attributes tab, enable the Separate Cross Sections and Use Attributes of Original Objects options, and in the Display tab, enable the Show Wall and Slab Components and Merge Adjacent Components with Same Fill options. Note that you may need to assign or modify the fill attribute of some wall components for proper display.

- If you cannot move a wall object’s wall peaks with the 3D Reshape tool, edit the wall style’s component(s) and check if either or both of the **Follow Top Wall Peaks** or **Follow Bottom Wall Peaks** options are disabled. You must enable these options to move the corresponding wall peaks.
2.04 Wall End Caps

Product: Architect

Vectorworks Architect 2011 adds a new Wall End Cap tool that lets you create accurate caps on the ends of unjoined walls by wrapping components, or customizing component shapes by adding or removing geometry. The new “end cap in wall” object:

• Has an option that determines whether its outside edge is flush with the wall’s endpoint, or the entire end cap extends past the endpoint.
• Conforms to standard graphical conventions by displaying appropriate component fills and edge/joint lines in Top/Plan view and section viewports, and correct 3D geometry and textures in 3D views and render modes.
• Is fully compatible with 3D wall components.
• Increases accuracy of material and cost reports based on data extracted from wall components.

There are three primary modes for creating wall end caps:

• **Component Wrap Mode**, which works in a manner similar to the Component Join tool but in the same wall: Extends, terminates, or joins (butt or continuous) components around the wall’s end, based on which side of the components you click, and whether the components have identical definitions.

• **Add Mode**, which creates a custom shape by adding the area of a closed 2D object (that intersects the wall end) to the selected component.

• **Clip Mode**, which creates a custom shape by subtracting the area of a closed 2D object (that intersects the wall end) from the selected component.

**Access**

Building Shell tool set: Wall End Cap, and then in the Tool bar enable Component Wrap Mode and select two components, or enable Add Mode (or Clip Mode) and select a component and an intersecting 2D closed object. Select Wall End Cap Preferences to toggle the Extend Cap Past Wall Endpoint option for all subsequently created end caps.

**Tips and Considerations**

Keep in mind the following tips and considerations when using wall end caps:

• You can perform multiple wrap operations on different components in the same wall.
• You can perform multiple add and clip operations on the same component.
• Editing options are limited for wall end caps. If you need to reconfigure a wall end cap, delete it and then create a new one.
2.05 Design Layer Section Viewport

Product: Architect, Landmark, Spotlight

In Vectorworks 2011 Design Series products, you can now create section viewports directly on design layers. You can then view the section viewport from any angle.

Some of the many uses for design layer section viewports include:

- Referencing and exporting section details.
- Adjusting, in the source design layer, the section line position for a section view that ultimately will reside on a sheet layer section (instead of repeatedly switching between the viewport and design layer).
- Verifying compliance with standard design practices by comparing a design layer section viewport in the current file with the corresponding referenced section viewport detail(s) from the company standards file(s). You can also use the same method to compare section views from one area of the same building with another to ensure consistency. While comparing section views, you may find it helpful to disable the Display Objects beyond View Plane option in the Object Info palette for one or both section viewports.
- Creating cut-away views of houses or buildings.
- Displaying a part with a cut-away effect to expose other complete parts (not in the section viewport) in exploded assemblies.
- Creating special effects with combinations of multiple design layer section viewports and/or design layer viewports.

Access

Menu: View > Create Section Viewport. Select an existing design layer or create a new design layer in the Create Section Viewport dialog box’s Create on Layer drop-down list.

Tips and Considerations

Keep in mind the following tips and considerations when using design layer section viewports:

- You can not create a design layer section viewport from another design layer section viewport.
- 2D section lines and fills are displayed on the primary cut plane and (for offset sections) any other cut planes that are parallel to the primary cut plane.
- For offset sections, enable the Limited by Section Line Length option for Length Range when you first create the section viewport.
- To see section fills (including fills of 3D wall components and slab components) in Wireframe rendering mode, enable the Show fills in planar objects in 3D views option—and adjust the Fill Opacity percentage as necessary—in the Wireframe Options dialog box (accessed from the View > Rendering > Wireframe Options or Current Render Mode menus).
- To see section fills (including fills of 3D wall components and slab components) in OpenGL rendering mode, enable the Use Planar Attributes option in the OpenGL Options dialog box (accessed from the View > Rendering > OpenGL Options or Current Render Mode menus).
• Design layer section viewports do not have an annotation mode. If you need to create annotations for design layer viewports, you can either create planar annotation objects on a design layer (to reference or export the objects) and use class visibility controls, or you can create a sheet layer viewport (from a view normal to the design layer section viewport) and use the sheet layer viewport’s annotation mode.

• You may find it helpful to create and save a working plane when you need to create annotation objects on the section viewport’s design layer. To do this, activate the Set Working Plane tool’s Planar Face Mode and then define a working plane on the section plane. You can then save the working plane for subsequent edits or click Look At Working Plane to quickly set the view normal to the section viewport. See also Improved 3D Environment (pg 8).

• You cannot create a symbol from a design layer section viewport.

2.06 Open Database Connectivity (ODBC)

Product: Architect, Landmark, Spotlight

You can now create dynamic data exchanges between Vectorworks and other applications. New database options let you connect data in Vectorworks record fields with data from external databases using an external ODBC database management system. You can choose to limit read and write access, or enable full bi-directional associativity (update a Vectorworks record field from an external database, or update a database from a Vectorworks record field).

Access

Menu: Tools > Database > Manage Databases lets you connect to database files, view table columns, and select the key field.

Tools > Database > Record Format Connection lets you create and manage record formats, assign database tables, and import or export connections in XML files.

Tools > Database > Object Connection lets you connect data from the database file to one or more selected object’s records.

Tools > Database > Update External Database refreshes data from the Vectorworks file in the database file.


Tools > Database > Update Settings lets you verify or modify database and Vectorworks file refresh options.

Process Overview

The following steps describe the general process for connecting data in an external ODBC database to record fields attached to Vectorworks drawing objects:

Note: See all Tips and Considerations below before continuing.

You start by installing drivers for your operating system’s ODBC manager, and then you create data source names for your database file(s).

1. Launch your operating system’s ODBC Data Source Administrator tool, and then:
   • If applicable, install the appropriate driver(s).
   • Create data source names for your database file(s).

Next, you connect the Vectorworks document to the desired data source.

2. From the menu, select Tools > Database > Manage Databases to display the Manage Databases dialog box.

3. Click Connect, and then in the Database Connection dialog box, select one of the defined data source names or enable the Use Connection String option and enter the connection string. Click OK to connect the database and automatically list the database and its (indented) tables in the Available Databases column.
4. Click the desired table, and verify or adjust the default key column.
5. Repeat steps 3 and 4 to connect another database (if necessary).

Next, you define how the Vectorworks record format fields connect to the desired database table columns.

6. From the menu, select Tools > Database > Record Format Connection to display the Record Format Database Connection dialog box.

7. If record formats are displayed in the list, go to step 8. Otherwise, click New, and then create the desired record format(s).

8. Select the desired record format and click Edit, and then in the Edit Record Format dialog box.
   • Enable the Database Connection option.
   • Select the desired database name and table from the drop-down lists.
   • Select each field to connect (one at a time), and then click Edit. In the Edit Field dialog box, select the desired column and link type (select Read/Write for bi-directional associativity) from the drop down lists, and then click OK.
   • Click OK to close the dialog box and save the field connection settings.

Next you connect database rows to instances of the record format (from the previous step), which are attached to drawing objects. For a single drawing object, go to step 9. To connect multiple unresolved drawing objects, go to step 13.

9. In the drawing area, select the object you want to connect to the database.

10. In the Object Info palette, select the Data tab and then:
   • In the Record Formats section, verify that the record format from step 8 is enabled (if not, enable it).
   • In the Record Fields section, notice the default or missing values of the record format’s fields.
   • Click Object Database Connection (or from the menu, select Tools > Database > Object Connection).

11. In the Object Database Connection dialog box:
   • Select a record from the Available Records drop-down list (if it’s not already active).
   • Select Use Selected Database Table Row (or select Add New Database Table Row and add a row).
   • Select the table row to connect.
   • Click OK to close the dialog box and save the row connection.

12. In the Object Info palette, notice that the record format fields now display the table row’s data. Go to step 17.

13. In the drawing area, select the objects you want to search.

Next, you use data from one field to populate the data in other fields of the same record as well as built-in search functions to find unresolved objects in the current selection.

14. From the menu, select Tools > Database > Object Connection. In the Multiple Object Database Connection dialog box:
   • Select the Find Row by Value option.
   • Select the Find by Value column of a field where data exists in all or most of the selected records. A check mark is placed in the column, and a query is sent to the database. If a record in the Vectorworks file contains a value in this field that matches the value of the same field in the database file, data in all other connected fields are retrieved from the database file’s record. These data automatically populate the corresponding fields in the Vectorworks record (which then resolves the drawing object it’s attached to, and updates the quantities in the status messages to the right).
   • If any objects are still unresolved, select another field’s Find by Value column (if applicable), and check the status.
   • If necessary, repeat the above step until either all objects are resolved or you can’t resolve any additional objects by selecting any Find by Value column.
   • Select the deselect resolved objects option, and then click OK. If no objects are selected, go to step 17. Otherwise, click Fit To Objects in the View bar, and note which (unresolved) objects are selected.

15. Clear the current selection, and then one at a time, select the unresolved objects and enter an appropriate key field value in the Object Info palette’s Data tab (or worksheet, if present--see Tips and Considerations).
16. Repeat steps 14 and 15 as necessary until all objects are resolved.
17. You can now change data in the Vectorworks file or database table, and then update the values in the other file—if you selected Read/Write DB Link Type options in step 8—using the update options in the Tools > Database menu.

**Tips and Considerations**

Keep in mind the following tips and considerations when using ODBC database connectivity:

- There are extensive options for creating, configuring, and connecting ODBC databases that are beyond the scope of this new feature guide. Refer to the Help system in your database program and/or operating system for fully detailed instructions and complete coverage for all options.
- If you are not familiar with using record formats, refer to the Vectorworks online Help system for more information about using record formats and options for ODBC database connections.
- You cannot add or delete records in the external database file when you run the Update External Database command from the Vectorworks file.
- You can display record format fields in Vectorworks symbols. To do this, link individual text objects—optionally formatted with text styles—in the symbol’s definition to the appropriate field of a record format. Refer to the online Help system’s “Linking Text to Record Formats” topic for more information.
- When you create drawing objects with record formats attached, enter unique data in the key field (if not the key field, then enter appropriate data in the same field for all objects) to facilitate the connection with an ODBC database.
- In Vectorworks files with significant quantities of record instances, you may find it helpful to create a worksheet for tracking or editing field values.
- FileMaker 11 is the recommended version for connecting FileMaker databases on Macintosh computers. Version 11 facilitates the connection process with a built-in feature that automatically installs and configures the ODBC drivers.
- When you edit data in the external database file’s fields, update the database (or at least move the cursor out of the edited field) before you update the connected Vectorworks document.

### 2.07 Multi-File Batch Print

**Product: Architect, Landmark, Spotlight**

Vectorworks 2011 now lets you simultaneously batch-print or batch-export (to PDF) saved views and sheet layers from multiple Vectorworks files, whether they’re active or not.

**Access**

You can select multiple files and adjust other settings in the Batch Print and Batch Export PDF dialog boxes:

- **Menu:** File > Batch Print.
- **File > Export > Export PDF (Batch).**

Use the **Select Folder** button to navigate and select the project folder(s), sort the Sheets and Saved Views available list (if necessary) by clicking any column header(s), then select items to print and use the arrow keys to add them to or remove them from the Sheets and Saved Views to Print list. To customize the printing order, click the # column header, and then drag and drop the line numbers as necessary.

To optionally save the current batch settings: Click **Save a Set**, and then enter a name in the New Saved Set dialog box. Select a path storage option for externally referenced files (if applicable), and then click **OK**. To recall a saved set, click **Manage Sets**, and then select a saved set from the Name list in the Manage Saved Sets dialog box (where you can also edit or delete saved sets), and then click **Recall**.
2.08 Improved Window and Door Settings

Product: Fundamentals, Architect, Landmark, Spotlight, Designer

The redesigned Window and Door Settings dialog boxes in Vectorworks 2011 are now easier to navigate and streamline the process of configuring door and window objects, with the following key improvements:

- Nested configuration controls and extra pop-up menus have been removed.
- All option groups are now selectable from the list on the left.
- For most option groups, all configuration settings are now visible at once.
- The top/plan preview and a new 3D preview are now persistent for all option groups. You can specify a standard view and render mode for the 3D preview when any option group is active.
- The Use Symbol Geometry option now incorporates the symbol definition's wall hole cutting object (if present).

Access

Building Shell tool set: Window or press Shift+D; Door or press Alt+Shift+D (Windows), Option+Shift+D (Macintosh).

2.09 Create Wall Using Core Component for the Control Line

Product: Fundamentals

The new Core Component Control Line Mode option for the Wall and Round Wall tools lets you set the control line relative to the wall's core component. Also, the newly added Wall Control Line Mode option lets you set the control line relative to the entire wall (as in previous versions).

Note: The Core Component Control Line Mode option requires a core component in the active wall style.

Access

Building Shell tool set: Wall or press 9, and then click Core Component Control Line Mode in the Tool bar.

2.10 IFC Support Improvements

Product: Architect

Vectorworks 2011 includes several UI improvements for IFC functions, and increases interoperability with other IFC-enabled products through the following new or enhanced data, import, and export features:

- Project/File/Building attribute improvements as defined by the GSA CD BIM 2010 MVD: File Owner/History, Name (user-defined vs. automatic), Project/Site/Building Storey Long Name, and Project Phase
- Export support for Vectorworks 2011's new or improved architectural object types
- UI and functionality support for choosing a MVD for export
- Support for Base quantities via IfcElement
- Support for IfcActor assignment to Project
- Parametric support for Doors and Windows
- Support for Classification Reference of any or all objects

Access

Menu: File > Import/Export > Import IFC/Export IFC Project.
2.11 Improved Stairs

Product: Architect

Key improvements for stairs in Vectorworks Architect 2011 are summarized as follows:

- General settings dialog box enhancements: The Preview section of the Stair Settings dialog box’s General tab now includes more display options and reports the display/scale status based on current setting of the “Hide details when layer scale...” document preference.

- Graphic Attributes centralization: The Graphic Attributes tab of the Stair Settings dialog box now provides single-point control of all stair graphic attributes, including walk line end markers and common text attribute settings for stair data text objects. When the new Fit to Tread Depth option in the Attribute dialog box is enabled, the size of the walk line end marker will be adjusted accordingly, based on the attributes of the actual line end marker specified. Also, attributes for the circle and double line end markers (with attributes different from the walk line’s) have been removed from the Attributes Walk Line dialog box.

- Auto-classing and standard naming features: If auto-classing is enabled in the Standard Naming dialog box, the stair object and its components now default to best-practice workflow classes according to the current Active Standard.

- Creation of straight stairs with two landings: You can now create straight stairs with two landings, or you can select the new Straight, Double Landings option from the Select a Stair Configuration dialog box and modify the settings as necessary.

- Stair Geometry interface optimization (for straight stairs with various landing configurations): To eliminate redundancy with the Geometry tab, the Length and Numbers of Risers parameters have been removed from the General tab of the Stair Settings dialog box. Also, the Length and Walk Line Length parameters (in the Geometry tab) are now editable and lockable.

- Support for flights and landings with different widths: You can now specify different widths for flights and landings of L and U stair configurations. Also, the new Walk Line on Center option automatically draws the walk line along flight centerlines. You can also enable the Link button(s) in the Geometry tab to couple values and maintain equal widths, or disable the button(s) to allow different widths. Note that when widths are different, the Stair Width field in the General tab is empty.

- Stair Text Improvements: You can now control the position and rotation of riser numbers. For tread numbers, you can now specify the lateral position (left, centered, and right for straight stairs) and distance from riser lines by changing the new Offset parameter value. The existing text object “Total” has been renamed “Note 1,” and a new “Note 2” text object has been added. The new text variables “Total Rise” and “Arrow Direction” are now included in all runs and “Note 1” and “Note 2” text objects. Also, the text variable “New Line” has been renamed “Line Break” for consistency.

- New fixed angle winder configurations: You can now select standard U and L stair configurations with fixed angle winders (all winder treads have the same angle). To adjust the three primary settings for fixed angle winders, select the Geometry tab of the Stair Settings dialog box. You can then adjust the value of the Min. Inside Tread Depth parameter and click the winder area in the preview to adjust settings in the Winder Parameters dialog box. Alternately, you can click the Min./Max. Settings button to adjust the value of the new Winder Tread Depth Min. parameter.

- Stair railing enhancements: You can now place a handrail next to a guardrail (all railing components in Vectorworks 2010, such as top rail, frame, frame bars, and posts, are now referred to as “guardrail” components) in the stair object. There are now more controls for the guardrail position, and new options to align the right or left-hand side posts with the position of the other side. You can now create rectangular frame bars, and there are now more options to define top and bottom extensions of handrails and top rails.
Animation

Click here to view an animation of these features.

Access

Various tabs of the Stair Settings dialog box:

Building Shell tool set: Stair.

2.12 Connect Roof Faces

Product: Fundamentals

Vectorworks 2011 now lets you use two of the Connect/Combine Tool modes—with a new preference setting—to connect roof face objects, so you can create complex and irregular roof shapes quickly and accurately:

- **Single Object Connect Mode**: The first-clicked roof face is extended (when disjointed) or trimmed (when intersecting; the clicked part is kept) to the boundary of the second-clicked roof face, which remains unmodified.

- **Dual Object Connect Mode**: If the roof faces being connected are intersecting, both roof faces are split at the intersection, and only the clicked parts of both roof faces are kept. If they are disjointed, the clicks on both roof faces determine the projected intersection to which both roof faces are extended to.

Animation

Click here to view an animation of these features.

Access

Basic palette: Connect/Combine Tool, or press the “;” key. In the Tool bar, choose either Single Object Connect Mode or Dual Object Connect Mode, and then optionally click Connect/Combine Roof Faces Preferences to display the Connect/Combine Settings dialog box, where you can toggle the new Use Vertical Thickness of Subject Roof Face option. This option controls whether the boundary roof face’s vertical thickness will be changed as necessary to match the subject roof face’s vertical thickness (enabled) or if the boundary roof face’s vertical thickness will not be changed (disabled).

Tips and Considerations

Keep in mind the following tips and considerations when using the Connect/Combine Tool to connect roof face objects:

- You can use the Create Roof command to quickly model the basic roof components (with “standard” shapes) of your complex roof designs. If you do, you must ungroup roof objects to connect resultant roof faces with other roof face objects using the Connect/Combine tool.

- Duplicate a roof face object in place—before using the Connect/Combine tool—if it will be trimmed by more than one connecting operation with other roof face objects.
2.13 Style Class Removal

Product: Fundamentals, Architect, Landmark, Spotlight, Designer

Vectorworks 2011 replaces the “Style-#” classes for “part” attribute assignments of plug-in objects with user-definable classes that respond to the current document’s class definitions and preserve class attributes in all standard editing contexts.

Access

Multiple preference and tool settings dialog boxes.
3. Exceptional Text Features

Vectorworks 2011 significantly expands text and annotation functionality with new text styles for global text control, new formatting options, legibility in 3D views, and accurate text display in the newly enhanced editing box—regardless of text and view orientation.

3.01 “Perfect Preview” Text Editing

Product: Fundamentals

In Vectorworks 2011, word wrapping and font spacing in text creation/editing mode now exactly matches how the completed text object is displayed and printed. Also, you can now optionally edit rotated text in a rotated aspect.

Animation

Click here to view an animation of these features.

Access

You can toggle the Edit text horizontally by default option in the Edit tab of the Vectorworks Preferences dialog box:

Menu: Tools > Options > VectorWorks Preferences, or click on the far right side of the Tool bar and select VectorWorks Preferences, and then select the Edit tab.

In text creation/editing mode, you can optionally click the rotation button at the top right corner of the text block to toggle rotated/horizontal editing display (the text edit tab ruler is always shown in horizontal editing display).

3.02 Text Styles

Product: Fundamentals

You can now use text styles (a new type of resource) to globally control text objects; if you change the definition of a text style, all text in the drawing with that style property will update automatically. Text objects and many types of objects that contain text (such as dimensions and most plug-in objects) now have a Style property. For these objects, you can choose to use un-styled text or text based on styles.

Standard text styles are included as default content, or you can create your own text styles and save them as resources in the current document (or in a template or library file), so you can share them with other files and users via importing/exporting, referencing, or placing them in default content files.

Animation

Click here to view an animation of these features.
Access

You can create, modify, and activate text styles from the Resource Browser. You can create and activate text styles from the Format Text dialog box:

Menu: Text > Format Text or right-click a text object and select Format Text from the context menu. Note that if you change settings in the Format Text dialog box—when no objects are selected—the settings are saved as the document’s default when you click OK.


You can apply a text style from the Object Info palette, Tool bar (which sets the document’s default text style when the Text tool is active), multiple dialog boxes, or by dragging its definition from the Resource Browser and dropping it on a valid text-styled object.

To navigate directly to a text object’s style definition, right-click the text object and select Locate Text Style In Resource Browser from the context menu.

Tips and Considerations

Keep in mind the following tips and considerations when using text styles:

• When you edit text objects, the style you select will only be applied to currently selected text.
• If you change the other attributes of a styled text object or selection, that text becomes un-styled.
• You can specify multiple text styles to partial selections inside a text block. If an entire text block object is assigned a text style, the text block itself reverts to un-styled text if you change the style or any text attributes of a partial selection inside the text block. If a text block object contains portions of styled text, those styles are cleared if you apply a text style to the entire text block.
• The Alignment, Spacing, and Background Color text attributes are only applied when you assign a text style to an entire text block object; they are never applied when you change the style of a partial selection inside a text block.
• Outline and Shadow text are only available on Macintosh computers.

3.03 Improved Text

Product: Fundamentals

Vectorworks 2011 includes the following improvements for text objects:

• The new Tight Fill option automatically adjusts the fill width—which now allows different fill widths—for each line in a text block.
  You can toggle the Tight Fill Mode option in the Tool bar, or toggle the Tight Fill option for selected text in the Object Info palette.
• The Check Spelling option is now always displayed in the context menu during text editing mode.
• You can now rotate text objects by their grips with the Selection Tool by holding down the Alt key (Windows) or Option key (Macintosh).
• The new Justify option in the Object Info palette’s Horiz. Align drop-down list adjusts the word spacing (for full lines only) to align text to both left and right.
• You can now create true superscript and subscript text formatting—inside a text object—using the new Superscript and Subscript options in the Object Info palette.
• When text editing mode is active, you can now use the Zoom In/Zoom Out with the Alt Key tool (without exiting text editing mode).
Animation
Click [here](#) to view an animation of these features.

Access
Basic palette: Text (or press 1), and then optionally click **Tight Fill Mode** in the Tool bar.

3.04 Viewport Text Scale Support
Product: Fundamentals
The Text Scale viewport advanced property now affects the scale of plug-in object text and associated adorning objects (such as the circle that surrounds a reference marker’s text).

Access
You can set a viewport’s Text Scale value in the Advanced Viewport Properties dialog box:
Object Info palette: Click **Advanced Properties**.
4. Tap into Power Tools

Vectorworks 2011 increases your productivity with the following improvements:

- New symbol properties allow symmetric or asymmetric scaling of symbol instances.
- A new 2D tile fill attribute with interactive editor for dynamically creating fill patterns.
- New options to display commonly used preferences on the Tool bar.
- New tools and options for creating, selecting, and editing objects.
- More controls and options for creating and displaying dimensions, new capabilities for re-positioning multiple dimensions, and new dynamic controls for independently adjusting dimension leader and witness lines.
- Data entry, extraction, and text sorting improvements.
- Saved views can now optionally preserve render mode settings.
- More options for deleting, renaming, and managing resources.
- Classes imported from "standard files" can now replace attributes of existing class definitions (without breaking any class associations), forcing common classes to comply with company drawing standards.
- Compatibility improvements for exchanging DXF/DWG data.
- Plug-in objects that previously required “Style-#” classes for part attribute assignments now accept any user-defined class.

4.01 New Scalable Symbols

Product: Fundamentals

Vectorworks 2011 adds new properties to symbols that let you apply symmetric or asymmetric scale factors to symbol instances. To take full advantage of scaling, symbol definitions now include a new Units option, which must be set to one of two states:

- **Page-based**: The symbol instance is automatically sized relative to the instance’s page environment. As an example, a page-based units symbol created from a 1” x 1” square would be drawn at a size of 25” x 25” (with its Scaling property set to None) when inserted on a 1:25 scale design layer. Symbols with page-based units can only be scaled symmetrically.

- **World-based**: The symbol instance is always sized in world dimensions, regardless of the symbol instance’s page environment. If the example symbol (above) was changed to world-based units, it would be drawn at a size of 1” x 1” when inserted on a 1:25 scale design layer.

Access

Select the symbol instance(s) you want to scale. In the Object Info palette, select Symmetric or Asymmetric from the Scaling drop-down list, and then enter the desired scaling factor(s). Select None from the Scaling drop-down list to revert the symbol scaling.

You can toggle the Units option settings in the Create Symbol and Symbol Options dialog boxes. When you create a symbol from currently selected objects:

Menu: Modify > Create Symbol.

For an existing symbol: Right-click the symbol in the Resource Browser and select Edit. In the Edit Symbol dialog box, select Symbol Options, and then click Edit.
4.02 New Tile Fills for 2D Objects

Product: Fundamentals

You can now use tile fills—a new type of fill style resource—to display simple or complex repeating patterns on 2D objects. Tile definitions are based on settings (similar to symbol settings), and geometry created or edited in a special tile mode with dynamic controls that let you intuitively arrange the pattern repetitions (view the animation below to see tile mode’s interactive controls and display options).

Standard tile fills are included as default content, or you can create your own tile fills and save them as resources in the current document (or in a template or library file), so you can share them with other files and users via importing/exporting, referencing, or placing them in default content files.

Animation
Click here to view an animation of these features.

Access
You can create, modify, and activate tile fills from the Resource Browser:


You can apply a tile fill from the Attributes palette, multiple dialog boxes, or by dragging its definition from the Resource Browser - and dropping it on a closed 2D object.

To navigate directly to an object’s tile fill definition, right-click the object and select Locate Tile In Resource Browser from the context menu.

Process Overview

The following steps describe the general process for creating a new tile resource:

1. From the Resource Browser menu (or right-click the Resource Browser background), select New Resource in [file name] > Tile.
2. In the New Tile dialog box:
   • Enter the name.
   • For the Units, select either Page (fill geometry is automatically sized relative to the object’s page environment) or World (fill geometry is always sized in world dimensions, regardless of the object’s page environment).
   • Adjust Rotate options (if necessary).
   • Either disable the Background Fill option, or change the desired background color (if a color other than white is required).
   • Click OK to close the New Tile dialog box and activate tile mode in the drawing area.
3. Create 2D objects for the base (or master pattern) geometry, and then drag the master pattern and/or grayed repetitions to adjust the tile pattern as desired (view the animation above to see tile mode’s interactive controls and display options).
4. When finished, click the orange Exit Tile button in the upper-right corner of the drawing area. The new tile resource is displayed in the Resource Browser.
Tips and Considerations

Keep in mind the following tips and considerations when using tile fills for 2D objects:

- You can insert text objects when you create or edit tile fill geometry.
- You cannot insert symbols when you create or edit tile fills.
- You can duplicate a tile fill from the default content, and then edit the duplicate to create similar tile fills, or learn how different pattern effects are created.

4.03 Quick Prefs

Product: Fundamentals

Vectorworks 2011 introduces new Quick Prefs that let you quickly modify commonly used preferences and settings through optional shortcut buttons on the Tool bar.

Access

You can toggle the display of Quick Prefs by clicking on the far right side of the Tool bar. A check mark indicates active Quick Prefs (displayed on the Tool bar). You can also select the Document Preferences or Vectorworks Preferences options at the bottom of the menu.

4.04 New Select Connected Objects Command

Product: Fundamentals

The new Select Connected Objects command uses the active selection of one or more objects to automatically select all objects that are directly or indirectly connected end-to-end with the original selection.

Valid objects for the Select Connected Objects command include:

- Lines
- Polygons
- Arcs
- Polylines
- Open 3D polygons
- NURBS curves
- Walls
- Round walls

Use the Select Connected Objects command to facilitate the selection of:

- Contiguous objects (such as those found in imported AutoCAD files) comprised of many constituent objects, for subsequent composing operations.
- Connected objects in congested areas and/or complex configurations, or when the display is cluttered by objects on other visible layers or other conditions where objects would otherwise be difficult or extremely time-consuming to select.
- Boundaries for one or more rooms or buildings to create other objects such as spaces, roofs, and slabs (manual boundary only; by polygon conversion).
- Objects to verify the accuracy of coincident drawing objects.
Animation
Click here to view an animation of these features.

Access
Select one or more objects, and then select Edit > Select Connected Objects from the menu.

4.05 General Dimension Improvements
Product: Fundamentals
Vectorworks 2011 includes the following improvements for creating and modifying dimensions:

• You can now use text styles to control text globally in custom dimension standards.
• All dimension-related controls are now grouped together in the Object Info palette.
• The Selection Tool now lets you edit multiple-selected dimensions simultaneously.
• The floating data bar now displays more useful controls (such as offset or length) for editing dimensions with the Selection Tool.

Access
Dims/Notes tool set: (Multiple dimension tools), and multiple dialog boxes, editing modes, and the Object Info palette.

4.06 Improved Dimension Leader Line
Product: Fundamentals
You can now add leader lines to linear, arc length, and chain dimensions.

Access
Drag dimension text, and then you can toggle the Leader Line option in the Object Info palette.

4.07 Saved Settings for the Eyedropper Tool
Product: Fundamentals
Vectorworks 2011 now lets you save and recall Eyedropper settings.

Access
Basic palette: Eyedropper or press Shift+E, and then select either All Attributes or Plug-In Parameters from the Active Settings drop-down list, or click Eyedropper Tool Preferences in the Tool bar to select specific attribute criteria to transfer.

To save criteria settings: Click Save, and then enter a name in the Assign Name dialog box. Click OK to save the settings for later recall by selecting them from the Active Settings drop-down list.
4.08 Line from Center Mode

Product: Fundamentals

The new Line From Center Mode for the Line tool in Vectorworks 2011 lets you draw a line from its midpoint.

Animation

Click here to view an animation of these features.

Access

You can select the new Line From Center Mode in the Tool bar:

Basic palette: Line or press 2.

4.09 New Even Divide Command

Product: Fundamentals

The new Even Divide command automatically splits any combination or quantity of selected arcs, circles, and rectangles into equally sized portions according to the designated number of divisions. You can optionally choose to retain the original object(s) and to leave the newly created object(s) selected.

Animation

Click here to view an animation of these features.

Access

Menu: Modify > Drafting Aids > Even Divide.

4.10 New Create Dividing Lines Command

Product: Fundamentals

The new Create Dividing Lines command automatically draws lines evenly divided (according to the designated number of divisions) by angle or distance between two lines you select—at a constant length determined by start and end points you specify.

Animation

Click here to view an animation of these features.

Access

Menu: Modify > Drafting Aids > Create Dividing Lines.
4.11 Scaled Line Creation

Product: Fundamentals

The new Line Settings dialog box lets you specify a length scaling factor preference for the Line tool.

Animation

Click here to view an animation of these features.

Access

Basic palette: Line or press 2, and then click Length Factor Preferences in the Tool bar to display the Line Settings dialog box, where you can specify the Length Scale Factor.

Tips and Considerations

Keep in mind the following tips and considerations when using a length scale factor to create scaled lines:

• Set the Length Scale Factor to 0.5 to quickly create a construction line with a vertex that “marks” the midpoint between two points when you can’t easily or quickly set Smart Points to use the “Snap to line between Smart Points” snap.

• When finished drawing scaled lines, remember to reset the Length Scale Factor to 1 to restore normal Line tool operation.

4.12 New Triangle Tool

Product: Fundamentals

The new Triangle tool creates a three-sided polygon based on side lengths and angles you specify.

Animation

Click here to view an animation of these features.

Access

Basic palette (hold down the left mouse button on the 2D Polygon tool to open the flyout palette): Triangle, or press Shift+T. In the Tool bar, select Triangle by Three Sides, Triangle by Two Sides and Included Angle, or Triangle by Two Angles and Common Side, and then click two points. You can then specify the side/angle values in the Triangle Settings dialog box.

4.13 New Roof Slope Preference

Product: Fundamentals

In Vectorworks 2011, whether you specify the roof slope in (integer or decimal) rise over run or angle format during creation or editing, the slope format is saved for each roof edge and maintained for subsequent editing operations. When you add a new roof edge with the 2D Reshape tool, the edge of the vertex you select determines the slope format of the new edge.

Access

Menu: AEC > Create Roof.
4.14 Saving Render Settings in Saved Views

Product: Fundamentals

The new **Save Render Settings** option in the Save View dialog box now lets you save all active render mode settings in saved views.

Access

For new saved views, you can toggle the **Save Render Settings** option in the Save View dialog box:
- **Menu**: Tools > Organization. Select the Saved Views tab, and then click **New**.
- **Menu**: Window > Palettes > Navigation (Design Series). Select the Saved Views tab, and then select **New** from the tab’s menu.

For existing the saved views, you can toggle the **Restore Render Settings** option in the Edit Saved View dialog box:
- Display the Saved Views tab as described above, and then right-click a saved view and select **Edit** from the context menu.
- You can also toggle the **Render Settings** option in the Redefine Saved View dialog box (Design Series):
  - Right-click a saved view in the Navigation palette’s Saved Views tab, and then select **Redefine** from the context menu.

4.15 Improved Witness Line Length Control

Product: Fundamentals

You can now use your mouse or choose new options in the Object Info palette to customize witness line lengths or offsets for linear and arc length dimensions, independent of the dimension’s standard.

Access

In the Object Info palette’s Witness Lines section—when either or both witness lines are visible—select a length or offset option from the new Override drop-down list, and then specify exact lengths or offsets in the related Offset and Length fields. You can also use the **Selection Tool** to dynamically drag the gray dashed lines extending from the witness line vertices. While dragging, you can optionally specify exact lengths or offsets in the floating data bar. When either the **Multiple Custom Lengths** or **Multiple Custom Offsets** override is active, hold down the Shift key to drag both together.

4.16 Improved Nudge for Objects in Walls

Product: Fundamentals

The **Nudge** command now moves one or more selected objects in a straight or round wall segment (without removing the objects from the wall, or moving the wall itself). In round or angled wall segments, selected objects are moved in the general direction of the arrow key. In all cases, selected objects are moved along the wall’s length by a distance of one nudge unit regardless of the wall segment’s orientation.

**Note**: You cannot use the **Nudge** command on multiple selected objects in different wall segments.

Access

Select one or more objects in a wall, and then press Shift+(any of the four arrow keys).
4.17 Offset Group Improvements

**Product:** Fundamentals

Offset operations on grouped 2D objects are now reliable and consistent—regardless of the offset direction—so you can confidently add graphic style to elevations or other elements.

**Access**

Basic palette: **Offset** (or press Shift+- (hyphen))

4.18 Rename Referenced Resources

**Product:** Fundamentals

You can now rename referenced resources in the host file (without opening the source file). This new renaming capability is available for:

- Symbol definitions
- Gradients
- Record formats
- Hatches
- **Tile fills**
- Renderworks backgrounds
- Textures
- Sketch styles
- Wall styles
- **Slab styles**
- Plant definitions
- Image resources

**Animation**

Click [here](#) to view an animation of these features.

**Access**

Right-click a referenced resource in the Resource Browser and select **Rename** from the context menu.
4.19 New Option to Replace Existing Classes During Class Import

Product: Fundamentals

Vectorworks 2011 now lets you import classes that already exist in the current document, so you can replace the existing classes’ attributes without breaking any class associations. Use this new feature to:

- Force common class definitions in any drawing to match the class definitions in your company’s standard file.
- Temporarily override classes at the document level for presentation purposes such as printing or creating dynamic or static renderings.
- Synchronize class attributes in multiple-file projects with referenced files and/or resources.

Access

To replace existing classes during class import:

Menu: Tools > Organization. Select the Classes tab, and then click New.

Menu: Window > Palettes > Navigation (Design Series). Select the Classes tab, and then select New from the tab’s menu.

In the New Class dialog box, select Import Classes, and then disable the Show only classes that are not in the current document option. If your standard file is a template (.sta) file, select it from the drop-down list. Otherwise, click Choose and navigate to your standard drawing file.

4.20 Thousands Separators in Dimension Text

Product: Fundamentals

You can now optionally display thousands separators in dimension text (such as the comma in the number “1,000”).

Access

You can toggle the Show Thousands Separators in Dimension Text option in both tabs of the Units dialog box:

Menu: File > Document Settings > Units.

4.21 Number-Aware String Sorting

Product: Fundamentals

In Vectorworks 2011, many alphanumeric lists that contain numbers will now sort more intuitively, so you won’t have to maintain numbering schemes with extra 0 (zero) prefixes to control list sorting of file structure elements, drawing resources, and object parameter/database record data.

Access

Multiple locations: Examples of columnar and drop-down list locations include dialog boxes, palettes, the Resource Browser, and worksheets.
4.22 New Worksheet Inquiry Functions

Product: Fundamentals

Vectorworks 2011 adds three new inquiry functions for worksheets that return the insertion point’s drawing coordinate for symbols, point plug-ins, and loci:

- XCoordinate (criteria): Returns the X coordinate of the object relative to the user origin.
- YCoordinate (criteria): Returns the Y coordinate of the object relative to the user origin.
- ZCoordinate (criteria): Returns the Z coordinate of the object relative to the object’s layer plane.

Access

You can access new worksheet formatting options in the Select Function dialog box.

Worksheet drop-down menu: Paste Function.

4.23 Improved Mirror Tool for Objects in Walls

Product: Fundamentals

The Mirror tool now mirrors one or more selected objects in a straight or round wall segment. When you select objects in a wall, the Mirror tool now automatically constrains the mirror axis line perpendicular with the wall, and then mirrors the objects along the wall. The resultant mirrored objects:

- Remain inserted in the wall if they are completely inside the wall boundary.
- Are removed from the wall if any portion extends beyond the wall boundary.

Note: You cannot use the Mirror tool on multiple selected objects in different wall segments.

Access

Select one or more objects in a wall, and then from the Basic palette, click Mirror or press =.

4.24 Resource Browser Library Access Improvements

Product: Fundamentals

Vectorworks 2011 adds a new Libraries section to the Resource Browser’s File drop-down list that includes shortcuts to the application, user, and workgroup library folders. When you select a library shortcut, the folder’s contents are instantly displayed in the Open dialog box.

Access

Resource Browser Files drop-down list: In the Libraries section, select Vectorworks Libraries, or User Libraries, or Workgroup [number] Libraries (folder name) (if workgroup and project folders are designated in the User Folders tab of the Vectorworks Preferences dialog box).
4.25 Disassociate Dimensions Context Menu Command

Product: Fundamentals

The new Disassociate context menu command instantly deletes constraints from an associative dimension object.

Access

Right-click an associative dimension or chain dimension object and select Disassociate from the context menu.

4.26 Delete Symbol Completely

Product: Fundamentals

A new option for deleting symbol definitions in the Resource Browser also deletes all instances in the current drawing.

Access

To find a symbol’s definition from a drawing instance: Right-click a symbol instance, and select Locate Symbol in Resource Browser from the context menu.

To delete the symbol definition and remove all instances from the current drawing: Right-click the symbol definition in the Resource Browser, and select Delete from the context menu. In the confirmation dialog box, enable the Delete Symbol Instances completely option.

Tips and Considerations

Keep in mind the following tips and considerations when using the Delete Symbol Instances completely option:

- Enable the Always delete Symbol Instances completely option with caution. Once enabled, the confirmation dialog box no longer displays the symbol deletion options, and only warns you that the resource will be deleted (not all instances). As a result, you may unknowingly delete symbol instances when you delete their definition.
- You can disable the Always delete Symbol Instances completely option—and restore the display of symbol deletion options in the confirmation dialog box—by opening the SavedSettingsDialog.xml file in a text editing program, and then deleting this entire line in the <AlwaysDoSelectedAction> section:
  
  `<DeleteSymbolCompletely>true</DeleteSymbolCompletely>`

  Typical folder locations for the SavedSettingsDialog.xml files are:

  Windows: C:\Documents and Settings\[Current User]\Application Data\Nemetschek\VectorWorks\2011\Settings


4.27 Prevent In Place Duplications

Product: Fundamentals

The new Allow Ctrl-click in-place duplication option in the VectorWorks Preferences dialog box lets you choose whether Ctrl (Option)+clicking an object will create a copy in the same location. This preference is disabled by default to prevent inadvertent duplications of selected objects.

Note: When this preference is disabled, you can still create duplicates by Ctrl (Option)+clicking and dragging any non-zero distance away from the source object.

Access

You can toggle the Allow Ctrl-click in-place duplication option in the Edit tab of the Vectorworks Preferences dialog box:

Menu: Tools > Options > VectorWorks Preferences. or click on the far right side of the Tool bar and select VectorWorks Preferences, and then select the Edit tab.
4.28 Closed Checkbox for Polylines

Product: Fundamentals

Vectorworks 2011 adds a new **Closed** checkbox for polylines to display or toggle the current open/closed state of the polyline. Enabling this option closes the polyline by making all edges visible. Disabling this option opens the polyline by making the last edge invisible (if that edge is between two corner-type vertices). The open (or disabled) state is displayed for a selected polyline if any of its edges—including any intermediate edge—is invisible.

**Access**

You can verify or toggle the open/closed state of polylines with the **Closed** option in the Object Info palette.

4.29 New Adjust Flipped Text Document Preference

Product: Fundamentals

The **Adjust flipped text** option is now a document preference (instead of an application preference). This option is enabled by default for new files and legacy files migrated to Vectorworks 2011.

**Access**

You can toggle the **Adjust flipped text** option in the Display tab of the Document Preferences dialog box:

Menu: **File > Document Settings > Document Preferences**, or right-click a blank area in the drawing and select **Document Preferences** from the context menu, or click on the far right side of the Tool bar and select **VectorWorks Preferences**. Then select the Display tab.

4.30 Double Line Marker

Product: Fundamentals

Vectorworks 2011 introduces the new double line marker style.

**Access**

You can select the double line marker from the Line Startpoint Style and Line Endpoint Style drop-down lists in the Attributes palette.

End marker settings are saved in the **SavedSettings.xml** file. Typical folder locations for these files are:

Windows: **C:\Documents and Settings\[Current User]\Application Data\Nemetschek\VectorWorks\2011\Settings.**

Macintosh: **/Users/[Current User]/Library/Application Support/VectorWorks/2011/Settings.**

4.31 Improve Section Line Instances Dialog

Product: Architect, Landmark, Spotlight

Vectorworks 2011 replaces the Section Line Instances dialog box’s “Find Instances In:” drop-down list with Design Layers and Viewports tabs.

**Access**

With a section viewport selected, click **Section Line Instances** in the Object Info palette, or right-click a section viewport and select **Properties** from the context menu. Then click **Section Line Instances** in the Properties dialog box.
5. **Simplify File Exchange**

Vectorworks 2011 improves compatibility for DXF/DWG data exchanges by dramatically reducing file sizes, supporting hatches and arc length dimensions, exporting planar objects and design layer viewports, and including default ISO dash styles.

5.01 **Improved File Sizes**

**Product: Fundamentals**

In Vectorworks 2011, imported DXF/DWG files sizes are now as much as 50% smaller, and import faster when source files contain extensive quantities of 2D polylines comprised of line or arc segments, 3D polygons, 3D circles, and hatched objects with multiple boundaries and islands.

**Access**

Menu: File > Import > Import DXF/DWG or Import Single DXF/DWG File.

File > Export > Export DXF/DWG.

5.02 **Improved Support of Hatches**

**Product: Fundamentals**

Where applicable, DXF/DWG hatches are now imported as a single definition in Vectorworks but with different scales and angles. DXF/DWG hatches with the same hatch definition, but different colors, will continue to be imported as different hatch definitions in Vectorworks.

**Access**

Menu: File > Import > Import DXF/DWG or Import Single DXF/DWG File

5.03 **Improved Export of Planar Objects**

**Product: Fundamentals**

To ensure identical appearance and proper 3D orientation of planar objects exported to DXF/DWG files, all design layer objects are now exported in Top View, with the view in the new AutoCAD file changed to match the Vectorworks view.

**Access**

Menu: File > Export > Export DXF/DWG

5.04 **DXF/DWG Export of Design Layer Viewports**

**Product: Fundamentals**

A new option lets you choose whether design layer viewports are exported as separate externally referenced DWG files or bound into the newly created master DWG file.

**Access**

You can toggle the Export Design Layer Viewports as Separate Files option in the DXF DWG Export Options dialog box.

Menu: File > Export > Export DXF/DWG
5.05 Import/Export Support for Arc Length Dimensions

Product: Fundamentals

You can now import or export arc length dimensions as true dimensions. Note that if the DXF/DWG file has dimensions that measure arc openings, they will be imported as groups.

Access

Menu: File > Import > Import DXF/DWG or Import Single DXF/DWG File.

File > Export > Export DXF/DWG.

5.06 ISO Dash Styles

Product: Fundamentals

In Vectorworks 2011, default dash styles are now listed as defined by International Organization for Standardization (ISO).

Access

You can view and manage dash styles in the Dash Styles dialog box:


Attributes palette: Select Edit Dash Styles from the Line Style drop-down list.
6. Landmark

Landmark 2011 includes new commands for converting wall networks to site modifiers or stepped walls, new tools for creating grades and existing trees, site model display and performance improvements, more visibility/configuration controls and parametric data fields for hardscapes.

6.01 New Retaining Wall Site Modifier

Product: Landmark

Vectorworks Landmark 2011 adds a new command to create a site modifier object from a selected wall network, so you can design your retaining wall scheme with flexible wall objects and then generate accurate site modifiers directly from wall network geometry. You can modify the resultant path-based retaining wall site modifier object (new object type) to precisely sculpt the site model topography around the walls by:

- Directly editing the path with the 2D Reshape tool, or reshaping the side edges with the 3D Reshape tool (control points are restricted to move along the wall surface between the two adjacent points).
- Right-clicking the site modifier and selecting any of the context menu’s edit options.
- Using the Object Info palette’s standard site modifier and vertex editing controls, and new options for enabling or disabling either or both modifier edges. Note that there is no retaining behavior if a modifier edge does not exist; the terrain automatically slopes to the bottom of the wall.

Animation

Click here to view an animation of these features.

Access

Select one or more linearly connected walls (auto-joined in X or L configurations or joined by the Wall Join tool’s L Join Mode or X Join Mode), and then select (Designer) AEC > Terrain > Create Retaining Wall Site Modifier or (Landmark) Landmark > Create Retaining Wall Site Modifier from the menu.

Process Overview

The following steps describe the general process for creating a retaining wall site modifier:

You start by adjusting Wall tool settings, and then you draw the wall object(s).

1. From the Building Shell tool set, click Wall or Round Wall. From the Tool bar:
   - Select <Unstyled> and specify an appropriate ±Z value, or select or create a wall style (optionally based on 3D components) with an appropriately configured height.
   - Make sure the Auto Join Walls Quick Pref is enabled.

2. Draw a single wall segment or draw connected wall segments. If you want to create a stepped wall, go to step 3; otherwise, go to step 4.

3. Select an individual wall, or use the Select Connected Objects command to select connected wall segments, and then select (Architect) AEC > Terrain > Create Stepped Wall or (Landmark) Landmark > AEC > Create Stepped Wall from the menu. In the Create Stepped Wall dialog box, select the step style, adjust applicable step parameters, and then click OK to automatically modify the selected wall(s) with stepped wall peaks.

Next, you select the wall object(s) and create the retaining wall site modifier.
4. Select an individual wall, or use the **Select Connected Objects** command to select connected wall segments.

5. From the menu, select (Designer) AEC > Terrain > Create Retaining Wall Site Modifier or (Landmark) Landmark > Create Retaining Wall Site Modifier. In the Create Retaining Wall Site Modifier box, adjust settings for the following:
   - Pad
   - Left side
   - Right side

6. Click **OK** to create the retaining wall site modifier object, which is selected by default.

7. From the 3D Modeling tool set, click 3D Reshape, and then reshape the side edge(s) as necessary.

**Tips and Considerations**

Keep in mind the following tips and considerations when using retaining wall site modifiers:

- After creation, the retaining wall site modifier object has no association with the wall network it was created from.
- Use a negative value for the pad modifier’s Vertical Offset for conditions where the excavation required is deeper than the walls (such as for sand and/or gravel fills).
- You can also use retaining wall site modifiers to fine-tune existing site models.
- If you move the walls or modify the wall network instead of reshaping the site modifier, you may find it faster and more accurate to delete the retaining wall site modifier—and then select the wall(s) and run the **Create Retaining Wall Site Modifier** command again.
- If the invalid selection warning dialog box is repeatedly displayed—even after rejoining all connections—try selecting fewer wall segments and then repeating the command to create the retaining wall from multiple site modifiers (you can edit site modifiers’ paths as necessary to remove overlaps).

**6.02 New Existing Tree Tool**

**Product: Landmark**

Vectorworks Landmark 2011 introduces the new **Existing Tree** tool that lets you:

- Document existing site plants for evaluation before construction work or landscaping.
- Accurately represent remaining trees in 2D and 3D views.
- Manage individual trees or entire groups of trees.

Key features of the new existing tree object are summarized as follows:

- Extensive size, shape, display (2D and 3D), and status parameters for each tree—even trees of the same species—let you accurately depict existing site conditions and track the disposition of each tree.
- Several data fields for status are included so you can organize, display, and manage data effectively for large tracts.
- You can optionally auto-number trees, and manually override auto-numbers.
- For rapid visual reference, you can optionally apply different 2D display attributes to indicate significance or identify “keep clear” areas for root and tree protection zones.
Animation

Click here to view an animation of these features.

Access

Site Planning tool set: Existing Tree.

Process Overview

The following steps describe the general process for initially configuring the Existing Tree tool and placing existing tree objects in a drawing:

If you have modified the data in your Landmark Plant Database and you want to use your own data with the Existing Tree tool, start with step 1 to create an existing tree list. Otherwise, start with step 5.

1. From the menu, select Landmark > VW Plants Database. The Vectorworks Landmark plant database opens in a separate window.
2. If you want to use all of your plant database records, select Records > Show All Records from the plant database menu (if only a subset is currently found) and then go to step 4. Otherwise, continue with step 3 to find a subset of records.
3. In the Status Area, click Find to activate Find mode. Enter appropriate search criteria (see Search Tips below) to find the subset of records you want to use with the Existing Tree tool, and then click Find in the Status Area to display the records in Browse mode.

Search Tips:

1) You can also use operators from the Symbols menu (in the Status Area) in combination with truncated names or specific letters to find records.
2) In Find mode, click in a field and then Press Ctrl+I (Windows) or Cmd+I (Macintosh) to open the View Index dialog box, which displays the complete list of the active field’s values for all records. You can then scroll down the list (or start typing a name to jump directly to it) and double-click a value to paste it in the active field.

4. From the plant database menu, select File > Create ‘Existing Tree’ List. In the Create Existing Tree List dialog box, click OK to replace the ‘Existing Tree’ list with data from your currently found records.

Next, you set defaults for the Existing Tree tool.

5. From the Site Planning tool set, click Existing Tree, and then select Preferences from the Tool bar.
6. In the Object Properties dialog box, set defaults as desired for:
   - Species data
   - Autonumbering
   - ID tag
   - 2D and 3D appearance (including the selection of 2D component symbols)

   Important: To optimally control visibility and/or graphical attributes of existing tree elements, specify classing wherever possible while setting the default properties.

Next, you adjust attributes of classes specified for existing tree elements.

7. From the menu, select Tools > Organization. In the Organization dialog box, select the Classes tab, and then for each class specified for existing tree elements:
   - Enable the Use at Creation option.
   - Adjust graphical attributes as desired.
   - For classes specified for the canopy and trunk elements, set the texture (Renderworks required) or display color for 3D views.
   - If you want to display a marker, set the marker and line style for the class specified for the tag element.
Next, you place existing trees in the drawing.

8. From the Site Planning tool set, click **Existing Tree**. Click once in the drawing to specify the insertion point, and then click again to set the rotation. If the Object Properties dialog box is displayed, go to step 6. If not, you can continue placing existing trees (press the X key to exit the tool), and then edit their parameters in the Object Info palette.

**Notes:**

1) **The appearance of an existing tree may not match its 2D settings until certain parameters have been specified in the Object Info palette. As examples, the symbols specified for Retain or Remove will not display until you specify the Action; the significance color will not display until you set the significance. This helps you determine at a glance which trees still require your input.**

2) **The parameters of groups of selected trees, or trees on a specific layer, or all trees can be set in a single operation with the Apply options in various Existing Tree dialog boxes.**

3) **Indicate the location of important and less important areas of the site by specifying the significance of each tree or group of trees.**

**Tips and Considerations**

Keep in mind the following tips and considerations when using the new **Existing Tree** tool:

- You can quickly create a schedule for existing trees by importing the Existing Tree Schedule worksheet from the **Existing Tree Schedule.vwx** file (from the Resource Browser Files drop-down list, select **Vectorworks Libraries** in the Libraries section; in the Open dialog box, navigate to the Defaults > Reports~Schedules > Landmark Schedules folder, then open the Existing Tree Schedule.vwx file).

- In your own site drawings with multiple existing trees, you can create a worksheet to use as an “existing tree console” to enter parameter data quickly, or select trees in the drawing directly from the worksheet.

**6.03 New Grade Tool**

**Product: Landmark**

Vectorworks Landmark 2011 adds a new **Grade** tool that lets you annotate terrain slopes on site plan documents. The new parametric grade object can optionally act as a site model pad modifier and, when placed in series, can be used to show (or control) slope characteristics across a surface or identify problem areas by highlighting and/or temporarily selecting grade objects whose grades or elevations fall outside the specified analysis criteria range(s).

There are three primary grade object modes for controlling the difference in elevation and grade percentage between two points you specify:

- **Use Grade Object Heights**: Lets you specify custom heights for both points with absolute values—or with an absolute value for either point and the other point as a relative elevation or grade percentage.

- **Use Heights from Site Model**: Automatically extracts the heights from the existing or proposed site model’s elevation at both points.

- **Change Site Model (Use Grade as Pad Modifier)**: Lets you specify custom heights (as above in the first mode) and then inserts the grade object as a site modifier for the existing or proposed site model. After you create the grade object, you must update the site model to incorporate the change.
**Access**

Site Planning tool set: **Grade**. Click two points to draw a line and display the Grade Settings dialog box. In the Object Properties tab, specify the grade object mode, modify elevation or grade parameters as desired, and then choose which text labels will be displayed. Select the Global Settings tab to adjust graphical attributes or specify grade analysis options for all grade objects in the current document.

The Tool bar also includes the **Edit Elevation** and **Update Grade Object** buttons for existing grade objects.

### 6.04 New Create Stepped Wall Command

**Product: Architect, Landmark**

A new command lets you quickly create accurate stepped walls from a selected wall network by automatically generating wall peaks at evenly spaced intervals, based on the ±Z value of the selected wall(s) and step parameters you specify. The elevation of each wall peak and the Bot Z value for each wall segment is automatically adjusted for the steps, whether you choose to create:

- **Even Steps.** Constant rise determined by three parameters: Step Length, Step Rise, and Total Rise. You choose which one of the three parameters is automatically calculated by values you enter for the other two. You can choose to apply the steps to the wall top, bottom, or both.

- **Terrain Steps.** Variable rise automatically conforms to site model topography, in step lengths that you specify. You can choose to apply the steps to the wall top (terrain steps are always applied to the wall bottom), and whether the steps are placed above or below the terrain.

**Access**

Select one or more connected walls (with appropriate ±Z values, auto-joined in L configurations or joined by the **Wall Join** tool’s **L Join Mode**), and then select (Architect) **AEC > Terrain > Create Stepped Wall** or (Landmark) **Landmark > AEC > Create Stepped Wall** from the menu. In the Create Stepped Wall dialog box, select the step style, adjust applicable step parameters, and then click **OK** to automatically modify the selected wall(s) with stepped wall peaks.

**Tips and Considerations**

Keep in mind the following tips and considerations when using the new **Create Stepped Wall** command:

- You can use the **Select Connected Objects** command to quickly select wall networks.
- You can also use stepped walls to create **retaining wall site modifiers**.
6.05 New Stake Object from 3D Locus Command

**Product: Landmark**

A new command lets you convert selected 3D locus points to stake objects (in-place), which can store Landmark specific data and be recognized as site model modifiers.

**Animation**

Click [here](#) to view an animation of these features.

**Access**

Select one or more 3D locus objects, and then select **Modify > Convert > Stake Object from 3D Locus** from the menu. In the Convert to Stake Object dialog box, adjust stake object functional and display options (and choose whether to keep or delete the source loci), and then click **OK** to create the stake objects, which are all selected by default.

**Tips and Considerations**

Keep in mind the following tips and considerations when using the new **Stake Object from 3D Locus** command:

- Use the **Stake Object from 3D Locus** command to modify an existing site model with stake objects converted from 3D locus points imported from survey data files.
- Use the Select Similar tool to quickly select 3D loci for the conversion.

6.06 Site Model Image Mapping

**Product: Architect, Landmark**

You can now easily map an aerial image to a site model surface with the **Attribute Mapping Tool**.

**Animation**

Click [here](#) to view an animation of these features.

**Access**

Select a site model with an image-based shader texture (applied from the Object Info palette’s Render tab):

Basic palette or Visualization tool set: **Attribute Mapping Tool** or press Shift+A. You can then dynamically move, resize, and rotate the image as required to align it with the site model.

**Note:** To facilitate the mapping operation—at any time while the **Attribute Mapping Tool** is active—you can adjust the display with the zoom controls or boomerang mode (by temporarily holding down the Space bar).
6.07 Improved Site Model Grade Display

Product: Architect, Landmark

In Vectorworks Landmark 2011, the boundaries for colored slopes between contour lines are now perpendicular to the top contour, and all polygons with the same slope are now combined. As a result, slopes are now less triangular and more uniform in appearance. Accordingly, the 2D style 2D Triangulated Contours (colored slopes) option has been renamed 2D Contour (colored slopes).

Animation
Click here to view an animation of these features.

Access
You can select 2D Contour (colored slopes) mode from the 2D Style drop-down list in the Object Info palette or Site Model Settings dialog box:

Menu (new site model): AEC > Terrain > Create Site Model or Landmark > Create Site Model.

6.08 New Cut and Fill Site Model Display

Product: Architect, Landmark

Vectorworks 2011 introduces two new options for physically displaying the topography or areas that were cut and filled, directly on the site model:

- The Cut and Fill option for 3D display mode lets you show the cut and fill as colored topography in 3D views.
- The 2D Cut Fill Area option for site analysis graphic properties lets you show the cut and fill as triangulated polygons in 2D display mode.

Animation
Click here to view an animation of these features.

Access
You can select Cut and Fill mode from the 3D Display drop-down list in the Object Info palette or Site Model Settings dialog box:

Menu (new site model): AEC > Terrain > Create Site Model or Landmark > Create Site Model. To display the Site Model Settings dialog box (existing site model): double-click a site model, or right-click a site model and select Edit from the context menu. Alternately, you can select a site model and click Site Model Settings in the Object Info palette. You can change 3D Cut Volume and 3D Fill Volume default colors in the Site Model tab of the Graphic Properties dialog box (see access below).

You can toggle the 2D Cut Fill Area option and adjust color settings in the Site Analysis tab of the Graphic Properties dialog box: Display the Site Model Settings dialog box (see access above), and then click Graphic Properties, and select the Site Analysis tab.
6.09 Improved 2D Site Model Plans

Product: Architect, Landmark

Vectorworks 2011 includes the following improvements for 2D site model plans:

- A more robust algorithm for 2D Contour (smoothed) display mode now eliminates overlapping or disappearing contours.
- You can now specify contrasting colors in new individual controls for existing and proposed colors of major and minor 2D contours to accentuate the differences in Proposed + Existing 2D display mode.

Animation

Click here to view an animation of these features.

Access

You can change colors for major/minor existing/proposed 2D contours in the Site Model tab of the Graphic Properties dialog box:

(New site model) Menu: AEC > Terrain > Create Site Model or Landmark > Create Site Model.

(Existing site model): Double-click a site model, or right-click a site model and select Edit from the context menu. Alternately, you can select a site model and click Site Model Settings in the Object Info palette.

In the Site Model Settings dialog box, click Graphic Properties, and then select the Site Model tab.

6.10 Improved Site Model Update

Product: Architect, Landmark

In Vectorworks 2011, site model updates are now faster, and the new Save site model cache document preference option—when enabled (default setting)—eliminates the requirement for a site model update each time the file is opened (but increases site model’s file size). Disabling this option reduces the site model’s file size, but requires a site model update each time the file is opened (as in previous versions).

Note: The Object Info palette now only displays the “Projected Area” for a site model (it no longer displays the projected area for the proposed and existing states).

Access

You can toggle the Save site model cache option in the Display tab of the Document Preferences dialog box:

Menu: File > Document Settings > Document Preferences, or right-click a blank area in the drawing and select Document Preferences from the context menu. Alternately, you can click Preferences on the far right side of the Tool bar and select VectorWorks Preferences and then select the Display tab.

To update a site model: Right-click a site model and select Update from the context menu, or select a site model and click Update in the Object Info palette.
6.11 New Site Model Volume List

Product: Architect, Landmark

The new Create Site Model Volume List command creates reports—to provide verification for reviewers or approving agencies—that document all individual calculations used in the creation of the overall cut and fill volume.

You can choose to create an individual report, or simultaneously create any combination of reports in the following formats:

- Tab-delimited text file
- Groups consisting of triangles with report data in text blocks, placed directly on top of the site model's corresponding surface triangles
- Worksheet (only if the limit of 4000 rows for worksheets is not exceeded)

Access

Menu (Landmark): Landmark > Create Site Model Volume List.

6.12 Hardscape Component Classing

Product: Landmark

You can now assign classes to the main area joint pattern and the border joint pattern of a hardscape object to control—or override in viewports—their visibility and display attributes.

Animation

Click here to view an animation of these features.

Access

You can select any class in the current document from the Joint Class and Border Joint Class drop-down lists in the Hardscape Object Settings dialog box:

Site Planning tool set: Hardscape, and then click Preferences.

Note: The Hardscape Object Settings dialog box is automatically displayed after you draw the first site modifier object in a file.

For existing hardscapes, select the hardscape and then click Hardscape Settings in the Object Info palette.
6.13 Improved Hardscape Settings

Product: Landmark

In Vectorworks Landmark 2011, the Hardscape Object Settings dialog box will be revised as follows:

- The Sketch Style field has been removed, and the Tag Display drop-down list has been added to the Definition section.
- The ID Tag Style drop-down list was renamed Tag Style, and “ID” was renamed “Name” in drop-down lists.
- The Draw 3D toggle has been removed and can now be disabled by selecting None from the 3D Type drop-down list.
- The Pad and Texture Bed options in the 3D Type drop-down list were renamed Pad Modifier and Texture Bed Modifier, respectively.

In the Object Info palette’s settings for hardscape objects, the Sketch Style field has been removed and the following options or fields added:

- Draw Border option and related Border Width field
- Border Pattern Size field
- Tag Style drop-down list
- 3D Type drop-down list with None, Slab, Pad, and Texture Bed options
- 3D Thickness field
- Footprint Area, Main Perimeter, Border Perimeter, and Footprint Perimeter informational fields. Footprint Area calculates the area of the entire hardscape’s footprint. Main Perimeter calculates the boundary length of main area polyline. Border Perimeter calculates the length of the footprint perimeter that is bordered. Footprint Perimeter calculates the boundary length of the entire footprint polyline.

Animation

Click here to view an animation of these features.

Access

You can access the new hardscape settings in the Object Info palette or Hardscape Object Settings dialog box:

Site Planning tool set: Hardscape, and then click Preferences.

Note: The Hardscape Object Settings dialog box is automatically displayed after you draw the first site modifier object in a file.

For existing hardscapes, select the hardscape, and then click Hardscape Settings in the Object Info palette.

6.14 New Apply Saved Hardscapes to Existing Hardscapes

Product: Landmark

Vectorworks Landmark 2011 adds drag-and-drop functionality to hardscape definitions so you can easily transfer attributes from a saved hardscape to an existing hardscape.

Animation

Click here to view an animation of these features.

Access

Drag a saved hardscape definition from the Resource Browser and drop it onto an existing hardscape.
6.15 Improved Display of Site Modifiers in 3D

**Product:** Architect, Landmark

The new Show 3D option lets you toggle visibility in 3D views for boundary, grader, and texture bed site modifier objects. Also, the texture bed’s Class parameter (below the Apply To parameter) has been renamed “Texture from Class” and converted to a drop-down list that displays all classes in the current document.

**Access**

For new boundary, grader, and texture bed site modifier objects, you can toggle the Show 3D option in the Object Properties dialog box:

Site Planning tool set: Site Modifiers, and then click Preferences.

**Note:** The Object Properties dialog box is automatically displayed after you draw the first site modifier object in a file.

For existing boundary, grader, and texture bed site modifier objects, you can toggle the Show 3D option in the Object Info palette.
7. **Spotlight**

Vectorworks Spotlight 2011 boosts your design productivity with the following enhancements:

- Fully automatic 3D aiming at focus points and new focus point graphics display options
- New preferences for ganging and lighting device position sensing
- More seating layout options and new default content
- More complete data exchanges with Lightwright

### 7.01 Better Focus Point Support for Lighting Instruments

**Product: Spotlight**

Lighting instruments and everything associated with them—their light source, accessories, associated 3D geometry, and beam—now always point toward the designated focus point, regardless of whether the lighting instrument and focus point objects are actual objects or virtual representations displayed in design layer viewports. As a result of this new capability, movies created with the [Manage Scenes](#) and [Animate Scenes](#) commands now render gobos and shutter cuts correctly inside an animation.

**Animation**

Click [here](#) to view an animation of these features.

**Access**

This feature is fully automatic, without Vectorworks Spotlight controls or options.

**Important:** You must use Spotlight 2011 lighting device symbols or update your own symbols for proper operation of this feature. Search the term “Instrument and Accessory Specifications” in the online Help system for detailed information and instructions for creating compatible symbols.

**Tips and Considerations**

Keep in mind the following tips and considerations when using focus points with design layer viewports:

- If possible, the virtual instance of a lighting instrument (with focus point) in a design layer viewport will point toward a single specific visible instance of its focus point. If one or more visible instances exist, then the most suitable visible focus point will be selected. If no actual or virtual visible focus point instances exist, then the lighting instrument will point toward the invisible actual focus point instance.
- The [Create Plot and Model View](#) command no longer moves an instrument’s focus point (if it resides on another design layer) to the lighting instrument’s design layer.
7.02 Lightwright Data Exchange Improvements

Product: Spotlight

The Lightwright automatic data exchange in Vectorworks Spotlight 2011 now:

- Places new lights created in Lightwright between existing lights on a lighting position in Vectorworks.
- Preserves selection states of lighting devices set by Lightwright.
- Adds the Vectorworks and Lightwright version and build numbers to the data exchange.

Animation

Click [here](#) to view an animation of these features.

Access


7.03 Ganging Tool Preference Dialog Box

Product: Spotlight

A new preference dialog box now lets you specify default settings for the Ganging Tool before placing a 2-fer object.

Access

Spotlight tool set: Ganging Tool, and then click Ganging Tool Preferences in the Tool bar.

7.04 Automatic Position Sensing Preferences

Product: Spotlight

Vectorworks Spotlight 2011 now lets you specify a custom pick radius, or disable automatic positioning for lighting device placement. When the new Enable Lighting Device Auto Positioning option is:

- Enabled (default), the new Pick Radius field is activated (with a default value of 1'6" [457.2mm]). When you move a lighting device, it will either maintain or automatically update its position name and height, based on the proximity of the lighting position(s) inside the specified Pick Radius.
- Disabled, the Pick Radius field is grayed out. The lighting device is only assigned a position during initial placement with the Insertion Tool. Subsequent movements will not update the lighting device’s position name or height. Note that moving a lighting position will still move the lights assigned to that position.

Access

You can toggle the Enable Lighting Device Auto Positioning option and specify the Pick Radius value in the new Positioning tab of the Spotlight Preferences dialog box:

Menu: File > Document Settings > Spotlight Preferences.

You can optionally enable the Save as default option to preserve the settings for all new documents.
7.05 New Options for Seating Layout

Product: Architect, Spotlight

Spotlight 2011 introduces the following new options for seating layouts:

- Display Seating Section Name
- Display Seating Count
- Show Seat Number (based on values you specify in the new Starting Number and Increment fields).

Access


Menu (Spotlight): Spotlight > Architectural > Create Seating Layout.

You can then adjust the new display options for seating layouts in the Object Info palette.

7.06 New Default Event Seating Content

Product: Spotlight

The Create Event Seating command now accesses additional default content from the seating layout default symbols library.

Access

[VectorWorks application folder]\Libraries\Defaults\Seating Layout - Symbols folder

7.07 Improved Focus Point Object Graphics

Product: Spotlight

Vectorworks Spotlight 2011 gives you new shape choices and new display controls for focus point text and graphics. The new Focus Point Shape property lets you select standard focus point shapes or default content from a drop-down list, and the new Show Focus Point Name option in the Object Info palette lets you toggle the display of focus point text. Also, a new preference dialog box lets you specify default settings for the Focus Point Tool.

Access

Spotlight tool set: Focus Point Tool, and then click Focus Point Tool Preferences in the Tool bar.
8. Renderworks

Renderworks 2011 includes a robust new rendering engine, camera and viewport linking, and texture mapping improvements.

8.01 New Renderworks with Cinema 4D Engine

Product: Renderworks

Renderworks 2011 dramatically increases rendering speed and quality by replacing the LightWorks rendering engine with Maxon’s Cinema 4D rendering engine.

Note: Search the terms “Creating and Mapping Textures” and “Rendering the Drawing” in the online Help system for detailed migration information or interface and capability changes.

Animation

Click here to view an animation of these features.

Access

View bar: Current Render Mode > [multiple modes].

Menu: View > Rendering > [multiple modes].

Sheet layer viewport Background Render drop-down list in the Object Info palette.

8.02 Linking Camera and Viewports

Product: Renderworks

Renderworks 2011 now lets you link a RenderWorks camera to a sheet layer viewport so you can use the camera’s view controls to optimize the viewport’s view.

Some examples of the many uses for linked cameras and sheet layer viewports include:

- Creating 3D views with precise control over all view aspects.
- Setting up 3D views to match existing or planned site photography.
- “Documenting” an exact perspective or orthogonal view aspect that can be replicated in the same file (or other files) by copying camera objects, and then pasting them in-place on design layers or inside other sheet layer viewports.
- Verifying object visibility for cameras in stage or studio designs.

Animation

Click here to view an animation of these features.

Access

Visualization tool set: RenderWorks Camera.

Menu: View > Create Viewport.

Process Overview

The following steps describe the general process for creating a linked sheet layer viewport from a RenderWorks camera:
1. Activate the design layer where you want to place the camera, and then activate the Top/Plan view.

2. From the View bar:
   - Adjust visibility of all layers and classes that will affect the view.
   - Enable Unified View mode (if applicable).
   - Adjust the zoom level (if necessary) so that the intended viewer location is visible in the drawing area.

3. From the Visualization tool set, click **RenderWorks Camera**. Click to specify the camera’s viewer location, and then click to specify the camera’s target. If this is the first camera in the file, the Object Properties dialog box is displayed. If not, go to step 5.

4. Adjust settings in the Object Properties dialog box as desired, and then click **OK**.

5. Press the X key once to exit the tool and display the camera grips. In the Top/Plan view, adjust the camera viewing location, target, or viewing angle as necessary by clicking the appropriate grip, and then clicking again to reposition it.

6. In the Object Info palette, adjust settings as necessary, then click **Fine Tune Camera View** to display the Perspective View Controls dialog box and activate the camera view. Adjust the sliders as necessary and verify the settings as the view dynamically updates. When finished, click **OK** to save the settings.

7. With the RenderWorks camera still selected, select **View > Create Viewport** from the menu. In the alert dialog box, click **Yes** to use the camera for the viewport’s view. In the Create Viewport dialog box:
   - Enter a viewport name and drawing title.
   - Select the sheet layer to place it on (or create a new sheet layer).
   - Change any other parameters as necessary (View and Projection parameters are set by the camera).
   - Click **OK** to create the sheet layer viewport and automatically move the camera inside the viewport.

8. If you right-click a viewport and select **Edit Camera** from the context menu, you can:
   - Edit the linked camera’s settings, which subsequently affect the viewport’s view.
   - Remove the link between the viewport and camera by pressing the Delete key.
   - Paste a RenderWorks camera object into an unlinked viewport to create a link between them.

### Tips and Considerations

Keep in mind the following tips and considerations when using cameras linked with viewports:

- The linked camera’s render mode does not affect the viewport’s render mode.
- You can create a viewport with a linked camera to preserve the starting point for walk-throughs in perspective views. To do this, right-click the viewport and select **Edit Camera** from the context menu. With the camera selected in edit camera mode, select **OpenGL** from the Object Info palette’s Render Mode drop-down list, and then enable the **Auto Update 3D View** option. Press Shift+U (for the **Walkthrough** tool shortcut). When finished, click the orange **Return to Viewport** button in the upper-right corner of the drawing area. The viewport’s original camera view is restored.
8.03 Attribute Mapping Tool Improvements

Product: Renderworks

Renderworks 2011 facilitates 2D and 3D texture mapping with the following improvements for the Attribute Mapping Tool:

- The blue-colored 2D mode scale and rotate grips are now always drawn on the texture frame (no longer projected onto the object)—even when the texture frame does not intersect the textured object—to prevent them from disappearing. For planar map types, the texture frame is now always drawn on the blue transparent mapping surface, which automatically resizes as necessary to accommodate the texture frame.

- When you select an object set to an unsupported map type, an alert dialog box is displayed that lets you change the map type.

- Texture parts set to an unsupported map type now appear as options in a different section of the Tool bar’s Part drop-down list. If you select these parts, an alert dialog box is displayed that lets you change the map type.

- The 2D/3D Mapping Modes and 3D Constrained Mode were removed from the Tool bar; the Object Info palette now displays controls for both 2D and 3D modes. Clicking in the texture frame or in a blank area displays the 2D mode scale and rotate grips, and clicking on any of the 3D texture space axes displays the 3D origin and rotation handles. You can activate the 3D mode’s set by face feature by clicking on a face outside of the texture frame.

- The Reset to Default Mapping button has been replaced by the Reset Mapping button, which now resets all parameters modified by the tool.

- For cylinder and sphere map types, the projection lines and a circular cross section of the mapping surface will now always be drawn. Four new grips along the mapping surface edge let you modify the radius of the 3D texture space.

- You can now specify exact values in the data bar when you resize the texture with the scale grip, move the texture frame, or modify the 3D texture space radius for cylinder and sphere map types.

- The working plane is now hidden when the Attribute Mapping Tool is active.

- If you activate the Attribute Mapping Tool when multiple objects are selected, only the first selected object remains selected (all others are automatically deselected).

Animation

Click here to view an animation of these features.

Access

Basic palette or Visualization tool set: Attribute Mapping Tool or press Shift+A. You can either select the textured object first and then activate the Attribute Mapping Tool, or select the textured object after you activate the tool.
Additional Training Materials

Product: All

Click the following links for more information on additional training materials to help you maximize productivity.

- Free Resources
- Training Guides

Access

Web site: [www.nemetschek.net/training/index.php](http://www.nemetschek.net/training/index.php)