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Introduction 
Welcome to Vectorworks Architect! This tutorial will introduce you to key tools and techniques for drawing and editing, and a streamlined workflow 
which provides the proper framework for exploring the full power of Vectorworks Architect on your own. 

Important: For free tutorial updates and instructional videos, visit the Architect Getting Started website. 

Overview of the Modeling Process 
In this thematic tutorial, you use Vectorworks Architect to design a modern vacation home. You begin with a pre-configured (but otherwise blank) 
starting file, and continue using this single file for all design phases and documents. You complete the project by creating various construction 
documents: 
Note: The house design in this tutorial was adapted from the award-winning Dwell Home design by Resolution: 4 Architecture. 

                

                         

As you work through 11 continuing exercises, you develop the house design using a combination of Vectorworks standard and Vectorworks 
Architect tools to complete the following design features in order: 

 Room layouts (walls) 
 Architectural elements (floors, doors, windows, and other symbols) 
 Multiple level features (roof) 
 Construction documents (commonly used) 
 Annotations 

Notes: 
1) Starting with Exercise 3, you can optionally open completed exercise files (available in the Data Set folder) to check your model or to skip 
ahead to the beginning of the next exercise. For example, open the GS-VWAx10.vwx file (completed Exercise 10) to start at the beginning of 
Exercise 11 (see the General Exercise Tips section for more information). 
2) This tutorial focuses on creating or setting up only the most common construction documents for a house design project. 
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How to Use This Tutorial 
This tutorial is provided as an e-Book, in PDF format. You can print any or all pages for reference, or you can view the tutorial on-screen for 
enhanced electronic benefits including navigation links and search features. 

If you choose to view the tutorial on-screen, you can optionally enable Reflow viewing mode (available from the View menu only in the Adobe 
Reader 7 or Adobe Acrobat 7 programs, available from the View > Zoom menu in newer versions) to display the text with a wrapping effect 
similar to a web browser. You can then adjust the Zoom level, and resize both the tutorial and Vectorworks windows to display them side-by-side 
as shown. 

 
 

Notes: 
1) You can review workflow sequencing and locate specific procedures by scanning the process lists at the start of each section. The process lists 
are also hyperlinked to facilitate navigation. 

2) If you view the tutorial on-screen, look for the Previous View  and Next View  tools at the bottom of the screen (or available in the 
Page Navigation toolbar in newer versions). These useful tools—available in Adobe Reader and Acrobat—let you revert or repeat navigational 
changes by page controls, bookmarks, and hyperlinks. 
 
3) If you use Reflow viewing mode with the Adobe Reader window configured as shown in the figure above, you may need to temporarily increase 
the size of the window to see details in larger figures. 

4) The Adobe Reader Search tool  provides more extensive options for searching text than the Find command. 
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General Exercise Tips 
Use the following tips to facilitate working with your exercise drawing files: 

 Read each step carefully and make sure your results match the figures. If your results vary from the figures, stop immediately and review 
the previous steps. If you can’t find the problem quickly, start the exercise over with the appropriate supplied file. 

 Alternate methods are shown for activating many tools, commands, and modes. Use the method that works best for you. 
 In many cases, you must click in the drawing area after using the Navigation palette before continuing with the next step. 
 Watch for SmartCursor cues that appear when you hover your cursor over significant drawing object geometry. Pause briefly over snap 
points to display the red snap box, and watch for the red confirmation dot displayed temporarily after you complete the snap. When too 
many red snap boxes are displayed in congested areas, press the Esc key once to clear the display. 

 For some operations, additional view adjustments may be required. For these cases, press the Z key for the Snap Loupe shortcut, or use 
the Zoom, Pan, and Fit to Objects tools as required. If you have a mouse wheel, use it to zoom in and out. 

 To pan across the drawing at any time (even if a tool or command is active) hold down the Space Bar and drag the cursor. 
 If you inadvertently cleared a selection required for an active tool or command, press Space Bar+X temporarily, and then select the 
object(s). 

 Many tools have different operational modes, which you can select in the Tool bar (located above the drawing window). 
 Keep the Object Info palette open (to open it, select Window > Palettes > Object Info). It displays valuable information, and provides 
access to key properties of selected objects. 

 Press the Esc key to cancel any operation. If you are using a tool, it will still be active, but you can then start drawing again or choose 
another tool. Sometimes, you must press the Esc key before you use a keyboard shortcut to activate another tool. 

 Use the Undo command in the Edit menu to revert steps as necessary (both drawing and view changes are reverted). 
 For tools that create multiple segments (such as the Wall tool) press the Delete key once while the tool is active to revert a single segment, 
or press it repeatedly to revert additional segments. 

 If multiple files are open, you may need to click the Resource Browser’s Home button  if your house file isn’t active. 
 Object artifacts may remain in the drawing area after some drawing and editing operations. To refresh the screen and clear the artifacts, 

double-click the Pan tool  (in the Basic tools palette). 
 Save your files often to prevent data loss. 

Important: 
1) Exercise steps in this tutorial are based on default preference settings from a new installation of the Vectorworks Architect program. Results for 
some steps may vary from the figures if your preference settings differ from the defaults. 
2) Close any open files before you open a completed exercise file (only if you plan on using it to start the next exercise). 

Using Metric Units with Exercises 
All exercise data set files for this tutorial are set to use imperial units. If you want to use metric values for the exercise steps, enter the values 
exactly as shown in [square brackets, with the unit mark], and Vectorworks will convert the values accordingly. If you want to measure distances 
or drawing objects for reference, use the appropriate dimension tool and object snaps to create temporary dimensions, which are set by default to 
display alternate units in metric values. Delete the temporary dimensions when finished. 

Note: For proper exercise operation—and to validate your results with the imperial figures—do not change the document's units setting to metric. 
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Checking Your Work 
The GS-VWAxCheck.vwx file is included in the Data Set folder so you can verify the accuracy of your file. If you want to use this file to check your 
work: 

1. Copy the Data Set folder to any location on your hard disk. 

2. In Step 3 of Exercise 1, open the GS-VWAx01.vwx file in the Data Set folder, and then save the file under the name House.vwx in the Data 
Set folder on your hard disk. 

Notes: 
1) Before you use any of the supplied files to start any other exercise, save your current file under a different name, and then open the read-only 
file (from the Data Set folder on your hard disk) and save it as House.vwx in the Data Set folder. 
2) You must name your file “House“ and save it in the Data Set folder to ensure the GS-VWAxCheck.vwx file works properly. 

3. After saving your House.vwx file at the end of exercises 3 through 11, open the GS-VWAxCheck.vwx file from the Data Set folder on your 
hard disk, and then follow the exercise-specific checking instructions exactly as shown in the last steps of the exercise. 

Keyboard Shortcuts 
All keyboard shortcuts included in this guide are based on the Windows operating system. If you’re using a Mac, use the Option key instead of the 
Alt key, and use the Cmd key instead of the Ctrl key. Refer to the Vectorworks 2010 Shortcuts PDF file (available from the Online Help) to print a 
complete list of your own keyboard shortcuts. 
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Section 1: Program Installation and Setup 
In this section, you start by installing the Vectorworks Architect program. Following installation, two exercises cover the following program setup 
and interface adjustment processes: 

 Activating the Architect workspace (pg 7) 
 Opening the starting file (pg 8) 
 Adjusting Vectorworks preferences (pg 9) 
 Adjusting snapping settings (pg 10) 
 Adjusting Grid and Smart Point settings (pg 10) 
 Setting the default font (pg 11) 
 Adjusting the Navigation palette display (pg 11) 

In these exercises, you activate (or reset) the Vectorworks Architect interface, and then you adjust program preference settings and adjust the 
interface. 

Installing the Vectorworks Architect Program 
Note: If you have already installed Vectorworks Architect, start with step 2 below. 

1. Follow the installation instructions in the ReadMe file located in the root folder of your installation DVD. 

2. Start the program. You can do this by selecting Programs > Vectorworks2010 > Vectorworks2010 from the Windows Start Menu. 

3. From the menu, select Help > Check for Updates. If updating is necessary, follow the on-screen instructions. 

4. After updating, close Vectorworks (if it’s still running) to reset the program. 
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Exercise 1: Launching the Program and Opening the Starting File 
In this exercise, you launch the application and activate the Vectorworks’ Architect workspace. After a brief orientation of the Architect interface, 
you then open the supplied starting file. 

Activating the Architect workspace 
You start by launching the Vectorworks program. 

1. From the Windows Start Menu, select Programs > Vectorworks2010 > Vectorworks2010. 

2. From the menu, select Tools > Workspaces > Architect. If the Architect workspace is already active, select it again to reset the interface. 
Position the Navigation palette where shown, and examine key areas of the interface identified in the following figure. 
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Tool Sets 

Resource Browser

Object Info palette

Attributes palette 

Message bar 

Scroll bar 
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Program Installation and Setup  Vectorworks 2010 - 7 



Getting Started with Vectorworks Architect   

Opening the starting file 
Next, you open the supplied starting file. To save time, this starting file contains many pre-configured resources, and is already fully set up for 
creating a two story structure without a basement. 

Note: Before you open the supplied starting file, see Checking Your Work in the Introduction. 

3. From the menu, select File > Open. In the Open Vectorworks Drawing dialog box, open the Data Set folder and open the read-only  
GS-VWAx01.vwx file. The page boundary is displayed, and it’s ready for laying out the first floor room areas. 

4. From the menu, select File > Save As, and save the file under the name House.vwx. 

You can now skip ahead to Exercise 2, or you can use the Online Help to review the following commands that were used to set up this file: 
 Document Setup – Specifies layer scale, drawing area (page setup), sheet border, and title block settings used by the  
Create Standards Viewports command. 

 Model Setup – Creates basic design layers, with appropriate height settings for 3D objects. 
 Create Standard Viewports – Creates design layer, sheet layer, sheet layer viewport, and class schemes appropriate for selected 
construction documents. Also creates matching “working” views, which you use throughout the project to facilitate file navigation. 

 Standard Naming – For enabling the Auto-classing option to assign class names and attributes to many of the objects you create. 
Visibility of these classes is handled automatically in sheet layer viewports and saved views generated by the Create Standard Viewports 
command. 

Notes: 
1) Design layers are used in architectural projects as spatial containers for creating drawing objects. 
2) Sheet layers provide a 2D-only page layout environment for printing. 
3) Sheet layer viewports are individual 2D “live camera view” objects that reside on sheet layers, but display 2D and 3D drawing objects on design 
layers. When you modify drawing objects on a design layer, the viewport itself doesn’t change, but it displays the changes in the design layers. 
4) Classes are used to control display properties of drawing objects. 
 
Important: As you start the tutorial, do not be concerned if you don’t fully understand the file structure and setup commands. As you progress 
through the exercises, you will see how the file structure works in context of a design project.
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Exercise 2: Adjusting Preference Settings 
In this exercise, you verify and adjust program preferences. 

Adjusting Vectorworks preferences 
Next, you verify or adjust key application preference settings to ensure proper exercise operation, turn on scroll bars to facilitate navigation, and 
increase the maximum number of undos so you can revert exercise steps if necessary. 

1. From the menu, select Tools > Options > Vectorworks Preferences. In the Vectorworks Preferences dialog box, select the Edit tab, and then 
verify or adjust settings as shown (keep the dialog box open for the next three steps). 

 

2. Select the Display tab, and enable the Scroll bars option, and then verify or adjust other settings as shown. 
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3. Select the Session tab, and then enter 100 in the Maximum number of undos field. Verify or adjust other settings as shown. 

 

4. Select the Interactive tab, and then change the cursor’s Selection box size, and Snap box size, and verify or adjust other settings as shown. 
Click OK to save the settings and close the dialog box. 

 

Adjusting snapping settings 

5. Verify or adjust options in the Snapping palette (as shown), and then click the X in the palette’s upper right corner to close it. 

 

Adjusting Grid and Smart Point settings 

6. Press Ctrl+8 to display the SmartCursor Settings dialog box, and then select Grid from the Category list. Clear the Show Grid Lines and Print 
Grid Lines checkboxes, and verify or adjust other settings (.125” [3.18mm], 1/2" [12.70mm]) as shown at left. From the Category list,  
click Smart Point, and verify or adjust settings, as shown at right. Click OK to close the dialog box and save the changes. 
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Setting the default font 
Next, you adjust the default font. 

7. From the menu, select Text > Font > Arial to set the default font (if it’s not set to Arial already), and then select Text > Size > 12 to set the 
default font size to 12 point (if it’s not set to 12 already). 

Adjusting the Navigation palette display 

8. If your Navigation palette is not already displayed, from the menu, select Window > Palettes > Navigation. If necessary, expand the 
Navigation palette by dragging the lower right corner to resize it. 

 

9. In the Attributes and Navigation palettes, turn on Auto Hide  (Window Shade for Mac). 
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Section 2: Laying Out Room Areas 
In three exercises, this section covers the following processes in the home design project: 

 Drawing connected walls (pg 13) 
 Applying geometric constraints to walls (pg 15) 
 Adjusting dimension preferences (pg 16) 
 Dimensioning walls (pg 17) 
 Dynamically adjusting the layout (pg 17) 
 Precisely adjusting the layout (pg 18) 
 Drawing the functional area walls (pg 22) 
 Drawing the pantry wall (pg 23) 
 Dimensioning walls (pg 24) 
 Copying walls for the second floor plan (pg 26) 
 Joining walls (pg 27) 
 Applying geometric constraints to walls (pg 28) 
 Drawing remaining walls (pg 29) 
 Dimensioning walls (pg 29) 
 Inserting a stair object (pg 30) 
 Modifying the stairwell, foyer, and deck walls (pg 31) 

In these exercises, you work on design layers as you start the design by drawing wall objects (using unique wall styles for maximum flexibility) in 
approximate proportions. You then: 

 Place geometric constraints on related walls. 
 Automatically create associative dimensions for all walls. 
 Use a combination of dynamic and precise methods to progressively tighten the accuracy and define basic spatial relationships of the 
rooms. 

Note: Although you can also use space planning tools and massing models, this tutorial covers tools for drawing walls directly. 
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Exercise 3: Drawing Exterior Walls 
In this exercise, you draw the exterior walls to define the first floor envelope. 

The completed exercise is shown in the following figure. 

 

Drawing connected walls 
You start the exercise by setting an appropriate zoom level, and then you draw four walls using the 6.5" [165.1mm] Generic Ext style to 
represent the storage room. 

1. If you did not complete Exercise 2—or you are unsure of your file’s accuracy—open the GS-VWAx02.vwx file. 

2. From the View bar, click Fit to Page Area . From the Building/Shell tool set, click Wall . In the Tool bar,  
select 6.5" [165.1mm] Generic Ext from the Wall Style drop-down list (if it’s not already active). 

Note: Before you continue, click here to view an animation of steps 3 through 9. 

3. Draw four connected walls in clockwise order, starting at the lower left corner, approximately where shown at left (use the page border for 
approximate positional reference): Draw the first two segments, and then use angle snaps and acquire a Smart Point (see Note 2 below figure) 
at the starting vertex to control the length of the third segment to keep the walls square. 

 
Notes: 
1) Draw exterior connected walls in a clockwise direction ensures that the interior and exterior sides are oriented correctly. 
2) Before you draw the last segment, pause the cursor briefly over the starting vertex until the smart point is acquired (red box displayed). Pause 
the cursor one time to acquire a smart point, pause the cursor a second time to clear a smart point. 
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4. From the Basic tools palette, click 2D Selection . In the Tool bar, make sure the Enable Connected Walls Mode  option is enabled. 
Drag two of the walls to verify the connections, as shown. 

                         
Next, you draw the L shaped exterior walls that define the perimeter of the functional area and living room. 

5. Press the 9 key for the Wall tool shortcut. Use the same drawing technique to draw six connected walls in clockwise order, starting at the lower 
left, approximately where shown. 

 

6. Press the X key for the 2D Selection tool shortcut. Drag various walls from the L shaped room to verify the connections, as shown. 
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Applying geometric constraints to walls 
Next, you apply colinear constraints to four walls to maintain the distance between them and their alignment. 

7. Press the X key twice to clear the current selection. From the Basic tools palette, click the Zoom tool . In the Tool bar, make sure 

Marquee Zoom Mode  is active, and then draw a marquee around the area shown (at left) to zoom in. From the Dims/Notes tool set,  

hold down the left mouse button on the Constrain Coincident tool  to open the flyout palette, and then click Constrain Colinear , 
as shown at right.  

                      

8. Click the midpoints of the wall segments in order, (shown at left) to place colinear constraints between the midpoints and constrain the walls 
along their centerlines (notice the horizontal colinear constraint indicators ), as shown at right. 

           

9. Press the X key and any drag one of the upper and one of the lower constrained walls to verify the constraints (both constrained walls move 
together), as shown. Press the X key twice to clear the current selection. From the View bar, click Fit to Page Area  to adjust the display. 
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Adjusting dimension preferences 
Next, you verify or adjust dimension creation and precision preferences. 

10. Right-click a blank area and select Document Preferences. In the Document Preferences dialog box, select the Dimensions tab. Verify or 
adjust settings (8 Mils [.2032mm]) as shown, and then click OK. 

 
Dimension Notes: 
1) Associative dimensions “attach” themselves to drawing objects by placing parametric constraints on vertices of selected geometry. Parametric 
constraints let dimensions move and update values when you move or resize associated geometry, or (for linear and chain dimensions only) 
modify associated geometry if you change the Length parameter. 
2) To turn off display of the parametric constraints, select Tools > Options > Vectorworks Preferences from the menu, and then select the 
Display tab and turn off the Show Parametric Constraints option (leave the display on for these exercises). 
3) If the Associative Dimensions option is disabled, any dimensions you create will not be attached to—or control—geometry you snap to. 
4) The Dimension Exterior Walls command optionally creates associative dimensions, but it cannot create them for all objects. 
5) Refer to the Online Help’s Associative Dimensioning topic for more information. 
6) In your own files, you can create or import custom dimension standards and use them individually, or to replace default standards (in the active 
drawing only) if you need to adjust any parameters such as Offset Text size. Refer to the Online Help’s Using Custom Dimension Standards topic 
for more information. 
7) For your own drawings with dimensions based on multiple standards, you can set the current dimension standard from the Tool bar when any 
dimension tool is active. 

11. From the menu, select File > Document Settings > Units. In the Units dialog box, select the General Display and Dimensions tab. Verify or 
adjust settings, as shown at left. Select the Dual Dimensions tab, and then verify or adjust settings as shown at right. Click OK to save the 
settings. 
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Dimensioning walls 
Next, you use the Dimension Exterior Walls command to automatically dimension the first floor exterior walls. 

12. From the menu, select AEC > Dimension Exterior Walls. In the Dimension Exterior Walls dialog box, adjust settings as shown at left, and then 
click OK to create the dimensions. Press the X key twice to clear the current selection. Examine the completed dimensions, shown at right  
(your values will vary; you remove duplicate dimensions later in this exercise). 

      

Dynamically adjusting the layout 
Next, you use different methods to dynamically resize and reposition the exterior walls as you continue to refine the building envelope. 

13. From the Basic tools palette, click 2D Selection . In the Tool bar, make sure the Enable Connected Walls Mode  option is active. 
Drag individual connected wall segments, starting with the vertical walls from right to left, and then the horizontal walls from top to bottom, 
approximately as shown. As you would when you dynamically refine spatial relationships in your own designs, try to get within ±1’-0” [.305m] of 
the dimensions shown (do not reposition dimensions until later in this exercise). Notice that the dimensions update to reflect changes and 
provide instant positional and size feedback as you adjust the layout (leave the 2D Selection tool active for the next four steps). 
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14. In the Tool bar, click the Enable Connected Walls Mode  option to disable it, and then make sure the Enable 2D Cursor Rectangular 

Selection Mode  option is enabled. Draw a marquee selection as shown at left. Move the entire selection by dragging any selected wall 
to the right until the distance between the rooms is between 27’-0” [8.230m] and 29’-0” [8.839m], as shown at (notice that all selected walls and 
dimensions move together). Now that the “closed loop” move operation is complete, reset the default status of the Enable Connected Walls 
Mode option by pressing the P key to toggle (enable) it. 

                                       

Warning: Drag closed loops with the Enable Connected Walls Mode  option disabled only when all connected walls are selected.  
Partial selections will be disconnected from unselected walls. 

Tip: You can use the 2D Reshape tool  to resize subsets of selected walls. Refer to the Architect Getting Started website page for more 
information. 

Precisely adjusting the layout 
Next, you edit the length parameter of key dimensions to precisely adjust the size and position of all walls. 

15. Double-click the vertical dimension text to activate editing mode, as shown at left. Click the bottom fix point (circled for clarity) to select it, or 
press the Tab key repeatedly to toggle fix points until the bottom fix point is selected. Enter a new value of 15’9” [4.801m], and then press Enter 
to accept the new value. The dimension and walls update to reflect the change, as shown at right. 
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16. Repeat the length parameter editing process for the other five key dimensions in the order shown. Click or use the Tab key to control the fixed 
positions (circled, with corresponding key dimension numbers) as required (see Note below figure). 

 Dimension 1: 26'1" [7.950m] 
 Dimension 2: 21'9" [6.629m] 
 Dimension 3: 28'9" [8.763m] 
 Dimension 4: 15'9" [4.801m] 
 Dimension 5: 9'9" [2.972m] 

 
Note: Your initial dimensions may vary. If a dimension edit causes an unintentional change to another dimension, press Ctrl+Z for the Undo 
command shortcut to revert the change, and try again with a different fix point. 

Next, you use the 2D Selection tool and the floating data bar to index the house position with the file's origin. 
Note: You move the layout to ensure proper operation with the supplied exercise checking file. In your own designs, you may find it helpful to 
index the design with the origin for more meaningful world coordinates (because the entire design resides in the positive XY quadrant for 
Cartesian coordinates), and for more predictable results when referencing files. 

17. From the Basic tools palette, click the Select Similar tool  Click one of the walls (away from the dimensions), and then confirm all 10 walls 
are selected in the Object Info palette, as shown at left. Press the X key, and then press the P key to toggle off Enable Connected Walls 
Mode. Start dragging the lower left corner endpoint (shown in the next figure; if necessary, press the Z key and make sure you drag the 
endpoint, as shown in the next figure). Move your cursor slightly (do not release the left mouse button) and then press Tab five times to highlight 
the X value in the floating data bar. Enter 0 (zero) for the value, and then press tab and enter 0 (zero) for the Y value. Press Enter twice to move 
the selected walls. Press the P key to toggle Enable Connected Walls Mode on, and press the X key twice to clear the selection. Press Ctrl+6 
for the Fit to Objects shortcut to see the entire layout. Notice that the rulers confirm the lower left corner is on the origin (0,0), as shown at right. 

             
Tip: Use the snap loupe whenever you need to temporarily zoom in and select a point. For best snap loupe performance, press Ctrl+8, select the 
General Category, and then disable the Zoom Line Thickness in Snap Loupe option. 
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Next, you delete duplicate dimensions, and then you reposition the remaining dimensions to clean up the drawing. 

18. Right-click the text of the dimensions circled at left (one at a time), and select Delete Dimension from the context menu to remove them from 
the drawing. Drag the remaining dimensions (by dimension lines; not text) into place, approximately where shown at right. 

                      
 

Next, you lock all dimensions to prevent inadvertent changes. 

Note: The walls won’t change position or resize when you lock all associated dimensions, but you can still modify wall properties and insert 
objects into them. 

19. From the menu, select Window > Script Palettes > Scripts. Drag the Scripts palette to the left of the Navigation palette, and then double-click 
the Custom Select All Dims script. All dimensions are now selected. Right-click the text of one of the dimensions, and select Lock from the 
context menu. The selection highlight color turns gray (and the Object Info palette updates) to indicate all selected objects are locked,  
as shown. 

 
 

20. Press the X key twice to clear the selection, and then press Ctrl+S to save the file. 
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If you set up your files as instructed in the Checking Your Work section, you can now optionally check the accuracy of your file. 

21. Open the (read-only) GS-VWAxCheck.vwx file. In the Navigation palette, double-click the 01 Floor Plan-1 saved view to activate it, and then 
double-click the Check EX03 saved view to activate it. 

22. Use the Zoom  and Pan  tools (in the Basic tools palette), and the Previous View tool  (in the View bar) as necessary to 
examine the drawing. Your drawing objects are displayed in red, and the master file’s drawing objects are displayed in their default colors. You 
should see your red drawing objects overlaid directly on top of the master file’s drawing objects (check dimensions for completeness; ignore 
dimension alignment). 

23. After checking your file’s accuracy, close the active file (your House.vwx file should now be active). If your drawing is inaccurate, close your file 
and continue with the next exercise by starting with the supplied file. 
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Exercise 4: Drawing Interior Walls 
In this exercise, you draw and dimension the internal walls. 

The completed exercise is shown in the following figure. 

 

Drawing the functional area walls 
You start the exercise by drawing walls using the 4.5" [114.3mm] Generic Int style. 

1. If you did not complete Exercise 3—or you are unsure of your file’s accuracy—open the GS-VWAx03.vwx file. 

2. Press the 9 key for the Wall tool  shortcut. In the Tool bar, select the 4.5" [114.3mm] Generic Int wall style. To start the first segment, 
move your cursor over the left vertical wall, and then click the wall (when it’s highlighted), approximately where point 1 is shown at left. 
Complete the first segment by holding down the Shift key and clicking approximately where point 2 is shown at left. Complete the second 
segment by holding down the Shift key to vertically constrain the cursor, and then snap to the existing wall approximately where point 3 is 
shown at left (when the exterior wall is highlighted). Notice that the internal walls were automatically joined at the corner, and to the existing 
walls on both exterior ends, as shown at right (leave the Wall tool active for the next three steps). 
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3. Use the Shift key to draw two vertical wall segments, and another L shape series with a corner connection, approximately where shown 
(highlighted for clarity; to start and terminate connections with existing wall, click when existing walls highlight). 

 

Drawing the pantry wall 
Next, you draw a vertical interior wall in-line with—and connected to—an exterior wall. 

4. Right-click the vertical wall segment on the inside of the L, and select Send > Send to Front from the context menu as shown at left.  

In the Tool bar, enable Right Control Line Mode . Move your cursor to the lower left vertex of the vertical wall segment, and then click the 
existing wall (when it’s highlighted and the Endpoint SmartCursor cue is displayed), as shown at center. Complete the pantry wall segment by 
holding down the Shift key to vertically constrain the cursor, and then snap to the horizontal interior wall directly below (when it’s highlighted). 
Press the X key twice to clear the selection. Notice that the pantry wall was automatically joined at both ends, as shown at right. 

                                     
 

Notes: 
1) You send this vertical segment to the front to facilitate an automatic connection when you draw the wall segment in the next step. 
2) Notice that the Wall tool stays active when you use the context menu to change the wall’s stacking order. 
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Next, you join the horizontal wall to complete the intersection. 

5. From the Building Shell tool set, click Wall Join , then click T Join Mode  in the Tool bar. Click wall segments in order, 
approximately where shown at left. The wall intersection is joined and trimmed, as shown at right. 

                                     

Dimensioning walls 
Next, you create linear dimensions, add dimensions to an existing chain dimension, and then you modify the length values to precisely position 
the interior walls. 

6. From the Dims/Notes tool set, click Constrained Linear Dimension . In the Tool bar, make sure Constrained Linear Mode  is 
active. Snap to the appropriate wall endpoints (see Notes below figure) to create two constrained linear dimensions, as shown (highlighted). 

 
Notes: 
1) Snap to the endpoints marked with green squares, which indicate the parametric constraint points of associative dimensions. 
2) The first two clicks determine dimension points (if prompted, accept default wall selections); the third click orients and places the dimension. 
3) Pick up points of existing dimension geometry, and then use SmartCursor cues to align new dimensions as you create them. 
4) Make sure the dimensions you create are associative (green squares are displayed on both ends). If not press Ctrl+Z and try again. 
5) Press the X key, and then drag dimension lines or text if you need to move either. 

Next, you unlock two of the existing chain dimensions so you can add dimensions for the interior walls. 

7. In the Scripts palette, double-click the Custom Select All Dims script to activate it. Right-click any of the selected dimensions, and select 
Unlock from the context menu. Right-click the 25’-6” [7.772m] dimension and select Add Dimension from the context menu. Click the vertical 
wall endpoint to add a dimension, as shown at left. Add three more dimensions (to the right-most dimension), as shown at right. 
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8. Press the X key, and then double-click each dimension and change the values to match the following figure (change the fixed point as 
necessary; see Notes below figure). 

 
Notes: 
1) You only need to adjust the four left chain dimensions; the 4’-5” [1.346m] dimension on the right side will be corrected automatically. 

2) If you experience a bug that alters any wall T-joins when you change dimension values, use the Wall Join tool  with T Join Mode  
to re-create the joins. 

Next, you lock all dimensions. 

9. In the Scripts palette, double-click the Custom Select All Dims script. Right-click one of the selected dimensions, and select Lock from the 
context menu. 

10. Press the X key twice to clear the selection, and then press Ctrl+S to save the file. 

If you set up your files as instructed in the Checking Your Work section, you can now optionally check the accuracy of your file. 

11. Open the (read-only) GS-VWAxCheck.vwx file. In the Navigation palette, double-click the 01 Floor Plan-1 saved view to activate it, and then 
double-click the Check EX04 saved view to activate it. 

12. Use the Zoom  and Pan  tools (in the Basic tools palette), and the Previous View tool  (in the View bar) as necessary to 
examine the drawing. Your drawing objects are displayed in red, and the master file’s drawing objects are displayed in their default colors. You 
should see your red drawing objects overlaid directly on top of the master file’s drawing objects (check dimensions for completeness; ignore 
dimension alignment). 

13. After checking your file’s accuracy, close the active file (your House.vwx file should now be active). If your drawing is inaccurate, close your file 
and continue with the next exercise by starting with the supplied file. 
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Exercise 5: Drawing Second Floor Walls, and Adding a Stair 
In this exercise, you copy a subset of walls from the Mod-Floor-1 layer, and then you paste them in-place on the Mod-Floor-2 layer to start the 
second floor plan. Next, you clean up wall intersections, and then you constrain the exterior second floor walls to the mating first floor walls. You 
then complete the exercise by inserting a stair object and modifying the layout to fit the stair configuration. 

The completed exercise is shown in the following figure. 

 

Copying walls for the second floor plan 
You start the exercise by copying ten walls, and then you paste them in place in the Mod-Floor-2 layer to start the second floor plan. 

1. If you did not complete Exercise 4—or you are unsure of your file’s accuracy—open the GS-VWAx04.vwx file. 

2. Press Ctrl+6 to display the entire floor plan. Press the X key, and then hold down the Shift key and select the ten walls shown. 

 

3. In the Object Info palette, verify that 10 walls are selected, then press Ctrl+C to copy them. In the Navigation palette, select the Saved Views 
tab, and then double-click the Floor Plan-2 saved view to activate it (in the View bar, notice the Mod-Floor-2 layer is now active, as shown at 
left). From the menu, select Edit > Paste in Place to copy the walls to the same X and Y coordinates on the second floor, as shown at right. 
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Joining walls 
Next, you use the Wall Join tool to clean up wall intersections and corners. 

4. Press the X key twice to clear the current selection. From the Building Shell tool set, click Wall Join , then click L Join Mode  in the 
Tool bar. Click wall segments in order, approximately where shown at left. The wall corners are joined and trimmed, as shown at right. 

Important: Be careful to avoid clicking too close to the end of each wall segment. If you click at the end of the segment, the walls will not join 
properly. 

                 
 

Note: If you experience a bug that alters any existing wall joins in the previous or next steps, use the Wall Join tool  with either 

 L Join Mode  or T Join Mode  as appropriate to re-create the join. 

5. With the Wall Join tool still active, click wall segments 1 and 2 in order, approximately where shown at left, and then click T Join Mode  in 
the Tool bar. Click wall segments 3 through 8 in order, approximately where shown at left. Press the X key twice to clear the current selection. 
You can now see that all wall corners are appropriately joined and trimmed, as shown at right. 

                      
 

6. In the Navigation palette, select the Design Layers tab, and then (as shown at left): 
 Select Show/Snap/Modify Others from the Layer Options drop-down list. 
 Turn on visibility of the Mod-Floor-1 layer. 

In the Scripts palette, double-click the Toggle Dimension Class Visibility script to hide all dimensions, as shown at center. Drag all second 
floor exterior walls slightly outside the walls on the first floor (as shown) to verify all corners are connected. 
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Applying geometric constraints to walls 
Next, you apply geometric constraints to the second floor walls to link their length and position with the mating first floor walls. 

7. From the Dims/Notes tool set, click Constrain Colinear . Click wall midpoints in the order shown at left (use the zoom controls and scroll 
bars as necessary; see Notes below figure) to constrain the exterior second floor walls to the mating first floor walls (shown at right; notice the 
second floor’s three interior walls were moved – shown highlighted for clarity). 

              
 

Notes: 
1) If an error message is displayed after you click the second point for a constraint, try zooming in closer. 
2) If a second floor wall moves over a first floor wall after another wall segment is constrained, move the second floor wall away from the first 
before you apply a constraint. 
3) Only the second floor walls move when constraints are applied, because the dimensions on the Mod-Floor-1 layer are locked. 

8. Use the Constrain Colinear  tool to constrain the three second floor interior walls to their mating walls on the first floor, as shown at left. 
Press the X key twice to clear the current selection (in case anything is selected), and then press Ctrl+6 to adjust the display. Examine the 
current layout, as shown at right. 

                                        
 
Note: The combination of geometric (colinear) and dimensional constraints in this model provide additional design benefits that are not covered in 
this tutorial. Refer to the Architect Getting Started website page for more information. 
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Drawing remaining walls 
Next, you draw the remaining interior second floor walls in their approximate positions. 

9. In the Navigation palette, select the Saved Views tab, and then double-click the Floor Plan-2 saved view to activate it. The Mod-Floor-2 layer 

is now active, and the Mod-Floor-1 layer is now invisible. From the Building/Shell tool set, click Wall . In the Tool bar, make sure the  
4.5" [114.3mm] Generic Int wall style is still active. Use the Shift key to draw the remaining the interior walls approximately where shown 
(highlighted for clarity). 

 

Dimensioning walls 
Next, you use the same dimension/modification technique as the previous two exercises (with minimal instruction) to complete the second floor 
layout. 

10. Use either the Dimension Exterior Walls command, or the Constrained Linear Dimension tool  with Constrained Chain Mode  
(see Notes below figure) to create associative dimensions, and then change the length and fixed points as necessary to precisely position the 
interior walls from the previous step, as shown (with chain dimensions). 

 
Notes: 
1) The dimensions shown are the only dimensions required to complete the second floor interior wall layout; all other walls are constrained to the 
first floor walls (see Note 3). Dimensions for all second floor walls required for construction documentation are not necessary for this exercise. 
2) To automatically associate dimensions with T-joined wall intersections with the Dimension Exterior Walls command: Select Centerlines from 
the Dimension to Wall drop-down list, and select Center of Openings from the Dimension to drop-down list in the Dimension Exterior Walls dialog 

box. If you prefer dimensions to wall edges, use the Constrained Linear Dimension tool , and double-click the snap point in the chain to 
terminate the dimension string. 
3) Any dimensions associated with second floor exterior walls will also control mating (constrained) walls on the first floor, even though the first 
floor walls already have dimensions associated with them. Vectorworks allows multiple-dimension control (from dimensions in design layers and 
sheet layer viewport annotations) over associated objects. 

4) If you experience a bug that alters any existing wall joins in the previous or next steps, use the Wall Join tool  with either  

L Join Mode  or T Join Mode  as appropriate to re-create the join. 
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Inserting a stair object 
Next, you insert a custom stair plug-in object. You then drag and nudge the stair object into position. 

11. In the Navigation palette, double-click the Floor Plan-1 saved view to activate it. In the Scripts palette, double-click the Toggle Dimension 
Class Visibility script to hide all dimensions. 

Note: You can use the Toggle Dimension Class Visibility script at any time in any of the exercises to check dimensions or hide them to reduce 
clutter. 

12. From the Building Shell tool set, click Custom Stair . In the Tool bar, click Wall Insertion Mode  if it’s active to turn it off, and then 

enable the Align Object Left  option. Snap first to the corner and then snap to the wall edge, where shown at left. The stair object is 
created (shown at center). Press the X key, and then move the stair object by dragging the upper right corner of the platform and releasing it on 
the top right inside corner of the stairwell, as shown at right. 

                          
 

Note: The Custom Stair tool was pre-configured for this file. The Stair Settings dialog box would normally be displayed for the first custom stair 

object inserted in a file. For subsequent insertions in your own files, click Preferences  from the Tool bar before placing the custom stair to 
set default parameters. If you change Stair Settings dialog box parameters, all subsequent insertions are affected. 

13. Zoom in on the stairs by pressing Ctrl+6 for the Fit To Objects shortcut, and then hold down the Shift key and then press the Left and Down 
arrow keys one time each to make sure the stairs are close to the walls, but not touching them, as shown. 
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Modifying the stairwell, foyer, and deck walls 
Next, you shorten the stairwell divider wall to accommodate the stair platform and handrails. 

14. From the View bar, click Previous View , and then press the X key and select the stairwell divider wall below the stair (notice the selection 
highlight is visible under the stair object). Click the top grip when the resize cursor  and SmartCursor Point cue is displayed to “pick up” the 
endpoint (do not snap to another point after you click the top grip, or the wall will not remain vertical). Move your cursor, then press the Tab key 
three times and enter 0 for the ±X value, and then press Enter. Notice the vertical constraint indicator, as shown at left. Move your cursor to the 
inside edge of the horizontal stair handrail, and then press the Z key for the Snap Loupe shortcut (to temporarily zoom in). Click the midpoint of 
the stair handrail’s inside edge to resize the wall (and close the snap loupe), as shown in the next figure. In the Object Info palette, select Start 
from the Caps drop-down list, as shown in the next figure. Click in a blank area of the drawing to clear the selection and examine the wall cap, 
shown at right. 

                                                    
 

Next, you use the 2D Reshape tool to shorten the kitchen wall’s left edge to make a 3’ wide opening into the foyer. 

15. In the Scripts palette, double-click the Toggle Dimension Class Visibility script to show all dimensions. Right-click the 6’-2 1/4" [1.886m] 

dimension and select Unlock from the context menu. From the Basic tools palette, click the 2D Reshape . Make sure that the  

Move Polygon Handles Mode  is active in the Tool bar. Select the horizontal kitchen wall. Click the left grip to “pick up” the endpoint, and 
then move the cursor to display the floating data bar. Type 3’ for the ±X value, press tab and enter 0 (zero) for the ±Y value, and then press 
Enter twice to complete the reshape operation, as shown at left. In the Object Info palette, select Start from the Caps drop-down list. From the 

Building Shell tool set, click Remove Wall Breaks . Draw a marquee from lower left to upper right approximately as shown at center (see 
Note below figure). Notice that the wall break was removed (the wall line is now continuous). Lock the 6’-2 1/4" [1.886m] dimension, and then 
press the X key twice to clear the selection. Examine the shortened wall, as shown at right. 

                                 
 

Note: Remove only the wall break of the vertical wall (do not remove the wall break on the left edge of the horizontal kitchen wall). 
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Next, you change the height of the deck and stairwell walls to make balustrade walls. You then shorten the stairwell wall. 

16. In the Navigation palette, double-click the Floor Plan-2 saved view to activate it. Notice that the custom stair object inserted in the Mod-Floor-1 
layer is also displayed in the (currently active) Mod-Floor-2 layer. In the Scripts palette, double-click the Toggle Dimension Class Visibility 
script to hide dimensions. Press the X key twice, and then hold down the Shift key and select the 6 walls shown at left. In the Object Info 
palette, disable the Link Wall Height to Layer ±Z option, and then change the ±Z value (3’0” [.914m]), as shown at center. Click a blank area, 
and then select the stairwell wall. Click the top grip, hold down the Shift key, then click the right front stair edge to resize the wall. Use the 

Remove Wall Breaks  tool to remove the break at the resized end, and then select Start from the Caps drop-down list in the Object info 
palette to complete the stairwell wall, as shown at right. 

                                                                         

17. In the Scripts palette, double-click the Toggle Dimension Class Visibility script to show the dimensions. Press the X key twice to clear the 
selection, and then press Ctrl+6 to adjust the display. Examine the completed second floor walls, as shown. 

 

18. Save the file. 

If you set up your files as instructed in the Checking Your Work section, you can now optionally check the accuracy of your file. 

19. Open the (read-only) GS-VWAxCheck.vwx file. In the Navigation palette, double-click the 01 Floor Plan-1 saved view to activate it, and then 
double-click the Check EX05 saved view to activate it. 

20. Use the Zoom  and Pan  tools (in the Basic tools palette), and the Previous View tool  (in the View bar) as necessary to 
examine the drawing. Your drawing objects are displayed in red, and the master file’s drawing objects are displayed in their default colors. You 
should see your red drawing objects overlaid directly on top of the master file’s drawing objects. 

21. In the Navigation palette, double-click the 02 Floor Plan-2 saved view to activate it, and then double-click the Check EX05 saved view to 
activate it. 
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22. Use the Zoom  and Pan  tools (in the Basic tools palette), and the Previous View tool  (in the View bar) as necessary to 
examine the drawing. Your drawing objects are displayed in blue, and the master file’s drawing objects are displayed in their default colors. You 
should see your blue drawing objects overlaid directly on top of the master file’s drawing objects. 

23. After checking your file’s accuracy, close the active file (your House.vwx file should now be active). If your drawing is inaccurate, close your file 
and continue with the next exercise by starting with the supplied file. 
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Section 3: Creating Architectural Elements 
In two exercises, this section covers the following processes in the home design project: 

 Saving settings for the Select Similar tool (pg 35) 
 Creating a floor slab from the first floor exterior walls (pg 37) 
 Changing floor slab properties (pg 37) 
 Inserting doors (pg 38) 
 Copying a door using Ctrl+drag (pg 38) 
 Creating different door types (pg 39) 
 Creating a cased opening (pg 41) 
 Inserting windows (pg 41) 
 Examining the design in a 3D view (pg 43) 
 Saving a 3D reference view (pg 44) 
 Creating a floor slab from the second floor exterior walls (pg 46) 
 Creating a floor slab from a rectangle (pg 47) 
 Copying and inserting the remaining doors and windows (pg 48) 
 Examining the design in various 3D views (pg 51) 

In these exercises, you continue working in 2D floor plans (on design layers) as you: 
 Create floor slabs from existing geometry. 
 Refine the house design by inserting a variety of architectural elements (intelligent plug-in objects). 

After inserting architectural elements, you use simple view controls to examine the 3D objects that were created automatically by the 2D tools. 
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Exercise 6: Creating the First Floor Plan 
In this exercise, you create a floor object, and then you place common architectural elements in the first floor plan. 

The completed exercise is shown in the following figure: 

 

Saving settings for the Select Similar tool 
You start by saving two configurations of attribute matching settings for the Select Similar tool. 

1. Open the GS-VWAx05.vwx file in the Data Set folder. In the Navigation palette, activate the Floor Plan-1 saved view. In the Scripts palette, 
double-click the Toggle Dimension Class Visibility script to hide all dimensions. 
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2. From the Basic tools palette, click the Select Similar tool . In the Tool bar, click Select Similar Preferences . In the Select Similar 
Preferences dialog box, verify or adjust settings as shown at left. In the Selection Options section, click Save. In the Assign Name dialog box, 
enter Object for the name, as shown at center. Click OK to save the settings. Notice that the Object saved setting is now displayed in the  
Use Saved Settings drop-down list (and is now active), as shown at right (keep the Select Similar Preferences dialog box open). 

                               

3. In the Other section, enable the Class option, as shown at left. Click Save and save the settings as Class and Object, as shown at center. 
With the new Class and Object saved setting active (as shown at right), click OK to save the settings (leave the Select Similar tool active). 
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Creating a floor slab from the first floor exterior walls 
Next, you create a polygon from the first floor’s exterior walls, and then you create a floor object from the polygon. 

4. With the Select Similar tool still active, click any exterior wall. All first floor walls (confirm 10 in the Object Info palette) with the Wall-Exterior 
class are selected. From the menu, select AEC > Create Polys from Walls. In the Create Polys from Walls dialog box, select only the  
Gross Area Polys option (shown at left), and then click OK. Two polygons are created and are now the active selection, as shown at right. 

                                  

5. From the menu, select AEC > Floor. In the Create Floor dialog box, enter the values shown at left (1'4" [.406m]), and then click OK. The floor is 
created and displayed in the Object Info palette, as shown at right. 

                   
Notice that even though the entire floor object resides below the Z height of the walls, it is displayed on top of them due to the creation order (or 
stacking order) of objects in the Mod-Floor-1 layer. 

Changing floor slab properties 
Next, you change the floor object’s class and layer properties. 

6. In the Object Info palette, change the Floor object’s: 
 Class property to Structural-Slab (if a message dialog box is displayed, enable the Always do the selected action option, and click Yes) 
 Layer property to Mod-Slab-1. The floor object seemingly disappears (see Note below figure), but is actually present under the walls 
because of the layer order saved in the Floor Plan-1 view, as shown. 

 
Note: The floor object no longer appears selected because of the Floor Plan-1 saved view’s layer option settings. If you activate the  
Mod-Slab-1 layer (but do not activate it now), you would see that the floor object is still selected. 

Creating Architectural Elements  Vectorworks 2010 - 37 



Getting Started with Vectorworks Architect   

Inserting doors 
Next, you use the Door tool to insert a plug-in object. 

7. Zoom in on the kitchen and functional area, as shown at left. From the Building Shell tool set, click the Door tool . 
 Click the foyer wall approximately where shown in the next figure. 
 Move your cursor to orient the door as shown in the next figure (notice how your cursor position flips the door side and swing), and then 
click to place the door plug-in object, as shown at right. 

                               
 

Note: The Door tool was pre-configured for this file. The Door Settings dialog box would normally be displayed for the first door object inserted in 

a file. For subsequent insertions in your own files, click Preferences  from the Tool bar before placing the door to set default door 
parameters. If you change Door Settings dialog box settings, all subsequent insertions are affected. 

8. In the Object Info palette, verify a “Door In Wall” is selected (as shown). If not, drag the door to reinsert it in the wall (leave the door selected for 
the next step). 

 

Copying a door using Ctrl+drag 
Next, you create two more doors by copying the existing door object dynamically by dragging it while pressing the Ctrl key. 

9. Hold down the Alt key, and then click Zoom In/Zoom Out  (repeatedly if necessary) until the storage room is visible. Press the X key, and 
then Hold down the Shift and Ctrl keys and drag the foyer door (drag it from its insertion point; the middle of the door’s wall break) to create a 
copy (highlighted at left) in the storage room wall. If your copied door doesn’t break the wall, try again and release the mouse button when the 
Object/Horizontal SmartCursor cue is displayed. In the Object Info palette, click the Flip button one time to change the swing as shown. Hold 
down the Ctrl key and drag the foyer door to create the front door, approximately where shown (highlighted) at right. 
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Creating different door types 
Next, you copy one of the 3’ wide door objects and then you modify the copy to create a 2’6” [.762m] wide door. 

10. Press the X key twice, and then use the Ctrl+drag method to copy the front door (by its insertion point; the midpoint of its wall break) to the 
center of the stairwell closet wall, as shown at left. In the Object Info palette (shown at center), adjust the new door’s settings: 

 Change the Door Width to 2’6” [.762m] 
 Change the Door Height to 6’8” [2.032m] 
 Change the Open Angle to 15, and then press Enter to incorporate the change 
 Click the Flip button as necessary to orient the door as shown at right. 

                                     
 

Note: You change the open angle to 15 degrees so you can easily distinguish the 2’6” [.762m] wide door. 

11. Zoom in on the area shown at left. Press the X key, and then use the Ctrl+drag method to copy the stairwell closet door to the bathroom wall, 
approximately where shown at right. 

                                                  

Creating Architectural Elements  Vectorworks 2010 - 39 



Getting Started with Vectorworks Architect   

Next, you use the same copy and modify method to create a bi-part pantry door, and slider doors for the living room. 

12. Use the Ctrl+drag method to copy the bathroom door to the pantry wall, as shown at left. In the Object Info palette, change the new door’s: 
 Width to 2’0” [.610m] 
 Configuration to Swing Bi-part 
 Open Angle to 30 

Drag the bi-part door if necessary to reposition it, and then use the Ctrl+drag method to create a second bi-part door in the pantry wall, 
approximately where shown (highlighted) at right. 

                                     

13. Use the Ctrl+drag method to copy the 3’ [.914m] wide foyer door to the left living room wall, approximately where shown at left. In the Object 
Info palette, edit the new door’s Door Width (7’0” [2.134m]), and Configuration properties, as shown at center. Use the Ctrl+drag method to 
create a copy above, and then select both and use Shift+Ctrl+Drag to copy both to the opposite wall to create a total of four slider doors, in the 
orientations (use the Flip option as necessary) and approximate positions, as shown at right. 
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Creating a cased opening 
Next, you use the 3’ wide door to create a cased opening. 

14. Use the Ctrl+drag method to copy the 3’ wide foyer door to the horizontal bathroom wall, approximately where shown at left. In the Object Info 
palette: 

 Change the Configuration to Cased Opening. 
 Scroll down, and change the Jamb Width to 0 (zero) and press Enter to incorporate the change. 
 Scroll up and click Set Position. Click the wall corner (circled at left) for the reference point, and then click the cased opening’s lower left 
vertex for the object point. Adjust settings in the Enter Offset dialog box, as shown at center, then click OK to set the cased opening’s jamb 
flush with the wall edge, as shown at right. 

                                 

Inserting windows 
Next, you activate the Window tool, and then you insert two windows. 

15. Press the X key twice to clear the selection, and then from the Building Shell tool set, click the Window tool . 
 Click once to position the window in the left kitchen wall, approximately where shown at left. 
 Click outside and to the left of the kitchen to specify the rotation. The window plug-in object is created, as shown at center. 
 With the Window tool still active, insert another window in the wall (click outside to specify rotation), as shown at right. 

           
 

Note: The Window tool was pre-configured for this file. The Window Settings dialog box would normally be displayed for the first window object 

inserted in a file. For subsequent insertions in your own files, click Preferences  from the Tool bar before placing the window to set default 
window parameters. If you change Window Settings dialog box settings, all subsequent insertions are affected. 
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Next, you change properties of the last window to create a 7’ [2.134m] wide picture window. 

16. With the window still selected, confirm in the Object Info palette that the window is in the wall, and then: 
 Change the Overall Width to 7’0” [2.134m] 
 Change the Overall Height to 8’0” [2.438m] 
 Scroll down and change the Num V Muntins to 1 
 Change the Muntin Width to 4” [101.60mm] 
 Change the Muntin Depth to 1” [25.40mm], and then press Enter to update the window, settings 
 Drag the window so that its outside top jamb edge is flush with the inside edge of the living room wall, as shown. 

 
 

17. Press the X key, and then use the Shift+Ctrl+drag method (and the Ctrl+drag method) to copy the 7’ [2.134m] wide picture window seven times 
(highlighted for clarity) for a total of eight picture windows, as shown (see Note below figure). 

 
 

Note: Ctrl+drag automatically orients window exteriors. 
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Next, you copy the 2’ [.610m] wide window. 

18. Use the Ctrl+drag method to copy the small window one time, and then select both and use Ctrl+drag to copy both windows to create a total of 
four 2’ [.610m] wide windows, approximately where shown (highlighted for clarity). 

 
 

Note: In your own designs, you would now create associative dimensions for the windows and doors, (and edit length values as necessary). To 
save time, you skip this step in this exercise and in Exercise 7. Instead, you optionally create window and door dimensions later in Exercise 11. 

Examining the design in a 3D view 
Next, you activate different 3D views so you can examine the architectural elements you just inserted. 

19. Press the X key twice, and then press Ctrl+6 to adjust the display. From the Basic tools palette, click the 3D Selection tool . Notice that 
2D object details (such as door swings and wall breaks) disappear because a 3D top view is automatically activated, as shown at left. From the 
View bar, select the  Left Isometric view from the Standard View drop-down list, and then press Ctrl+6 to adjust the display. The viewing 
angle is changed, as shown at right. 

                   
 

Notice that: 
 Even though you were previously working in 2D, Vectorworks Architect automatically created 3D objects. 
 2D objects such as the living room rectangle (on the active layer), and the 3D floor object (on the Mod-Slab-1 layer) did not react to the 
view change. 

Note: Do not be concerned about the inappropriate single hung windows, you change properties of all windows later in Exercise 9. 
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Next, you adjust Unified View mode options, and then you activate Unified View mode to see only 3D objects in correct alignment. 

20. In the View bar, double-click the Unified View button . In the Unified View Options dialog box, adjust the options as shown at left, and then 
click OK to save the settings. In the View bar, click Unified View , and then press Ctrl+6 to adjust the display. Notice that the 2D objects 
disappeared, and the floor object on the Mod-Slab-1 layer is now aligned (or unified) with the active layer, as shown at right. 

          

Saving a 3D reference view 
Next, you save a view with the current display attributes that you use in other exercises later in the tutorial. 

21. In the Navigation palette, select the Saved Views tab, and then right-click the blank area below the list and select New. In the Save View dialog 
box, change the View Name and Layer Options, and confirm (or adjust) other settings as shown at left, and then click OK to save the view. 
Notice that the new view is now displayed in the list with the 3D view icon , as shown at right. 
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22. In the Navigation palette, activate the Floor Plan-1 saved view. Press Ctrl+5 for the Top/Plan view shortcut, and then press Ctrl+6 to adjust the 
display, as shown. 

 

23. Save the file. 

If you set up your files as instructed in the Checking Your Work section, you can now optionally check the accuracy of your file. 

24. Open the (read-only) GS-VWAxCheck.vwx file. In the Navigation palette, double-click the 01 Floor Plan-1 saved view to activate it, and then 
double-click the Check EX06 saved view to activate it. 

25. Use the Zoom  and Pan  tools (in the Basic tools palette), and the Previous View tool  (in the View bar) as necessary to 
examine the drawing. Your drawing objects are displayed in red, and the master file’s drawing objects are displayed in their default colors. You 
should see your red drawing objects overlaid directly on top of the master file’s drawing objects. 

26. After checking your file’s accuracy, close the active file (your House.vwx file should now be active). If your drawing is inaccurate, close your file 
and continue with the next exercise by starting with the supplied file. 
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Exercise 7: Creating the Second Floor Plan 
In this exercise, you use a variety of 2D and 3D tools and techniques to complete the second floor plan. 

The completed exercise is shown in the following figure: 

 

Creating a floor slab from the second floor exterior walls 
You start the exercise by creating a polygon from the exterior walls, which you then use to create the upstairs floor object. 

1. If you did not complete Exercise 6—or you are unsure of your file’s accuracy—open the GS-VWAx06.vwx file. 

2. In the Navigation palette, activate the Floor Plan-2 saved view. In the Scripts palette, double-click the Toggle Dimension Class Visibility 
script to hide all dimensions. Press the X key twice to clear the current selection, and then press Ctrl+6 to adjust the display. 

3. From the Basic tools palette, click the Select Similar tool . In the Tool bar, make sure that the Class and Object saved setting is active, 
and then click any exterior wall. All second floor walls (confirm 7 in the Object Info palette) with the Wall-Exterior class are selected. Press the X 
key, and then hold down the Shift key and click the three balcony balustrade walls (over the living room) to remove them from the selection set 
(only 4 walls should now be selected), as shown. 
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4. From the menu, select AEC > Create Polys from Walls. In the Create Polys from Walls dialog box, select only the Gross Area Polys option 
(shown at left), and then click OK. A polygon is created and is now the active selection, as shown at right. 

           

5. From the menu, select AEC > Floor. In the Create Floor dialog box, enter the values (2’5 [.737m]) as shown at left, and then click OK to create 
the floor. In the Object Info palette, change the Floor object’s Class property to Structural-Slab, and then change its Layer property to  
Mod-Slab-2 to correct the display order, as shown at right. 

                         
 

Note: You notch the second floor slab to accommodate the stairwell later in Exercise 9. 

Creating a floor slab from a rectangle 
Next, you draw a rectangle, which you then use to create a floor object for the deck over the living room. 

6. From the Basic tools palette, click the Rectangle tool . In the Tool bar, make sure Rectangle Mode  is active. Snap to the top left 
balustrade wall corner (shown at left) and then snap to bottom right corner to draw the deck rectangle, as shown at right. 
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7. In the Object Info palette, confirm that the selected rectangle’s Width is 15’9” [4.801m] and the Height is 26’1” [7.950m]. From the menu, select 
AEC > Floor. In the Create Floor dialog box, enter the values (2’5 [.737m]) as shown at left, and then click OK to create the floor. In the Object 
Info palette, change the Floor object’s Class property to Structural-Slab, and then change its Layer property to Mod-Slab-2 to correct the 
display order, as shown at right. 

               
 

Notes: 
1) You could combine the deck floor with the floor created from the walls, but they are created separately in this tutorial because of their structural 
and functional differences. 
2) Although the deck surface would normally have a slightly lower elevation than the floor surface for drainage purposes, they are both the same 
elevation (both slabs are the same thickness) in this tutorial for display purposes. 

Copying and inserting the remaining doors and windows 
Next, you copy doors and windows from the first floor (that you created in Exercise 6), and then you copy and modify them as necessary to 
complete the second floor plan. 

8. In the Navigation palette, activate the Floor Plan-1 saved view. Press the X key twice, and then right-click one of the bi-part pantry doors, and 
select Create Similar Object from the context menu. If a message dialog box is displayed (shown at left), enable the Don’t show this dialog 
again option, and then click OK. In the Navigation palette, activate the Floor Plan-2 saved view. Insert the bi-part door into the middle of the 
hall closet wall and orient it as shown at right. 

               
 

9. Press the X key, and then use the Ctrl+drag method to copy the bi-part door into the guest bedroom closet wall, as shown at left (use the Flip 
option if necessary). With the new closet door still selected, change the Door Width to 4’2” [1.270m] in the Object Info palette. Drag the new 
door into position, as shown at center. Use the Ctrl+drag method to copy the 4’2” [1.270m] door, approximately where shown at right. 
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10. Repeat the Create Similar Object process (step 8) to create a 2’6” [.762m] wide door from the first floor and position it in the middle of the 
second floor’s master bedroom hallway wall and orient it as shown at left. Press the X key, then use Ctrl+drag and Flip option to copy the  
2’6” [.762m] wide door four times (highlighted for clarity) in the orientations and approximate locations shown at right. 

                       

11. Repeat the Create Similar Object process to create a 7’ [2.134m] slider door from the first floor and position it in the second floor’s family room 
wall and orient it as shown at left. Press the X key, then use the Ctrl+drag method to create an adjacent copy of the 7’ [2.134m] slider, 
approximately where shown at right. Use the Flip control as necessary. 

                                       

12. Repeat the Create Similar Object process to create a 7’ [2.134m] wide picture window from the first floor plan and position it in the second 
floor’s master bedroom wall, and then click outside the wall to orient it as shown at left. Use the Ctrl+drag method to copy the 7’ [2.134m] wide 
picture window eight times, approximately where shown at right (highlighted for clarity). 

                  

13. Repeat the Create Similar Object process to create a 2’ [.610m] wide window from the first floor plan and position it in the second floor’s 
master bedroom hallway wall, and then click outside the wall to orient it as shown (leave the window selected for the next three steps). 

 
 

Tip: In your own designs, you can adjust layer visibilities (with Show/Snap Others layer mode active), and then Ctrl+Alt+click objects on other 
layers to activate the Create Similar Object command. 

Next, you use the Move by Points tool to precisely move and copy the 2’ wide window in the master bedroom hallway wall to complete the floor 
plan. 

14. Zoom in on the area shown. 
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15. Press Shift+M for the Move by Points tool shortcut. In the Tool bar, enable Move Mode . For the start point, click the selected window’s 
midpoint, as shown as left. For the end point, click the insertion point of the master bedroom walk-in closet’s door, as shown at center. The 
window stays in the wall, and is now centered with the walk-in closet’s door, as shown at right (leave the window selected for the next step). 

                                         

16. With the Move by Points tool still active, snap to the same midpoint on the window as the previous step, and then hold down the Ctrl key and 
then snap to the insertion point of the master bathroom door’s opening, as shown at left. The window is copied and the copy is now centered 
with the master bathroom’s opening, as shown at right (leave the copied window selected and the Move by Points tool active for the next step). 

                                            
 

Note: Holding down the Ctrl key temporarily enables the Retain option for the original object. 

17. Use either the Ctrl+drag method or the Move by Points tool  to create fourteen additional copies of the 2’ wide window, where shown 
(highlighted for clarity). 

 
 

Note: In your own designs, you would now create associative dimensions for the windows and doors, (and edit length values as necessary). To 
save time, you skip this step in this exercise (as you did in Exercise 6). Instead, you optionally create window and door dimensions later in 
Exercise 11. 
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Examining the design in various 3D views 
Next, you edit the Unified Isometric saved view to display additional layers and classes, and then you examine the new elements with the 
Flyover tool and Unified View mode. 

18. In the Navigation palette, activate the Unified Isometric saved view. Press the X key twice to clear the selection. Notice that the saved view 
does not show objects on the second floor, as shown. 

 

19. In the Navigation palette, right-click the Unified Isometric saved view and select Edit. In the Edit Saved View dialog box, click Layers. Adjust 
visibilities as shown at left, and then click OK. Click Classes, and turn on visibility of the Roof-Main class. Click OK twice to save the edits. 
Double-click the saved view to see the change, and then press the X key twice to clear the selection, as shown at right. 

                                
 

Note: To save time, you just turned on visibility for objects that don’t exist yet, but you create them later in the tutorial. 
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20. From the Basic tools palette, click the Flyover tool . In the Tool bar, make sure Interactive Origin Mode  is enabled. Start 
dragging the cursor to dynamically examine the model. Press Ctrl+6 to re-center the view. Click to stop the motion, and change the center of 
rotation by clicking on various object vertices (on the active layer), and then continue dragging the cursor to change the viewing angle. 

         

21. In the Navigation palette, activate the Floor Plan-2 view. From the menu, select View > Align Layer Views. In the Scripts palette, double-click 
the Toggle Dimension Class Visibility script to hide all dimensions. Press Ctrl+5, and then press Ctrl+6 to adjust the display. 

22. Save the file. 

If you set up your files as instructed in the Checking Your Work section, you can now optionally check the accuracy of your file. 

23. Open the (read-only) GS-VWAxCheck.vwx file. In the Navigation palette, double-click the 02 Floor Plan-2 saved view to activate it, and then 
double-click the Check EX07 saved view to activate it. 

24. Use the Zoom  and Pan  tools (in the Basic tools palette), and the Previous View tool  (in the View bar) as necessary to 
examine the drawing. Your drawing objects are displayed in blue, and the master file’s drawing objects are displayed in their default colors. You 
should see your blue drawing objects overlaid directly on top of the master file’s drawing objects. 

25. After checking your file’s accuracy, close the active file (your House.vwx file should now be active). If your drawing is inaccurate, close your file 
and continue with the next exercise by starting with the supplied file. 
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Section 4: Working with Multiple Levels 
In two exercises, this section covers the following processes as you continue the home design project: 

 Saving a “working” view for the roof (pg 54) 
 Creating the flat roof (pg 55) 
 Creating gabled ends on the flat roof (pg 56) 
 Examining the completed roof (pg 56) 
 Editing windows (pg 57) 
 Creating a corner window (pg 58) 
 Modifying the second floor’s floor slab (pg 58) 

In these exercises, you: 
 Create a flat roof, and then change its configuration by modifying roof edge settings. 
 Modify windows. 
 Convert two windows into a corner window. 
 Notch the second floor’s floor slab. 
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Exercise 8: Creating and Modifying the Roof 
In this exercise, you create a flat roof object, and then you modify its configuration. 

The completed exercise is shown in the following figure: 

                             

Saving a “working” view for the roof 
Next, you save a view to facilitate working with the roof later in the development cycle. 

1. If you did not complete Exercise 7—or you are unsure of your file’s accuracy—open the GS-VWAx07.vwx file. 

2. From the View bar, enable Unified View  viewing mode. In the Navigation palette: 
 Select the Classes tab, and turn on visibility of the Roof-Main class. 
 Select the Design Layers tab, turn on visibility of the Mod-Roof layer, and then make it the active layer, as shown at left. 
 Select the Saved Views tab, right-click the blank area below the list and select New. In the Save View dialog box, adjust the View Name 
and Active Class settings as shown at center, and then click OK to save the view. 

 Notice that the new view is displayed in the list, as shown at right. 
 Double-click the Roof Model saved view to activate it (in the View bar, notice that Roof-Main is now the active class). 
 Select the Design Layers tab and make the Mod-Floor-2 layer active. 
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Creating the flat roof 
Next, you create a flat roof object from the second floor’s exterior walls. 

3. From the Basic tools palette, click the Select Similar tool . In the Tool bar, make sure that the Class and Object saved setting is active, 
and then click any exterior wall. All second floor walls (confirm 7 in the Object Info palette) with the Wall-Exterior class are selected. Press the X 
key, and then hold down the Shift key and click the three balcony balustrade walls (over the living room) to remove them from the selection set 
(only 4 walls should now be selected). 

 

4. With the four walls still selected, select AEC > Create Roof from the menu. In the Create Roof dialog box, change settings as shown at left 
(click OK if the message dialog box shown at right is displayed). 

            
Tip: In your own designs, you can specify either a Rise:Run ratio (in inches), or angle value (in degrees) for the Roof Pitch. 

5. Click OK to create the roof. Notice that only the roof object is now visible. In the Navigation palette, select the Saved Views tab and activate the 
Roof Model saved view. Objects on the Mod-Floor-2 layer are now also visible, as shown. 
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Creating gabled ends on the flat roof 
Notice that Vectorworks created a hip roof by default. Next, you modify the roof to create the desired gabled ends. 

6. Select the roof’s left control point, as shown at left. In the Edit Roof Settings dialog box, select the Gable option, and then click OK to create the 
gable end, as shown center. Repeat the process to change the right and front sides to gable ends, as shown at right. 

                                               

Examining the completed roof 
Next, you examine the flat roof in various 3D views. 

7. In the Navigation palette, select the Saved Views tab and activate the Unified Isometric saved view. Press the X key twice to clear the 
selection, and then from the View bar, select OpenGL from the Render Mode  drop-down list. Switch to various standard 3D views, or 

use the Flyover tool  to examine the completed roof, as shown. 

                    

8. In the Navigation palette, activate the Floor Plan-2 view. From the menu, select View > Align Layer Views. In the Scripts palette, double-click 
the Toggle Dimension Class Visibility script to hide all dimensions. Press Ctrl+5, and then press Ctrl+6 to adjust the display. 

9. Save the file. 

If you set up your files as instructed in the Checking Your Work section, you can now optionally check the accuracy of your file. 

10. Open the (read-only) GS-VWAxCheck.vwx file. In the Navigation palette, double-click the 03 Roof Model saved view to activate it, and then 
double-click the Check EX08 saved view to activate it. Your roof is displayed in green, and the master file’s roof is displayed in its default color. 
You should see your green roof overlaid directly on top of the master file’s roof. 

11. After checking your file’s accuracy, close the active file (your House.vwx file should now be active). If your drawing is inaccurate, close your file 
and continue with the next exercise by starting with the supplied file. 
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Exercise 9: Editing Architectural Elements 
In this exercise, you edit various architectural elements to complete the basic house design. 

The completed exercise is shown in the following figure: 

                      

Editing windows 
You start the exercise by simultaneously modifying properties of all windows. 

1. If you did not complete Exercise 8—or you are unsure of your file’s accuracy—open the GS-VWAx08.vwx file. 

2. In the Navigation palette, activate the Unified Isometric saved view. From the Basic tools palette, click the Select Similar tool .  
In the Tool bar, select Object from the Active Settings drop-down list, and then click any window. In the Object Info palette: 

 Verify 37 window objects are selected. 
 Change the Sash Operation to Casement (wait a few seconds for the windows to update after each change). 
 Scroll down and change the Sash Width to 3” [76.20mm], and press Enter. 
 Change the Sash Depth to 4” [101.60mm], then press Enter. Press the X key twice, and notice that all windows were modified, as shown. 
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Creating a corner window 
Next, you change properties of the two smaller master bedroom windows to create a corner window. 

3. Hold down the Shift key, and then select the two windows shown at left. Press Ctrl+6 to zoom in, then scroll down to the bottom of the Object 
Info palette, and then: 

 Enable the Corner Window option. Notice that both windows automatically move to the corner position. 
 Select Mitered Sash from the Corner Condition drop-down list, and examine the mitered sash, as shown in the next figure. 
 Select Corner Post from the Corner Condition drop-down list, and change the Size to 5” [127.00mm]. Press Enter to update the windows, 
and examine the corner post, as shown in the next figure. 

 Select Flush Glass from the Corner Condition drop-down list, and then click in a blank area to clear the selection. The completed corner 
window is shown at right. 

                                           

Modifying the second floor’s floor slab 
Next, you notch the second floor’s floor slab at the stairwell. 

4. In the Navigation palette, activate the Floor Plan-2 view. Press Ctrl+5, and then press Ctrl+6 to adjust the display, and then zoom in on the 
area shown at left (notice the window sash width and depth changes from step 2). Right-click the floor to the left of the stairwell balustrade, and 

select Force Select. The Mod-Slab-2 layer is automatically activated. Use the Rectangle tool  to draw a rectangle by snapping to the 
point of the stair’s up arrow, and then snapping to the bottom flight’s up line anywhere above the first point, approximately where shown in the 

next figure. From the Basic tools palette, click Visibility . In the Tool bar, click the Visibility for Classes  and Invisible  
buttons to enable them. Click the stair object to turn off visibility of its class. Press 4 for the Rectangle tool shortcut, and then snap to balustrade 
wall vertices to draw a second rectangle, as shown in the next figure. Press the X key and select the first rectangle, and then resize it by clicking 
its top right grip and snapping to the inside wall corner (you can optionally press the Z key to temporarily zoom in), as shown at right. 
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5. Shift+select the stairwell rectangle to add it to the selection (2 rectangles should be selected), as shown at left. Right-click the selection, and 
then select Add Surface to combine both rectangles into a single polygon, as shown at right. 

                         

6. Hold down the Shift key, and select the floor object to add it to the current selection. Right-click the selection, and then select Clip Surface to 
clip the polygon from the floor. Press the Delete key to remove the clipping polygon, and notice the floor’s stairwell notch (shown at left). In the 
Navigation palette, select the Saved Views tab and activate the Floor Plan-2 saved view to display the stairs, as shown at right. 

                       

7. In the Navigation palette, activate the Unified Isometric saved view. Use 3D view controls and OpenGL render mode to examine the model  
(as shown). In the Navigation palette, activate the Floor Plan-1 saved view. From the menu, select View > Align Layer Views. Press Ctrl+5, 
and then press Ctrl+6 to adjust the display. 

                      

8. Save the file. 
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If you set up your files as instructed in the Checking Your Work section, you can now optionally check the accuracy of your file. 

9. Open the (read-only) GS-VWAxCheck.vwx file. In the Navigation palette, double-click the 01 Floor Plan-1 saved view to activate it, and then 
double-click the Check EX09 saved view to activate it. 

10. Use the Zoom  and Pan  tools (in the Basic tools palette), and the Previous View tool  (in the View bar) as necessary to 
examine the drawing. Your drawing objects are displayed in red, and the master file’s drawing objects are displayed in their default colors. You 
should see your red drawing objects overlaid directly on top of the master file’s drawing objects. 

11. In the Navigation palette, double-click the 02 Floor Plan-2 saved view to activate it, and then double-click the Check EX09 saved view to 
activate it. 

12. Use the Zoom  and Pan  tools (in the Basic tools palette), and the Previous View tool  (in the View bar) as necessary to 
examine the drawing. Your drawing objects are displayed in blue, and the master file’s drawing objects are displayed in their default colors. You 
should see your blue drawing objects overlaid directly on top of the master file’s drawing objects. 

13. After checking your file’s accuracy, close the active file (your House.vwx file should now be active). If your drawing is inaccurate, close your file 
and continue with the next exercise by starting with the supplied file. 
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Section 5: Creating Construction Documents 
In two exercises, this section covers the following processes in the construction documentation stage of the home design project: 

 Creating floor and roof plans (pg 62) 
 Creating elevations (pg 63) 
 Creating a section viewport (pg 64) 
 Editing section viewport display properties (pg 65) 
 Inserting appliance symbols (pg 66) 
 Inserting kitchen symbols (pg 68) 
 Inserting plumbing fixture symbols (pg 69) 
 Creating dimensions (pg 72) 
 Adjusting dimension visibility in multiple viewports and saved views (pg 73) 

In these exercises, you use a variety of 2D and 3D tools to create basic versions of commonly used construction documents from viewports (that 
display objects on multiple design layers) on sheet layers. For some documents, you also work with external files or create corresponding 
architectural and annotation objects as required. 
 

Note: Depending on the type of construction document, you create annotations in design layers or directly inside the viewport (in viewport 
annotation mode) based on suggested best practices. 
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Exercise 10: Generating Construction Drawings 
In this exercise, you complete the initial setup steps of commonly used construction drawings by arranging and modifying viewports to display your 
model. 

Note: To save time, you skip the process of creating fully detailed construction documents. 

The completed exercise is shown in the following figure: 

                                             

Creating floor and roof plans 
You start by activating the floor and roof plan sheets and arrange or modify the viewports as necessary. 

1. If you did not complete Exercise 9—or you are unsure of your file’s accuracy—open the GS-VWAx09.vwx file. 

2. In the Navigation palette, activate the Sheet-Floor Plan-1 sheet layer, and then clear the current selection (if anything is selected). Press 
Ctrl+6, and notice that the viewport is not centered, as shown at left. Drag any object in the floor plan to reposition the viewport in the 
approximate center of the drawing sheet, as shown at right. 

            

3. Repeat the process for the Sheet-Floor Plan-2 sheet layer, as shown at left. In the Navigation palette, activate the Sheet-Roof Plan sheet 
layer. Select only the viewport, and then click Layers in the Object Info palette. In the Viewport Layer Properties dialog box, turn on visibility of 
the Mod-Floor-2 layer (shown at center) and then click OK. Reposition the viewport approximately where shown at right. 
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Creating elevations 
Next, you adjust the viewport in the Sheet-Elevations-1 sheet layer to show the front elevation. You then copy the viewport to create the rear 
elevation. 

4. Activate the Sheet-Elevations-1 sheet layer. Select only the viewport, and then in the Object Info palette: 
 Disable the Display Planar Objects option. 
 Click Classes. Hold down the Alt key, and click in the first column to turn on visibility of all classes, and then click OK. 
 Change the View to Front. 
 Change Background Render to Hidden Line. Notice the striped highlighting around the viewport (indicating that it needs to be updated). 

Reposition the viewport, as shown. 

 

5. Start dragging the viewport straight up, and then hold down the Shift and Ctrl keys to create a copy, as shown at left. For the new viewport, 
change the View to Back, as shown at right. 

            

6. Shift+select the front elevation viewport. In the Object Info palette, verify 2 Viewports are selected, and then click Update to hide the lines. 
Press the X key twice to clear the selection and examine the elevations, as shown. 

 
Note: In your own designs, you would repeat this process to create right and left elevation viewports on other sheets as necessary. To save time 
in this exercise, you skip the repetitive process of creating additional elevation viewports. 
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Creating a section viewport 
Next you create a live section viewport of the house. 

7. In the Navigation palette, select the Viewports tab, and then double-click the VP-Floor Plan-1 viewport to select it (and activate the  
Sheet-Floor Plan-1 sheet layer). With the viewport still selected, select View > Create Section Viewport from the menu. To define the section 
line, click point 1, and then hold down the Shift key (the preview line should be just inside the exterior wall) and click point 2, where shown at 
left. Move the cursor to see how to control the view direction, and then double-click below the line (when the view direction arrow points down), 
as shown at right. 

                     

8. Notice that the section marker is created (shown at left), and then in the Create Section Viewport dialog box: 
 Disable the Name Viewport as Dwg No/Sheet No. option. 
 Adjust other field values, as shown in the next figure. 
 Click Layers, and adjust visibilities as shown in the next figure, and then click OK. 
 Click Classes, and turn on visibility of the Roof-Main class, and then click OK. 
 Click Advanced Section Properties, and verify the Length Range, Depth Range, and Height Range are all set to Infinite, and then click 
OK twice. After several seconds, the viewport—with drawing label—is created, the Sheet-Sections-1 sheet layer is activated (identified in 
the view bar as A4.1 [Sheet-Sections-1]), and the viewport is placed in the center of the sheet by default. Press the X key twice to clear the 
selection, and then select and delete the non-section viewport. Drag the section viewport into position, approximately where shown at right. 

          
Notes: 
1) The existing viewport was created when the Create Standard Viewports command was used to set up this file. 
2) The drawing label automatically picked up the sheet number because automatic drawing coordination is enabled. 
3) To (optionally) fix the drawing label length: Right-click the drawing label and select Edit Annotations. Select the drawing label, and then in the 
Object Info palette, select Auto-Fit from the Line Length Mode drop-down list. Click the orange Exit Viewport Annotation button (in the upper 
right corner of the drawing area) to return to the sheet layer. 
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Editing section viewport display properties 
Next, you edit graphic attributes of the Section Style class and then you change the viewport properties to improve legibility. 

9. Press Ctrl+6 to zoom in on the selected section viewport, and notice how the default heavy lines and red fill color make it difficult to distinguish 
detail, as shown. 

 

10. In the Navigation palette, select the Classes tab. Right-click the Section Style class and select Edit. In the Edit Class dialog box, change the 
Pen Line thickness to .25, then click the Fill Color drop-down arrow, and select the Classic VectorWorks Colors palette (at the bottom). Select 
the pale blue fill color, as shown at left. Click OK to save the class edits. Although only the fill color and pen thickness have changed, notice the 
striped highlighting around the section viewport (indicating that it needs to be updated), as shown at right. 

            

11. In the Object Info palette, click Update to regenerate the section viewport. Your updated viewport should look like the following figure. 
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Next, you add depth to the section by changing the section viewport’s Projection setting. 

12. In the Object Info palette, select Oblique Cabinet 30 from the Projection drop-down list, and then click Update to incorporate the change. Press 
Ctrl+6 to see the completed section viewport, as shown (leave the section viewport selected for the next step). 

 
 

Tip: You can also create offset section viewports (but you cannot change their projection). View the Live Sections movie, available by selecting 
Vectorworks 12 Feature Demos from the category drop-down list on Nemetschek’s Online Video Library web page. 

Next, you navigate back to the section line instance from the section viewport, and then you adjust section line properties. 

13. In the Object Info palette, scroll down and click Section Line Instances. In the Section Line Instances dialog box, select Viewports from the 
Find Instances In drop-down list. Select the VP-Floor Plan-1 viewport, as shown at left (the check mark identifies a section line instance), and 
then click Activate. Viewport annotation mode for the VP-Floor Plan-1 viewport is automatically activated, and the section line object selected. 
Press Ctrl+6 to see both section line markers. In the Attributes palette, select Solid for both the Fill Style and Pen Style, and then select black 
for the Solid Fill Color, as shown at center. In the Object Info palette, select Dwg No. over Sheet No. from the Text Style drop-down list. Click 
the orange Exit Viewport Annotation button (in the upper right corner of the drawing area), and then press Ctrl+6 to adjust the display. 
Examine the completed section line, as shown at right. 

                           

Inserting appliance symbols 
Next, you insert appliance symbols in the upstairs hall bathroom. You can choose to optionally follow steps 14 through 22, where you insert 
various symbols and plug-in objects in both floor plans. Or to save time, you can close your file and open the GS-VWAx10-Step23.vwx file 
(with the symbols and plug-in objects already inserted) and skip ahead to step 23. 

14. Open the Equip-Residential Appliances-Imp.vwx file in the Data Set folder (keep this file open through step 21 - don’t close your house file - 
see Note below). In the Resource Browser, click Home  to activate the Equip-Residential Appliances-Imp file. 

Note: This file is also included with Vectorworks Architect in the following folder: 
 [Vectorworks application folder]\Libraries\Objects-Building Architecture & Interior 
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15. From the Window menu, select your house file to activate it. In the Navigation palette, activate the Floor Plan-2 saved view. In the Scripts 
palette, double-click the Toggle Dimension Class Visibility script to hide all dimensions. Press Ctrl+5 and Ctrl+6, and then zoom in on the hall 
bathroom. In the Resource Browser, notice that the Equip-Residential Appliances-Imp file is still active, and then open the Symbols/Plug-in 
Objects folder (if it’s not already open). Double-click the Clothes_Washer_Top symbol to activate the 2D Symbol Insertion tool. In the Tool 

bar, enable Wall Insertion Mode  (if it’s not already enabled) and Align Actual Insertion Point Mode , and then move your 
cursor—with phantom preview—over the wall, approximately where shown at left. Double-click to complete the insertion, as shown at center. In 
the Object Info palette: 

 Make sure that Symbol in Wall is displayed (or undo the placement and try again). 
 Select Left Edge from the Insert drop-down list. 
 Select No Break from the Break drop down list. 
 Click Set Position, and then for the reference point, snap to the wall’s top left inside corner. For the object point, snap to either corner on 
the top edge of the clothes washer. In the Enter Offset dialog box, specify an offset of 3’10” [1.168m], and then click OK to move it into its 
final position, where shown at right. See Symbol Insertion Notes (after step 21) for additional information. 

                                         
 

16. Press the X key twice to clear the current selection, and repeat the previous step to insert the Clothes_Dryer_Sm symbol with an offset of  
2” [50.80mm] between the clothes washer (as shown), and then press the X key twice to clear the selection. 
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Inserting kitchen symbols 
Next, you insert various symbols and plug-in objects (with minimal instruction) to complete the kitchen. 

17. In the Navigation palette, activate the Floor Plan-1 saved view. In the Scripts palette, double-click the Toggle Dimension Class Visibility 
script to hide all dimensions. Press Ctrl+5 and Ctrl+6, and then zoom in on the kitchen area. Insert kitchen symbols in the order listed below. To 
do this, note the source VWX file of the symbol, and then if the symbol is located in: 

 Your House.vwx file: Double-click the symbol in your House.vwx file’s Resource Browser and insert it where shown at right (and also 
shown below the table in a bird’s eye perspective view for clarity). 

 Another file: Open the VWX File specified (in the Data Set folder – see Note below lower figure; keep VWX files open through step 21), 
and then switch the focus back to the house file. In the Resource Browser, activate the VWX File you just opened (if necessary, open the 
symbol folder, and scroll down), and then double-click the symbol and insert it where shown. 

See Symbol Insertion Notes (after step 21) for additional instructions. Use the Move by Points tool  as necessary. 
 

Order Source VWX File Symbol or Folder > Symbol 

1 House 2CompSinkCabinet 

2 House IslandCornerCabinet 

3 Equip-Residential Appliances-Imp Dishwasher 

4 House IslandCountertop 

5 House 2CompSink 

6 Equip-Residential Appliances-Imp Range_30_Gas 

7,8 House *RangeBaseCabinet 

9 Equip-Residential Appliances-Imp Range Hood 30 

10,11 House RangeWallCabinet 

12 Equip-Residential Appliances 
SubZero USA 

Built-in Refrigeration > **642 
Stainless 

 

*After you insert item 7, use the Mirror tool with Duplicate and Mirror Mode enabled to create item 8. 
**Insert this symbol in the center of the pantry wall, and then in the Object Info palette; change the Class to None, and select Full break with 
caps from the Break drop-down list. 

 
 

Note: The Equip-Residential Appliances SubZero USA.vwx file is also included with Vectorworks Architect in the following folder: 
 [Vectorworks application folder]\Libraries\Objects-Building Architecture & Interior 
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Inserting plumbing fixture symbols 
Next, you insert plumbing fixture symbols (with minimal instruction) in the first and second floor plans. 

18. Zoom in on the bathroom as shown. 

 

19. Open the Sanitary-Fixtures.vwx file in the Data Set folder. In the Resource Browser, activate the Sanitary-Fixtures.vwx file (scroll down as 
necessary), and then double-click symbols in the order listed in the table and place them in the bathroom where shown at right. 
See Symbol Insertion Notes (after step 21). 

 

Order Symbol  

1 WC Wall Floor Tank  

2 Lav Pedestal  

 

 

Note: The Sanitary-Fixtures.vwx file is also included with Vectorworks Architect in the following folder: 
 [Vectorworks application folder]\Libraries\Objects-Building Services 

20. In the Navigation palette, activate the Floor Plan-2 saved view. In the Scripts palette, double-click the Toggle Dimension Class Visibility 
script to hide all dimensions, and then press Ctrl+6, and zoom in on the area shown. 
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21. Insert symbols and plug-in objects in the order listed in the table below and place them in the bathrooms where shown at right. See Symbol 
Insertion Notes (below table) for additional instructions. 

 

Order Source VWX File Symbol 

1,2 Sanitary-Fixtures WC Wall Floor Tank 

3,4 House VanitySink 

5 House Shower 

6,7 House Bathtub 

   

 

             

Symbol Insertion Notes: 
1) You can drag symbols out of the Resource Browser and drop them into the drawing, but you double-click them to make them active so you can 
use the cursor’s phantom preview to facilitate accurate placement. 

2) Make sure Wall Insertion Mode  is active when inserting symbols. You don’t have to insert symbols in walls, but if you do, the symbols 
will move along with the walls when you drag wall segments to move or resize them. 
3) Use Insert = Left edge (or Right edge), and Break = No break options as required. 
4) Click the 2D Selection tool to terminate the 2D Symbol Insertion tool after each symbol insertion, then drag symbols and/or use the Flip and 
Set Position controls as necessary to orient and move them into their correct position. You can also use temporary associative dimensions to 
position symbols. 
5) In some cases, you may have to insert the symbol in another location away from other symbols, then drag and snap it—or use the Set Position 
control—to move it into its correct position. 
6) When correctly inserted, all symbols should display the “In Wall” suffix after the symbol name in the Object Info palette. 

22. Close all three symbol files. 

23. If you skipped steps 14 through 22, open the GS-VWAx10-Step23.vwx file. In the Navigation palette, select the Viewports tab, and then 
double-click the Section 1 viewport to activate it. Press Ctrl+6 to zoom in on the selected viewport. With the viewport still selected, click Update 
in the Object Info palette. Press the X key twice to clear the selection. Notice that the viewport updated with the appliance, kitchen, and 
plumbing fixture symbols, as shown. 

 
 

Note: You can move the section line if the sectioned bathtubs’ outside walls block the view inside both bathtubs, or if you want to examine the 
model at a different section point. To do this: Right-click the VP-Floor Plan-1 viewport and select Edit Annotations, and then press the X key and 
drag the section line to move it. With the section line selected, click Navigate to Section Viewport in the Object Info palette, and then press 
Ctrl+6 to adjust the display. Click Update in the Object Info palette to see the change. 

Creating Construction Documents  Vectorworks 2010 - 70 



Getting Started with Vectorworks Architect   

24. Save the file. 

If you set up your files as instructed in the Checking Your Work section, you can now optionally check the accuracy of your file. 
 

Note: The methods used in the GS-VWAxCheck.vwx file to compare your drawing file with the master files cannot compare viewports. You must 
manually check the accuracy of all of your viewports and any objects you created in viewport annotation editing mode. 

25. Open the (read-only) GS-VWAxCheck.vwx file. In the Navigation palette, double-click the 01 Floor Plan-1 saved view to activate it, and then 
double-click the Check EX10 saved view to activate it. 

26. Use the Zoom  and Pan  tools (in the Basic tools palette), and the Previous View tool  (in the View bar) as necessary to 
examine the drawing. Your drawing objects are displayed in red, and the master file’s drawing objects are displayed in their default colors. You 
should see your red drawing objects overlaid directly on top of the master file’s drawing objects. 

27. In the Navigation palette, double-click the 02 Floor Plan-2 saved view to activate it, and then double-click the Check EX10 saved view to 
activate it. 

28. Use the Zoom  and Pan  tools (in the Basic tools palette), and the Previous View tool  (in the View bar) as necessary to 
examine the drawing. Your drawing objects are displayed in blue, and the master file’s drawing objects are displayed in their default colors. You 
should see your blue drawing objects overlaid directly on top of the master file’s drawing objects. 

29. After checking your file’s accuracy, close the active file (your House.vwx file should now be active). If your drawing is inaccurate, close your file 
and continue with the next exercise by starting with the supplied file. 
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Exercise 11: Adding Annotations 
In this exercise, you complete the first and second floor plans by adding dimensions, and then you simultaneously adjust dimension visibility in a 
viewport and saved view. 

The completed exercise is shown in the following figure: 

                            

Creating dimensions 
You start the exercise by creating linear and chain dimensions for architectural objects on both floors. 

1. If you did not complete Exercise 10—or you are unsure of your file’s accuracy—open the GS-VWAx10.vwx file. 

2. Activate the Floor Plan-1 saved view, and then press Ctrl+6 to adjust the display. Use the Constrained Linear Dimension tool  with 

either Constrained Chain Mode  or Constrained Linear Mode  (see Notes below figure) as necessary to create the remaining 
associative dimensions, approximately where shown at left. Activate the Floor Plan-2 saved view, and then repeat the process to create the 
remaining associative dimensions, approximately where shown at right. 

        
Notes: 
1) Click window and door insertion points (the plug-in object will pre-highlight to confirm the insertion point will be selected) to create associative 
linear and chain dimensions. It’s not necessary for this exercise, but you can optionally change dimension length values as desired. 
2) You can unlock existing dimensions and reposition the dimension or text (by dragging), as necessary. 
3) If you haven’t created specific dimensional relationships (optional in previous exercises), you can alternately run the Custom Select All Dims 
script, and then press the Delete key to remove all dimensions from the drawing. You can then run the Dimension Exterior Walls command to 
re-create all dimensions on both floors. To automatically associate dimensions with T-joined wall intersections with the Dimension Exterior Walls 
command: Select Centerlines from the Dimension to Wall drop-down list, and select Center of Openings from the Dimension to drop-down list in 
the Dimension Exterior Walls dialog box. 
4) Refer to Exercise 13 in the “Getting Started with Vectorworks Fundamentals” guide for an overview of creating a text block and a callout. 
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Adjusting dimension visibility in multiple viewports and saved views 
Next, you use the Organization dialog box to simultaneously adjust visibilities in a viewport and saved view to hide or show dimension objects. 

3. In the Navigation palette, select the Classes tab, and then right-click the Dimension class and select Visibilities. The Organization dialog box is 
displayed with the Dimension class selected (in Visibilities mode). Resize the Organization dialog box (if necessary) so you can see the entire 
list of viewports and saved views. The Dimension class is visible by default in all saved views and viewports automatically created with the 
Create Standard Viewports command (but not the two saved views that you created), as shown. 

 

4. Turn off visibility for the VP-Roof Plan viewport, and then turn on visibility for the Roof Model saved view, as shown, and then click OK to close 
the Organization dialog box and save the changes. 

 

5. Examine the changes in the floor plan sheet layers, and then save the file. Congratulations - you have now completed the tutorial! 

If you set up your files as instructed in the Checking Your Work section, you can now optionally check the accuracy of your file. 

6. Open the (read-only) GS-VWAxCheck.vwx file. In the Navigation palette, double-click the 01 Floor Plan-1 saved view to activate it, and then 
double-click the Check EX11 saved view to activate it. 

7. Use the Zoom  and Pan  tools (in the Basic tools palette), and the Previous View tool  (in the View bar) as necessary to 
examine the drawing. Your drawing objects are displayed in red, and the master file’s drawing objects are displayed in their default colors. You 
should see your red drawing objects overlaid directly on top of the master file’s drawing objects. 

8. In the Navigation palette, double-click the 02 Floor Plan-2 saved view to activate it, and then double-click the Check EX11 saved view to 
activate it. 

9. Use the Zoom  and Pan  tools (in the Basic tools palette), and the Previous View tool  (in the View bar) as necessary to 
examine the drawing. Your drawing objects are displayed in blue, and the master file’s drawing objects are displayed in their default colors. You 
should see your blue drawing objects overlaid directly on top of the master file’s drawing objects. 

10. After checking your file’s accuracy, close the active file (your House.vwx file should now be active). 
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