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Introduction — How to Use This Book
When I was asked to write the original book in this series, I was delighted. It brings together two 
subjects about which I am passionate: garden and landscape design—and Vectorworks Landmark.
The book has been designed as a workbook that covers the typical work stages of the 
residential landscape designer. You will start with setting up your environment and then move 
through the various stages of the design process in order to create a garden plan that can be 
presented in both 2D and 3D. The book is not designed to make you a total expert in 
Vectorworks Landmark. It is designed to build a foundation of essential knowledge to help  
you understand the way Vectorworks is intended to work within your design discipline. It 
complements the information provided in the free guides discussed below and the extensive 
Help system, which is installed on your machine with the software—as well as the many 
training options available to you.
You will need Vectorworks Landmark 2014 software to follow the exercises faithfully, and 
Renderworks is recommended in order to gain the maximum benefit from the workbook and, 
indeed, Vectorworks Landmark. If you do not have version 2014 software, there are five 
earlier editions of this workbook suitable for use with Vectorworks Landmark versions 2009, 
2010, 2011, 2012 and 2013 but not earlier versions. The book is based on Vectorworks 2014 
Landmark with Renderworks and includes exercise files in the Vectorworks 2014 format only. 
You may use an Evaluation License, an Educational License or a Full License. If you don’t 
have Renderworks, it won’t stop you from using this book, but you won’t be able to complete 
some of the exercises or achieve the same finished look in some cases.

Before You Start
This book builds on the basic skills covered in the two free guides that cover the basics  
of drawing in both 2D and 3D: (1) Getting Started with Vectorworks Fundamentals and (2) 
Getting Started with Vectorworks Landmark 2014. It is recommended that you use these 
guides first. They can be downloaded from:
http://www.vectorworks.net/training/getting-started-guides/
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In addition, if you are completely new to using a computer, it would be really useful to have a 
basic understanding of the following:
•	 How files and folders are organized on a computer
•	 How to open files
•	 How to save files
This information is readily available on the Microsoft and Apple web sites, so if you’re completely 
new to using a computer, I recommend you look at some of their free training videos.

How to Use This Workbook
This workbook comes as a hard printed copy with one CD-ROM. The CD contains an exercise 
folder called ″2014 Landmark Workbook Exercises.” Copy the exercise folder to a file location 
of your choice on your computer's hard drive, such as the folder “Documents” to make it easy 
to find the files. Save any training files you work on to your exercise folder.
I recommend that to start with, you work through the book from end to end, using the example 
files on the accompanying CD. You may look at a subject and think you are already using those 
tools, but it’s always worth working through, as you may still learn something. Vectorworks is  
a huge tool so there is always something new to learn!
Once you’ve worked through from end to end, you can dip in and out of the book as needed. 
Some chapters will be essential to learn before you can go further—like the basics of setting 
up your drawing board and Resource Browser. But after that, if, for example, you want to 
remind yourself about the hard landscaping, you can just go straight to that section. At each 
stage, I’ve provided a completed sample file with the chapter so that you can compare your 
results with mine. Therefore you can pick up the book and start at any place by opening the 
completed file for the previous chapter—but please—work through from beginning to end first.

Vectorworks Environment Used in This Book
The book covers both the PC running Windows and the Apple Macintosh running MacOS X. 
However, the exercises and screenshots have been developed on a mixture of the PC 
environment with Microsoft Windows XP as the operating system and the Apple Macintosh 
environment running Mac OS X version 10.7. Where instructions for each operating system 
differ, this is described as follows. The + shows that the keys are to be pressed together—hold 
down the first key and then press the second:
•	 To undo the previous change, use Command+Z (Macintosh) or Ctrl+Z (Windows)
This book is not intended to replace the extensive Help system that installs with the software. 
While it does not cover industry workflows, Vectorworks Help will give you in–depth 
supplementary information on the tools you will use in this book. It is searchable, and  
you can create and save your own comments. With Vectorworks, there are always many  
ways to achieve something, and whichever way works best for you is the one to stick with.
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Typing Conventions in This Book
Exercises are clearly noted, and their instructions are shown as follows:
1.	 This is step one of this exercise.
Wherever menus and tools are discussed in this book, their names are written exactly as you 
will find them in the application. The location of each tool is described in the instruction. Tools 
can display their names in their respective palettes or can display their name when you hover 
the mouse over them. An example is as follows:
2.	 Use the Circle tool found in the Basic palette. Change the mode of the Circle tool to 

Circle By Diameter mode on the Tool bar.
Exercises may also contain lists of instructions within one numbered step. These are shown 
as a bulleted list. In the example below you should type 1000 into Box A and 2000 into Box B:

•	 Box A: 1000
•	 Box B: 2000

Wherever I refer to specific keys on the keyboard, key names have an initial capital. For example:
3.	 To constrain the line to 45°, press and hold the Shift key while drawing.
4.	 To save the file press Ctrl+S (Windows) or Command+S (Macintosh.

Regional Variations – Language and Measurements
Despite being born and bred in the UK—and fully versed in English-English—I have done my 
best to write in American-English to reach that wider audience. In putting together this book,  
I have discovered the joys of a common, and yet very different, language. For example, here 
in the UK we use a spanner to loosen a nut, whereas in the US, the same tool is known as a 
wrench instead. My UK students know that they should press the "Spanner and Pencil" button. 
This publication refers to the Wrench and Pencil button instead! There are other interesting 
variations such as math versus maths and biscuits versus cookies.
The book covers both metric and imperial measurements. My primary measurements are  
in millimeters or meters, but I have also translated into imperial. However, in order to create  
a design which works well in both metric and imperial, I have sometimes used imperial 
measurements that are not an exact translation. These translations ensure the overall  
design will work sensibly. For example: 500 mm has been translated as 1′6″ while the exact 
translation would be 1′ 7 ⅝″. In this book, this is written as follows:
1.	 Draw an object with the following dimensions:

•	 Width: 500 mm (1′6″)
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When I am training new users, there is often much discussion as to why some use metric and 
some use imperial. The two systems are widely used in many cultures. For example, here in 
the UK, we draw in millimeters or meters, buy paving by the square meter, but buy timber in 
imperial dimensions. We also measure rainfall in inches and fill our cars with liters of fuel. But 
we measure the consumption of fuel in miles per gallon. At the end of the working day we may 
go to the pub for a quick pint of beer! So, tolerance and the ability to convert is crucial and 
Vectorworks can do it for you!

Screenshots
The screenshots included in this book are annotated to show where to click and in which 
order. Therefore, the numbers on the screenshots relate to the order of clicks, not to numbers 
in the exercise instructions. I have tried to make this as clear as possible. Arrows have been 
used to draw your attention to something that you should notice, but not necessarily change.

Approximate Metric to Imperial Conversion
Here are some common metric to imperial conversions; they are approximate and make the 
most sensible translation.

Metric Imperial
25 mm 1″

100 mm 4″

150 mm 6″

0.3 m 1′

0.5 m 1′6″

1.5 m 5′

1.8 m 6′

3 m 10′

10 m 33’
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Windows and Macintosh
The Vectorworks Landmark software generally behaves identically on the Macintosh as it 
does in the Windows environment. However, there are certain differences on the keyboard, 
which are noted here.

Windows Key Equivalent Macintosh Key

Control (or Ctrl) Command (or Cmd, or ⌘ or )

Delete Some Macintosh keyboards don’t have a Delete key and use the 
Back key instead (←)

Sometimes, I’ve suggested keystrokes that can be used as shortcuts. For example, the Ctrl 
key pressed with the S key can be used to save a file without having to use the File menu. 
Menu commands are always written in bold, with a > to show the path. Where I’ve written 
such shortcuts, I’ve shown Windows first and then the Macintosh equivalent as follows:
1.	 Save your file using File > Save or by using Ctrl+S (Windows) or Command+S (Macintosh) 

on your keyboard.
Now it’s time to get started!
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Working With Hard Landscaping
When you’ve finished this chapter, you will be familiar with the Custom Stair tool, Round Wall 
tool, and the incredibly useful Hardscape tool. You’ll be able to draw new objects as well as 
convert existing shapes from your draft design to the object types listed above. You’ll also be 
able to produce a report that lists the quantities you need to order for each material. You will 
also be able to use other methods to complete hard landscaping areas for those occasional 
scenarios where the Hardscape tool doesn’t quite do what you want.

Converting Shapes From Your Draft Plan Layer
Part of many designers’ process is to start the design by working with shapes. It’s only at a 
later stage that decisions are made about what these shapes will become in the final design. 
We’ve seen that we can create complex shapes from simpler shapes; for example by using 
the Add and Clip Surface commands (which we used to create the planted area shapes). 
These existing 2D shapes can be converted into a variety of other “intelligent” objects, such  
as Walls or Hardscape, and then the settings of your choice can be applied to the resulting 
object. The Modify > Create Objects from Shapes command enables you to choose the 
type of object you wish to create from a basic 
shape. You have the option to retain the 
original shape in the drawing, and this can  
be useful for producing simple setting-out 
plans. I usually retain all my original shapes 
and store them on a separate layer, which  
I call Draft Plan.
By the time you have completed this 
exercise, your drawing will have been 
transformed from the drawing on the right to 
the drawings shown below.
 
The drawings below show the same garden, using a preset 3D view, rendered with Final Quality Renderworks

SAMPLE
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Exercise Twenty-Five: Set Up the Resources and File Organization

Check Your Favorites List in the Resource Browser
In the chapter Setting Up the Resource Browser, we added a list of files to your Favorites 
index. If you didn’t complete that exercise, or have forgotten how to do this, now would be  
a good time to review that chapter to ensure you have the resources available.
1.	 To begin this exercise, open the file “01-Start Hard Landscaping.vwx.”
2.	 To save you time, I have already imported the resources that we’re going to use in this file. 

However, I’ve included here a list of the libraries that they came from so you can find them 
again for future projects. (Note that if you have not purchased Renderworks you will not 
have the Texture libraries. This will not hamper your progress, but your 3D model will not 
have realistic textures available.) The Renderworks textures I mention below have already 
been set up for you in the relevant classes that we’re going to use—again to save you 
time. There are other textures available. These are just examples to get you into the habit 
of searching the resource libraries for inspiration!

3.	 These are the libraries I chose and their relevant resources:
•	 Landscape Stipples (Landscape and Land Usage folder): Foliage Dense 02, Foliage 

Floral, Turf b/w
•	 Textures-Default: Bricks (Arroway Bricks 020) (We used this earlier for the house walls.) 

Wood (Arroway Boards 002) New & Bright (We used this earlier to add a texture to the 
fence), Landscape Grass Fairly Green, Landscape Mulch, Stone (Arroway Stone 002 
Sandstone), Water with Absorption

•	 Textures_Interior Finishes: Carpet Berber 01 Lt Brown, Tile Travertine 02 Gray
•	 Textures_Exterior Finishes: Stucco Medium White Small
•	 Textures_StoneAndBrick: Stone Mix 05 Large, Stone Marble Gray 02
•	 Created by me in an external image editor: Dutch Pattern Paving

Review the Resources Available in the Resource Browser.
I have created a number of color gradients that you’ll be using in this chapter—to save you 
time when working through the exercises. However, if you need a reminder on how to create 
or edit Gradients, review the chapter on 2D graphics. Feel free to change the ones I’ve set  
up if you don’t like them. As with the Renderworks textures, these Gradients have already 
been applied to classes to save you time.
1.	 Click the Home button on the Resource Browser and review the resources available  

in the file. Notice the gradients and textures that I have listed above. The gradients are 
named as follows:
•	 Brick Paving Gradient
•	 Decking Gradient

SAMPLE
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Creating Additional 3D Objects
In this chapter, we’re going to look at some more 2D/3D hybrid objects to see what else 
Vectorworks can make easier for you. We’ll add some furniture to the garden using tools that 
avoid your having to model each item individually! We’ll also include some of the ready-made 
symbols that have shipped with Vectorworks and see how to edit them to add the textures  
of your choice. Then, if you’re feeling brave, you can have a go at modeling a simple pergola. 
We’ll also look at how to make a simple planting container and make a sail shade. When you 
model something unique in 3D, Vectorworks has a magical command that will automatically 
draw the 2D representation for your plans.
Some of this we’ll do in the imaginary garden we’ve been working on, but we’ll also work  
in some separate files so that you can draw with ease and without the distraction of what’s 
already there. If you make something you like, you can always save it as a symbol to use  
later in other projects.

Exercise Thirty-Two: Using More 2D/3D Hybrid Tools
1.	 Open the file “01-Start 3D Elements.vwx,” or continue working in your own exercise file.
2.	 On the View bar, create a new design layer called “3D Furnishing and Fixtures.” Ensure 

this new layer is the active layer. Make None the active class.
3.	 On the Visualization palette note that the evening lights are turned off and the daytime 

(heliodon) is switched on.

Create Handrails for the Terrace Edge
As much as I love the way the terrace leads our eye across the surface of the water to the 
garden, safety could be an issue! We are going to place some rails at the edge of the terrace 
to prevent disaster. Luckily, Vectorworks provides another tool for us to create these easily by 
entering the dimensions we want into a dialog. Vectorworks does the rest for you. You won’t 
be able to control the shape of elements here because they will all be rectangular (or rather 
cuboid), but you will get quick results! (Later in this chapter, you’ll learn how to model 
elements from scratch if you want something more customized.) The Handrail Straight tool 
enables you to define all your sections individually, but it is quicker to draw a polyline along 
the path for the handrails and then convert as we have done before to create Hardscape.
1.	 From the Furn/Fixtures tool set, choose the Handrail Straight tool. Click the Handrail 

(Straight) Tool Preferences button on the Tool bar and set the following options:
•	 Top Rail Width: 76 mm (3″)
•	 Top Rail Thk: 51 mm (2″)
•	 Inter Rail Width: 10 mm (½″)

SAMPLE
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•	 Inter Rail Thk: 40 mm (1 ½″)
•	 Check Starting Upright and Ending 

Upright to ensure that you have 
upright posts at each corner

•	 1st Upright spacing: 400 mm (1′3 ¾″). 
This will need to vary depending on 
the length of the segment. We will 
adjust each segment in place on the 
Object Info palette once the handrails 
are created.

•	 Upright Spacing: 800 mm (2′7 ½″)
•	 Upright Width and Upright Depth: 

(posts) 50 mm (2″)
•	 Caps: Start or End, or None, 

(dependent on position of each 
piece). We will need to adjust this for 
each segment, so don’t worry about  
it at the moment.

•	 1st Horizontal Height: 216 mm (8 ½″)
•	 Horizontal Spacing: 254 mm (10″)
•	 Overall Height: 914 mm (3′)
•	 Start Miter and End Miter: Leave 0 in place. We will need to adjust this once the 

handrails are created.
•	 Top Rail, Uprights and Intermediate Rails: Wood-Oak. As with other hybrid objects 

we’ve seen (such as Doors and Windows), you can apply different classes to different 
components of the handrail.

2.	 Click OK. You have set the preferences  
for the tool.

3.	 Draw a small segment of handrail on a  
blank space on the drawing area—away 
from the garden. Change to a 3D view  
and render using OpenGL so you can see 
what the tool is going to give you. Delete 
this small segment and return to Top/Plan 
view with Ctrl+5 (Windows) or 
Command+5 (Macintosh).

SAMPLE
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4.	 I have already set up the class Wood-Oak with a wood texture. Alternatively, you can 
browse the Resource Browser texture library yourself and choose a texture you prefer  
for the handrails. Place your new choice of texture in the Wood-Oak class.

5.	 Instead of drawing with the Handrail tool, we are going to draw the path for the rails using 
the Polyline tool and then convert the polyline to a handrail with the Create Objects from 
Shapes command. This process will use the current settings for the Handrail tool. Choose 
the Polyline tool from the Basic palette.

6.	 Click at the top left corner of the terrace area and then double-click the top left of the steps. 
This creates a single segment polyline. Now, start another polyline with corner vertices that 
start at the right side of the steps, extend to the corner, down past the pool, along the 
bottom of the pool, and double-click at to the top left of the right-most set of steps.

7.	 Now draw another polyline that starts at  
the other side of the steps and continues 
around to the far-right side of the terrace. 
Double-click to finish. At the moment, your 
polylines will have a white fill because you 
are using the default attributes. Don’t 
worry—this will disappear when we 
convert the polylines to handrails.

8.	 Click the Selection tool. Select the first  
two polylines (starting from the left of the 
drawing). Choose Landmark > Create 
Objects from Shapes. Complete the 
dialog as follows:
•	 Object Type: Handrails
•	 Offset: Left
•	 Delete Source Shapes: Check
•	 Continuous Spacing: Check
•	 Click OK.

9.	 The polylines will be converted to handrails.  
Select the third polyline on the right of the 
garden. Repeat the above process, but 
this time choose Offset: Right.

10.	 Unlike the Wall tool, the Handrail tool  
will not miter all of the corners for you  
(but it will do some of them). Select each 

SAMPLE
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The Vectorworks Plant Database
The Vectorworks Plant Database resides in a separate stand-alone application called 
Filemaker Pro. It is populated with thousands of plant records, drawn from many sources.  
This data is also available in the Vectorworks Plant Lists to which we referred when we 
created our Hamamelis plant earlier in the chapter.
The use of this database is not an essential part of the planting workflow—you have seen 
above that you can create plants without it. However, it can be a very useful resource that  
you can employ for the following purposes:
•	 Searching for inspiration when creating a planting scheme
•	 Creating Vectorworks Plant Lists (that Vectorworks can read when attaching plant  

data to a plant)
•	 Managing your existing plant lists (perhaps currently stored in spreadsheets)
•	 Adding your own images to the existing plant information or creating your own plant 

records from scratch
•	 Providing plant data sheets to your clients
This section will cover the following areas:
•	 Loading localized plant data—shipped with your product
•	 Importing data from spreadsheets
•	 Creating a Vectorworks Plant List
Because it is a separate application, the Vectorworks Plant Database and Vectorworks 
application itself are unable to talk directly to each other. However, the Vectorworks Plant 
Database can compile Vectorworks Plant Lists, which can be read by Vectorworks.  
(You used a Vectorworks Plant List when you created the Hamamelis mollis earlier.)

Setting Up Your Vectorworks Plant Database for Your Local Geography
When you first load the database, it contains a huge set of plant records (over 5000).  
However, there are also some further sets of data on your disk that contain plants for the UK, 
Sweden, and Australia. These lists have been put together by people in the local geographies. 
For example, the UK list contains plants found in the Coblands Nursery catalog.
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Exercise Forty-Five: Adding Local Data to Your Database
1.	 Choose Landmark > VW Plants Database. The first time you run this command, 

Vectorworks will create the database for you. The Choose Plant Database Location dialog 
opens, and asks you where you would like to store the database. Choose User Folder, and 
click OK. The User Folder is a location set up by Vectorworks, where any customizations  
to your Vectorworks setup are recorded.

2.	 The database is created and then the Filemaker Pro application opens. If you are using  
a PC running Windows, you will see a prompt asking for a username. Simply click OK to 
start the database.

3.	 At the top of the screen, make a note of  
the number of records in the database.

4.	 Choose File > Add Additional Plant 
Data. An Explorer (Windows) or Finder 
(Macintosh) window opens and displays 
three dataset files. If the window opens  
at another location, navigate to the 
following folder:
•	 C:\Program Files\Vectorworks\2014\Plant Database\VW Plants\Additional Datasets 

(Windows)
•	 Applications/Vectorworks/2014/Plant Database/VWPlants/Additional Datasets (Macintosh)

5.	 Select the data file for your geography and then click the Open button to import the data 
from the file. In my case, it is UK Coblands Plant Data.usr.

6.	 You will now have many more records in your database. Notice the increased number on 
the panel at the top of the screen. If you are in Australia or the UK, you can also change 
the search screen layout to show appropriate fields for specifying plants in your geography.

7.	 Choose Layout > Australian Plant Data or Layout > UK Plant Data.

Change the Unit of Measure in the Plant Data
1.	 Click the magnifying glass icon at the top of the screen to invoke the search mode.
2.	 Type * in the Latin Name field. Click Perform Find to select all records in the database.
3.	 Choose Edit > Options > Use Metric  

Value Lists or Edit > Options > Use 
Imperial Value Lists—whichever is your 
preference. By default, the information in 
the database is in imperial format.

4.	 When making your choice, you will be 
asked if you would like to convert your data. Once you click OK, the conversion will 
commence and can take a minute or two to complete.
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Exercise Forty-Six: Importing Your Own Plant Data from Another File
If you have plant information in your own files—such as a spreadsheet file—you can import it 
into the Vectorworks plant database and thereafter add to it, manage it, and search it. You can 
then create Vectorworks plant lists, making your existing information and previous hard work 
available to the Vectorworks Plant tool.
1.	 Within the Vectorworks Plant Database choose File > Import Records > File. Navigate to 

the directory in which you have stored your workbook sample files. Change the file type to 
Excel Files (*.xls) and choose the file "Sample Plant Import Data.xls."

2.	 The Vectorworks Plant Database will attempt to “map” the fields from the spreadsheet to 
the fields in the database. On the left, you will see the column headings from the 
spreadsheet. There are three columns of information. On the right, you will see the fields 
available in the database. Drag the Target Fields names up or down with the mouse until 
the relevant field is next to its corresponding column from the spreadsheet (Source Fields). 
The fields should be mapped as follows:
•	 Plant Name to VW Latin Name
•	 Height m to VW Height
•	 Spread m to VW Spread

3.	  Click between the two columns to switch on and off the arrow. The presence of the arrow 
indicates that this field will be imported. Complete other fields as follows:
•	 Add new records: Check (Note that there are also options for updating existing records 

if there are plants with the same name already in the database)
•	 Don’t import first record (contains field names): Check to stop the row headers creating 

a record in the plant database
4.	 Click Import and Import again to confirm  

the import. A confirmation dialog is 
displayed. Click OK. Your plant names will 
be imported, and you can continue to 
populate the data as much as you wish. 
The top of the screen displays the number 
of imported records compared to the total 
number of records in the database. You’ll 
see that your imported records are 
showing as “Found,” which means they 
are currently selected.

Now that these records are stored in the 
database, they can be searched easily and have more data added in a consistent format. 
Images can be added to the plant information and you could print or create PDF documents  
of the relevant plants to give to your clients.
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