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FIGURE 1 
Project Sharing in Vectorworks Architect 
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Project Sharing is a multiuser environment that streamlines project management and 
execution. It was developed to help Vectorworks users manage projects involving multiple 
users, fostering effective collaboration and communication within a project team. 

Project Sharing is a single-file structure providing a mechanism that allows multiple 
users to work within - and access parts of - a file, simultaneously (FIGURE 1). This type of 
multiuser environment offers all team members the opportunity to act together – sharing 
their knowledge and expertise to the overall design and documentation of the project. It 
allows for the entire team to think of a project holistically. More importantly, a multiuser 
environment means a single source of information that can be used for automation and quality 
checking in drawing production and data extraction – one of the greatest benefits of BIM.

Management in Project Sharing is done through a robust, permission-based system with 
options to control access and rights among the design team. Team members are granted 
access to either layers (design and sheet layers), or to a specific object or groups of objects. 
They have the ability to check out those layers or objects, to work on them, and then release, 
or check them back in. Vectorworks communicates the status of the changes being made 
by project members along the way, keeping the entire team informed during the project. 

INTRODUCTION



FIGURE 2 
Working File Title Bar
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UNDERSTANDING PROJECT SHARING

TERMINOLOGY

The functionality of Project Sharing brings some terminology that is necessary to understand.

PROJECT SHARING – the multiuser environment within Vectorworks. Project Sharing 
creates an environment that streamlines project organization and management by 
allowing design teams to work concurrently in the same Vectorworks document.  

PROJECT FILE – a single file that serves as the hub for sharing or collaborating 
on a project. All team members can access the Project File by way of their Working 
File. A Project File will be designated with the file extension .vwxp. When a Project 
File is opened, a Working File is created. This means that the Project File is always 
accessed through a Working File. The Project File should be kept either on a server 
or in a cloud-based storage folder that can be accessed by all team members.

WORKING FILE – a local copy of a Project File specific to the user who has created it. The 
Working File is used to add to, subtract from, or modify the Project File. In essence, all 
modeling and drawing creation is done in a Working File and then is committed back to the 
Project File. A Working File is designated with the file extension .vwxw. When a Working File is 
open, the title bar on the file will include WORKING FILE to indicate that you are currently in 
a Working File (FIGURE 2). The Working File is kept on the hard drive of your local computer.

CHECK OUT – reserving an object(s), design layer(s) and sheet layer(s) for exclusive 
use. Once a person checks out an object or layer, they become the owner. That 
object or layer becomes unavailable to other team members until it is released 
– see below.  Multiple objects and layers can be checked out at once.

COMMIT – saving changes made in a Working File back to the Project File.

RELEASE – relinquishing your reservation on, or exclusive access to, 
objects or layers that were previously checked out by you. This will make 
the objects and layers available for others to check out.
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REFRESH – an update of all out-of-date parts of your Working File. A refresh 
is performed after another team member commits their changes to the Project 
File, which will make parts of your Working File out-of-date. A refresh does not 
commit your Working File; nor does it affect any of your uncommitted work.

REVERT – discards any changes in the active Working File and reloads an exact copy 
of the Project File in its current state. This should be used only when changes to 
your Working File are to be discarded and not committed to the Project File.

MASTER LAYER – a designated, special layer that changes infrequently over the 
life of a project. A Master Layer may contain critical information that should not be 
changed or overwritten. An example of such a layer may be a design layer that holds 
a project’s structural grid. You can have multiple Master Layers in a project.

OFFLINE MODE – when a Working File is disconnected from the Project File while 
maintaining exclusive access to the checked-out layers. Offline Mode allows you 
to continue working without access to the server where the Project File is saved. 
Layers must be checked out before using Offline Mode to maintain exclusive access 
to them. Once the Working File is reconnected to the server and the Project File, 
changes made in Offline Mode can be committed back to the Project File.

PERMISSION LEVEL – one of the unique features of Vectorworks’ Project Sharing is 
the ability to assign a Permission level to each member of a project team. Permission 
levels range from Administrative to Read Only, and allow for greater control and 
management of resources and editing of the Project File. More about the various 
permission levels can be found in the How to Set Up for Project Sharing section.

FORCE RELEASE – when an administrator releases objects or layers that are checked  
out by another user. 

UNCOMMITTED CHANGES – changes that are made to a Working file but have not been  
committed to the Project file. 

UNDERSTANDING PROJECT SHARING [CONT’D]



FIGURE 3 
File-Project Sharing

FIGURE 4 
File-Save and Commit
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OVERVIEW OF PROJECT SHARING

Any existing or new Vectorworks document can be shared as a Project File by simply designating 
it as a Project File through the Project Sharing command in the File menu (FIGURE 3). Once a 
Vectorworks document has been marked as a Project File, all subsequent file opens on that file 
will effectively open a clone of the Project File. These clone files are called Working Files. 

This means that the Project File itself is never actually opened. Consequently, 
all changes, edits, and adjustments are done through a Working File. 

When a Working File is created you can check out objects as needed, or an entire 
layer, which will include all objects on that particular layer. Other team members may 
check out different layers or objects and work on those in their own Working File. This 
happens concurrently with the work you are doing in your own Working File.

Each Working File will contain all information, geometry, and data from the Project 
File, however, users will be restricted in the types of changes they can make in each 
Working File based on the objects and layers they have checked out and whether they 
are permitted to make certain changes according to their Permission level.

UNDERSTANDING PROJECT SHARING [CONT’D]



FIGURE 5 
File-Close and Release
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UNDERSTANDING PROJECT SHARING [CONT’D]

Once you reach a point where you want to merge your 
changes back into the Project File, you will perform 
a commit through the Save and Commit command in 
the File menu (FIGURE 4). Changed objects and layers 
will, in essence, be inserted back into the Project 
File, and other, non-drawing data such as resources, 
will be merged into the Project File.  Once you have 
performed a Save and Commit, others can see your 
changes by Refreshing their own Working Files. 

After you’ve performed a Save and Commit, you can 
continue to make changes to your Working File, as you 
still have exclusive access to your checked out layers.  If 
you have no more changes to make, you can perform a 
Close and Release, which releases the exclusive access 
that you have on the checked out layers (FIGURE 5).

WHEN TO USE PROJECT SHARING

Because Project Sharing does not change any fundamental aspects of Vectorworks, it can 
be implemented at any time during a project using any Vectorworks document that will 
require multiple users. Project Files can also be easily reverted back to regular Vectorworks 
documents when deemed necessary (for example, when archiving a project). 

There is no minimum or maximum size requirement of a project or project 
team. More importantly, Project Sharing can accommodate the need 
to increase or decrease the size of the team as necessary.

Project Sharing can be implemented at any point in time, therefore there are no preset rules 
or requirements for changing a Vectorworks document to a Project File. What may help 
determine the need for a Project File will be whether or not more than one person needs 
to access and edit information within the file. So depending on how a project begins and 
how it evolves, the point in time at which a Project File is created will vary. For example, if 
a project begins with one person in the conceptual design phase, a Project File may not be 
necessary. If after the completion of a schematic design package, a team of three people is 
formed, the Vectorworks document from the schematic design phase can be changed into 
a Project File, allowing multiple people to access it and continue developing the design.



FIGURE 6 
Permission Level
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HOW TO SET UP FOR PROJECT SHARING

UNDERSTANDING AND DETERMINING PERMISSION LEVELS

Because Project Sharing accommodates Vectorworks’ layer organization and allows for 
separate layer check out, the permission levels that are available vary from the ability to 
create layers to the ability to only edit existing layers. These layers include both design 
layers and sheet layers. Permission is also required to add, edit, or delete a shared resource 
such as symbols, wall styles, or classes. The restrictions for each permission level will 
help determine how to assign the appropriate permission to a project team member.

Implementing Project Sharing will mean a few new responsibilities for the project team. 
These responsibilities include the creation of the Project File itself, as well as management 
of the Project File and its shared information. This and other tasks that need to be completed 
for a project should help inform the Permission level that each team member will require. 
Understanding the Permission levels and what tasks they allow you to complete, will 
help you understand how they can coincide with project tasks and roles (FIGURE 6).

PERMISSION 
LEVEL

DESCRIPTION

Read Only ∙∙ Read and view the content of the file
∙∙ Navigate in the file
∙∙ Edit class and layer visibilities (cannot commit)

Layers-
Restricted

Read Only permissions, plus:

∙∙ Create, delete, and edit objects on layers
∙∙ Create, delete, and edit worksheets, scripts, and script palettes
∙∙ Edit unrestricted document preferences and settings (cannot commit)
∙∙ Create and edit saved views (cannot commit)
∙∙ Create and edit working planes (cannot commit) 

Layers-
Unrestricted

Layers-Restricted permissions, plus:

∙∙ Create, delete, and edit layers
∙∙ Commit saved views
∙∙ Create, delete, edit, and commit Publish saved sets
∙∙ Create, delete, edit, and commit batch render jobs

Layers and 
Resources

Layers-Unrestricted permissions, plus:

∙∙ Create, delete, and edit resources
∙∙ Create, delete, and edit dimensions standards
∙∙ Create, delete, and edit patterns

Project Layers and Resources permissions, plus:

∙∙ Create, delete, and edit classes
∙∙ Create, delete, and edit story data
∙∙ Set and edit master layers
∙∙ Create, delete, and edit references to Vectorworks files
∙∙ Edit restricted access document preferences and settings
∙∙ Commit all document preferences and settigns

Administrative Project permissions, plus:

∙∙ Manage project sharing settings
∙∙ Add, delete, and edit users
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HOW TO SET UP FOR PROJECT SHARING [CONT’D]

ADMINISTRATIVE
The Administrative permission level essentially has no restrictions. This permission is 
automatically assigned to the person who first creates the Project File. Exclusive to this permission 
level is the ability to manage the project sharing settings (such as Project File backup policies) and 
the ability to add, delete, and edit the users on the project. The administrator will also have the 
ability to do a force release if needed. 

It is highly recommended that there be more than one Administrative user on each project as a backup 
policy. This can be an office-wide BIM or CAD manager along with the project’s model manager.

PROJECT
The Project permission level is the least restrictive level in the project (aside from 
Administrative). This includes the ability to change and commit document preferences 
and settings. Project permission is also required to create, edit, and delete references that 
are being used. This permission level is also necessary to create and delete classes.

LAYERS AND RESOURCES
The Layers and Resources permission level is needed to create, edit, and delete 
resources. This includes, symbols, textures, wall styles, slab styles, etc. Resources 
that do not require this permission layer to create and edit include worksheets, 
records, scripts and script palettes. A person with this permission level can also 
create, edit, and delete dimension standards within the document preferences.

LAYERS-UNRESTRICTED
Aside from the ability to create, edit, and delete layers, this permission level also allows 
you to commit saved views back to the Project File allowing others to access these views. 
This permission level or a higher permission is needed to create, edit, delete, and commit 
Publish saved sets and batch render jobs. Lower permission levels can access Publish saved 
sets and batch render jobs, but cannot create them or commit them to the Project File.

LAYERS-RESTRICTED
The Layers-Restricted permission level allows you to create, edit, and delete objects and 
information on layers that already exist in the Project File. Resources that can be created, edited, 
and deleted with this permission level include worksheets, scripts, and script palettes. It is 
important to note that this permission level allows you to create saved views, working planes, and 
edit any unrestricted document preferences so that you can continue to work in your Working File 
as you like. These types of changes or additions, however, will not be committed to the Project File.



FIGURE 7 
Permission Level
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READ ONLY
As indicted by the name, the Read Only permission level only allows you to navigate through the 
file. You can access and view all objects, layers and information, as well as update out-of-date 
viewports. You can change layers and class visibility in your Working File, but cannot commit these 
changes. This permission level does allow you to Publish drawings and run export commands. 

If a team member is attempting to complete an operation for which they do not have 
the proper permission level, a dialog box will appear (FIGURE 7). This dialog box will 
inform them of what permission level is required to complete the operation.

FILE ORGANIZATION AND SETUP

Though a Working File does not behave differently or require unique functionality from a 
regular Vectorworks document, it may require a modified setup to fully benefit from Project 
Sharing. Because Project Sharing is based on the layer setup of Vectorworks, team members 
may be limited in what objects can be checked out or what tasks can be performed by the 
number of layers that are present in the file. Division of certain work and tasks may require 
a new layer system that allows for more granularity in the file, allowing more people to 
work on different tasks. For example, if a team member is tasked with creating a finish 
plan and schedule; an additional space design layer can be created to allow this person to 
work concurrently with someone working on an interior partition layout (SEE FIGURE 8).

It is highly recommended that a template that has a predefined story, level and layer 
structure be set up and used. This ensures that users who have the Layers and 
Resources permission level and below (those who cannot edit story data and information) 
can still work on the project and draw with story-aware objects as needed. 

Though it is best to set up a story and layer standard beforehand, additional design and sheet layers 
can be added or modified as necessary with the proper permission level as the project progresses 
forward. For example, when beginning a project that requires documentation of existing conditions, 

HOW TO SET UP FOR PROJECT SHARING [CONT’D]



FIGURE 8 
Layer Granularity

FIGURE 9 
Design Option Layers
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HOW TO SET UP FOR PROJECT SHARING [CONT’D]

one team member can document the existing conditions on an existing conditions layer, while 
massing model studies are created and developed by another team member on a separate layer. 
This person can also add layers as needed for additional studies or design options (FIGURE 9). 

For help on general model setup and creating templates visit the How section of the  
Vectorworks BIM page.

http://www.vectorworks.net/bim


FIGURE 10 
Alert for Exporting Resources
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HOW TO ACCESS RESOURCES

As mentioned before, Working Files do not function any differently from other, regular 
Vectorworks documents. This means that access to shared libraries and resources remains 
unchanged. The use of Workgroup Folders (or Project Folders) also remains the same. 
The only difference is that the creation of new resources, or importing new resources 
into a Working File requires the Layers and Resources or higher permission level.

Resources from another Vectorworks document can be imported into a Working File and 
committed to the Project File (with the proper permission). However, resources cannot 
be exported from an open Vectorworks document to a Working File (FIGURE 10).

Other resources to consider are what are referred to as non-drawing data. These 
include data such as classes, story information, saved views and so on. The following 
will describe the behavior of non-drawing data in the Project Sharing environment.

CLASSES
Classes can only be created, edited, and deleted by users with Project permission level or above.

DIMENSION STANDARDS
Document Dimension Standards are treated like other resources and therefore can only 
be created and modified by users with the Layers and Resources permission level.

HOW TO SET UP FOR PROJECT SHARING [CONT’D]
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SAVED VIEWS
All users except those with the Read Only permission level can create and edit Saved 
Views in their own Working files. However, only a user with Layers-Unrestricted 
permission level or above can commit Saved Views to the Project File.

If you are utilizing the Rotate Plan function, it will need to be saved as a Saved View for future access. 
Therefore, a rotated plan view will need to be created and committed to the Project File by a user with the 

Layers-Unrestricted permission level or higher. 

PUBLISH SAVED SETS
Saved sets that are used with the Publish command can only be created by users with  
Layers-Unrestricted permission level or above.

BATCH RENDER JOBS
Users with Layers-Unrestricted permission level or above can create batch render jobs.

WORKING PLANES
Like Saved Views, all users except those with Read Only permission level can 
create and edit working planes in their own Working Files. Only a user with Project 
permission level or above can commit Working Planes to the Project File.

STORY DATA
Story Data includes story definitions and Story Levels. These can only be 
created and  edited by users with Project permission level or higher.

When users who have the Project permission level change a resource such as a hatch or a 
class definition, there could be a resource conflict when their Working Files are committed. 
This will happen if another person has edited a resource or created a resource with the 
same name and has committed it to the Project File before them. This is discussed in more 
detail in Creating and Editing Resources in the Drawing in a Working File section.

For general information regarding managing resources refer to 
the BIM Managers Guide to Resource Management. 

HOW TO SET UP FOR PROJECT SHARING [CONT’D]

http://download2cf.nemetschek.net/bim/bim-manager-guide-to-resource-management1506792498.pdf
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USING PROJECT SHARING

LOCATION OF THE PROJECT FILE

The Project File (the .vwxp file) should be placed on a server or a shared network location 
that is accessible by all team members. This means that all team members must have 
full access to the server. They must be able to read, write, rename, delete, create, etc. 
to the folder on the server or shared network location in which the Project File is kept. 
This is necessary for when check outs, releases, commits, and refreshes occur. 

The performance of Vectorworks when working on a shared project over a network will depend 
on the available network bandwidth. If the network bandwidth is insufficient, operations 
that transfer large amount of data over the network will be slow. It is recommended to 
have, at minimum, a Fast Ethernet (100Mbit/s) network connection. For large projects, 
Gigabit Ethernet (1Gbit/s) networks are highly recommended for a faster and more fluid 
experience. Networks less than 1Gbit/s can still provide a satisfactory user experience 
if operations transferring large amount of data over the network, such as committing 
changes to the project file or refreshing a local working file, are kept to a minimum. 

For this reason, it is highly recommended to create a protocol and schedule for team members 
to follow when committing to a Project File and when refreshing their Working Files.

A layer check out or a layer release does not transfer data over the network, and therefore 
will be executed quickly when compared to committing or refreshing your Working File. 

FOR MAC USERS: With OSX 10.9, Apple has made SMB the default protocol for connecting 
to network shares, moving away from the previous standard, AFP. There have been 
some issues with SMB on OSX that cause permissions to be set incorrectly. 

IF YOU EXPERIENCE PROBLEMS WITH SAVING TO A NETWORK SHARE, ATTEMPT TO CONNECT 

WITH THE OLD STANDARD AFP TO SEE IF THAT SOLVES THE PROBLEM. TO DO THIS:

1.	 From Finder, select Go → Connect To Server. 

2.	 Enter the prefix afp: prior to your share address. For example, “afp://myserver.address.net”.  

3.	 Click Connect.

For information regarding network protocol please see our technical bulletin here.

https://forum.vectorworks.net/index.php?/articles.html/articles/project-sharing-network-protocol-when-using-smb-on-mac-osx-r501/


FIGURE 11 
Working File Name
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USING PROJECT SHARING [CONT’D]

CLOUD-BASED SHARING

Project Files can be placed and shared in cloud storage with online 
applications. Supported cloud storage applications include:

∙∙ Dropbox
∙∙ OneDrive
∙∙ Google Drive
∙∙ Box

The corresponding desktop applications for these cloud solutions must be installed and 
used to create a folder in which all shared project information should be placed. 

The Project File should be placed in this shared folder that can be accessed by all team members 
with full read, write, and delete permissions. The individual Project File itself should not be shared.

Never re-upload, move, or copy the Project File or the folder that contains the Project File once it has been 
placed in the cloud. This will cause connectivity problems between the Project File and the Working File.

LOCATION OF THE WORKING FILE

Working Files are created when you attempt to open a Project File. The 
name of the Working File will automatically be appended to include a suffix 
including the user’s name (FIGURE 11). Consequently, Working Files are unique 
to each user and should be used only by the designated user.

Though each user can create multiple Working Files, it is not recommended.

When you first create a Working File it is still unsaved. This means that the file does 
not have a designated place to be stored – just like a new, Untitled Vectorworks file. 
For this reason, when a Working File is first created, it should be saved promptly. 

The Project File will always be accessed through this Working File. Do not open the Project File again, as 
it will create a new Working File. Duplication of the Working File can lead to miscommunication and many 
errors with layer check outs. This will be discussed further in the Drawing in a Working File section.
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USING PROJECT SHARING [CONT’D]

The Working File should be saved to the user’s computer’s local hard drive. Though it can be saved 
on a server or in the shared cloud storage folder, it is not recommended to do so. The Project 
Sharing system is designed to minimize the complications of working over a server network 
or the internet. By saving a Working File on the server, you will not be taking full advantage of 
the optimization provided by Project Sharing. Saving on a local hard drive also allows the user 
to disconnect from the server and continue working in their Working File in Offline Mode. 

The backup policy of a Working File is the same as the backup policy of a regular Vectorworks 
file. A backup copy of the file is created after a designated period of time has passed (every 10 
minutes, every 15 minutes, etc.) or after the designated number of operations. The backup copy 
of your Working File should be created and stored on the same computer that the Working File 
itself is located. The backup copy should not be created or placed on the server or cloud.  

HOW TO CREATE A PROJECT FILE AND WORKING FILES

AS DISCUSSED EARLIER, ANY VECTORWORKS DOCUMENT CAN BE CHANGED INTO A PROJECT FILE 

AND BE USED IN THE PROJECT SHARING MULTIUSER ENVIRONMENT. TO CREATE A PROJECT FILE:

1.	 Open an existing Vectorworks document or create a new document.

2.	 Go to File and select the Project Sharing option. The Project Sharing Setup dialog box will open.

If you’ve created a new file, you will be prompted to save the file before continuing 
with the Project File setup. Save the file on a server/network or a shared 
cloud-based storage folder that is accessible by all team members.

If you’ve opened an existing Vectorworks file and it is not on your server or in the cloud, first move 
the file to your shared location for central access then begin the Project File creation process.

FOR CLOUD BASED SHARING: It is best to start with a regular Vectorworks 
file in a project folder already in your cloud folder.

3.	 The first panel of this dialog box informs you that you are sharing this 
Vectorworks document in the Project Sharing multiuser environment. 

Here, you will also be able to choose what type of network protocol should be used when accessing 
the server (FIGURE 12). If you are using a cloud-based storage system to share your Project file then 
it is not necessary to change the default. If you are sharing over the server, then it is important to 
set the network protocol. For more information on network protocol, visit the tech bulletin here. 

The checkbox at the bottom indicates that a Working File will be opened automatically 
upon completion of the setup. It is recommended to leave this option checked.

https://forum.vectorworks.net/index.php?/articles.html/articles/project-sharing-network-protocol-when-using-smb-on-mac-osx-r501/


FIGURE 13 
Administer Users

FIGURE 12 
Project Sharing Setup
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USING PROJECT SHARING [CONT’D]

 
The setup can be exited at any time by pressing Finish at the bottom right. This will skip all 
subsequent steps of the setup and open a Working File right away (FIGURE 12).  

4.	 Click Next to move to the next pane, Administer Users. This panel allows you to add project 
team members, assign permission levels and assign a user color (FIGURE 13). This color will 
be assigned to objects that the user has checked out. This color assignment allows users to 
visualize the current sate of objects. Therefore colors should have a good level of contrast.

A list of users and their corresponding permission levels can be imported from 
another Project File where a project team has already been defined.



FIGURE 14 
Master Layer
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USING PROJECT SHARING [CONT’D]

 
The user name is based on the User Name of the computer login. For this reason it is 
important that all user names match.   

5.	 At the bottom of the panel, there is an option to set the default permission for any new user 
that is added to the project. This will be the permission level assigned to a user who double 
clicks on the Project File and opens a Working File. This operation adds the person to the 
project team list. The permission level assigned to them is determined by this default. 

 
It is highly recommended that the default permission setting be set to Read Only. 
This insures against any unintentional changes by a non-project team member who 
may open a Working File to simply view the model or print a check set. 

6.	 Click Next to move to Classify Layers. This is the panel allowing you to specify a Master Layer.  
Only users with Administrative or Project permission levels can modify Master Layers.

A Master Layer can be either a design layer or a sheet layer. To designate a layer as a 
Master Layer, simply click in the yellow star column on the far right next to the layer that 
you would like to mark. A yellow star should appear by that layer (FIGURE 14). 

A project can have multiple Master Layers.

7.	 Click Next to move to the last step, which is to set the backup policy for the Project File itself. 
This is not the backup policy for your Working File, only for the Project File. The backup policy 
is the same as a regular Vectorworks file insomuch as a backup copy of the file is created in the 
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location that you designate. However, the backup policy for a Project file is based on the number 
of commits that are performed from any Working File. It is recommended that a backup copy of 
the Project File be created between every 5 – 10 commits. Additionally, it is also recommended 
that backup copies be located on the same server where the Project File is stored. 

8.	 Click Finish to complete the process of creating a Project File. 

9.	 A new Working File will open automatically if you’ve indicated to 
open a Working File in the first step of the setup. 

In your new Working File, you will be able to navigate and begin 
drawing as you would within a regular Vectorworks file.

Because you have created the Project File, by default you have the Administrative 

permission level. This means that you can check out a Master Layer and 

make changes to defined users in the file via your own Working File.

10.	Though your Working File has been created and will have a file name (the Project File name appended 
with the user name), the Working File is still not saved. Save your Working File on your local computer.

FOR CLOUD BASED SHARING: Your Working File should still be saved to your 
local computer. This includes backups of your Working File.

USING PROJECT SHARING [CONT’D]



FIGURE 15A 
Project Sharing Options

FIGURE 15B 
Project Sharing Options
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DRAWING IN A WORKING FILE 

As mentioned before, the behavior of a Working File is not very different from a regular Vectorworks 
file. Any drawing, modeling, editing, or creating operations are done in the same way. There 
are some minor changes to the interface and some settings and functions to be aware of.

At the top right of your Working File you’ll notice a quick-preference option called Project 

Sharing Options (FIGURE 15A). These options allow you to control how checked out or available 
objects are viewed in your own Working File. The options can also be found under the View 
menu under Project Sharing Options. There are three options (FIGURE 15B), which include:

∙∙ Show objects using actual colors will show no visual indication of what is checked out or available. 
∙∙ Highlight objects I have checked out will only highlight objects 

that are checked out in your Working File by you.
∙∙ Highlight objects using User Colors will show objects checked 

out by all users using their User Color.

USING PROJECT SHARING [CONT’D]



FIGURE 17B 
Cue that Shows that an Object is 
Available

FIGURE 17C 
Cue that an Object is Checked Out 
by Me

FIGURE 17A 
Cue that Shows the Name of 
the Object Owner

FIGURE 16 
Checked Out 
Colors
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By default, the Highlight objects using User Colors will be the option selected. Objects that are 
checked out by others will appear with the users designated color (FIGURE 16). There will also be 
object information cues that will also show the name of the owner of the object  
(FIGURE 17A). Objects that are available for check out will appear as normal, without a color 
highlight, and the objection information cue will read Available (FIGURE 17B). Objects checked out 
by you in your Working File will be designated as checked out by me (username) (FIGURE 17C).



FIGURE 18 
Unavailable Layer Alert
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To begin working in your Working File, you can simply begin to draw. You will notice that any 
new object created will by default take on your user color and be designated as checked 
out by you.  If someone has a specific layer checked out, you will not be able to draw on 
that layer and will get an alert indicating that the layer is unavailable (FIGURE 18). 



FIGURE 19 
Right Click Context Menu

FIGURE 21 
Check Out Alert
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SPECIFIC OBJECT AND LAYER CHECK OUT
In order to edit or modify any existing information or objects, you will need to check the 
object out or you can check the entire layer out. Checking out the entire layer will, in essence, 
check out all objects that are placed on that layer as well as lock other users from placing 
new information on that layer. You can check out a layer as well as individual objects from 
different layers at the same time (meaning you can mix the two types of check outs).

TO CHECK OUT SPECIFIC OBJECTS:

1.	 Select the available object or objects.

2.	 Right-click on the selected object(s) and select Check Out in the context menu (FIGURE 19).

OR

Go to Modify → Check Out.

OR

Simply begin to edit the object. You will be prompted to check out the available 
object and any related objects through an alert dialog box (FIGURE 21).  

Individual viewports on Sheet Layers can also be checked out on a per object 
basis allowing for multiple people to work on the same sheet layer.

USING PROJECT SHARING [CONT’D]



FIGURE 22 
Tools Custom Check Out

FIGURE 23 
Custom Check Out

FIGURE 24 
Saved Criteria Sets
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There is also an option to perform a Custom Check Out. A Custom Check 
Out will allow you to check out particular objects that are selected by 
user-defined criteria – much like the Custom Selection tool. 

TO PERFORM A CUSTOM CHECK OUT:

1.	 Go to Tools → Custom Check Out (FIGURE 22)

2.	 The Custom Check Out dialog box will open. Here you can set the criteria 
for the objects you would like to check out (FIGURE 23). 

3.	 Choose the desired criteria options. The number of objects in the file that meet the criteria displays.

4.	 Specify additional options by clicking More Choices. To remove the 
most recently added option, click Fewer Choices.

5.	 Specify whether to also include objects that are part of groups or viewport annotations.

6.	 Click Check Out.

 
Custom Check Outs can be performed with predefined Criteria Sets. This allows for faster Custom 
Check Outs for predefined tasks (FIGURE 24). Criteria Sets that are saved by a user will only be 
available to that particular user – no other user within the team will have access to them.  



FIGURE 25 
Project Sharing 
Layers Tab

FIGURE 26 
Right-click on a Layer in the Navigation Palette for 
Check Out

FIGURE 26 
Right-click on a Layer in the Organization Dialog Box 
to Check Out
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TO CHECK OUT SPECIFIC LAYERS: 

1.	 Go to File → Project Sharing. 

When the dialog box opens, navigate to the Layers tab (FIGURE 25). 

Here you can see the status of all layers in the project. This includes who has checked out what layers, at 
what time, and with what comment. You can also see what layers have been designated as Master Layers. 
Layers that you currently have checked out will appear blue. Layers checked out by others will appear gray. 

2.	 Select which available layers you would like to check out and press the 
Check Out button. This will prompt the Comment dialog box. 

Enter a comment that will inform other team members why you have checked out these layers.

3.	 Click OK and you will be returned to the Project Sharing dialog box. You will now see 
the layers you have checked out in blue text with your name next to them.

OR 

Right-click on the desired, available layer in the Navigation palette (FIGURE 26).

OR 

Right-click on the desired, available layer in the Organization 
dialog box found under the Tools menu (FIGURE 26).



FIGURE 27 
Unavailable Layer in the Navigation Palette

FIGURE 28 
Check Out Required Alert
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Multiple layers can be selected and checked out through the right-click context menu in the Navigation 
Palette or the Organization dialog box.  

In your Navigation palette, a layer that you have checked 
out appears in blue text, whereas layers checked 
out by other team members are grayed out (FIGURE 

27). Though objects or layers may not be available to 
you, you can still see the objects and layers in your 
Working File. You can also control the visibility of 
those objects and layers as with a regular Vectorworks 
file. You will also have the ability to copy unavailable 
information to paste in a different location or layer.

As you’re drawing in your Working File, you may find 
that you need to check out an object or layer that you 
currently do not have access to. Rather than having 
to plan ahead and check out the object or layer ahead 
of time, if the object or layer is available you can 
check it out on the fly, without any interruptions.

1.	 Simply begin drawing on 
the layer you need or editing the objects that exist. 

2.	 The Check Out Required dialog box will open, listing the available layers and 
objects that are required for you to continue the operation (FIGURE 28).

3.	 Click Yes to check out the required objects or layers.

 
By checking the Automatically check out objects on any layer listed above, you are ensuring that 
any future modification to objects on any of the listed layers will be automatically checked out without 
receiving an alert (as long as the objects are available).  

4.	 Complete the operation that you have begun.

Once you have checked out your objects and 
layers, they will no longer be available to other 
team members. There is no need to save and 
commit your Working File to reflect this check out 
in the Project File. This happens in real time. 

To help you decide whether or you should 
check out a layer or check out objects, you 
should understand the differences between 
the two types of checkouts. The fundamental 



 

FIGURE 29 
Entity Name Conflict
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difference is a matter of management.  The main reason that you may want to check out 
a whole layer rather than just objects, is to lock the layer and prevent anyone else from 
checking out any related objects on that layer.  This is recommended if you are making large, 
sweeping changes that may require manipulation of objects related to those changes.

If you check out an entire layer but only modify one object on that layer and then commit the 
changes to the project file, that is the only object whose data gets transferred to the project 
file. Not the entire layer. So whether you check out the entire layer or that one particular 
object, it will still take the same amount of time to commit the changes to the project file. 
In terms of performance, there’s no real difference between the types of check out. 

CREATING AND EDITING RESOURCES
To create or edit resources and non-drawing data, a permission level of Layers and 
Resources or higher is required. The actual process of creating or editing any type of 
resource has not changed in the Project Sharing environment. These operations are done 
the same way in a Working File as they would be done in a regular Vectorworks file. 

As mentioned before, if two project team members with the appropriate permission level attempt 
to change the same resource, Vectorworks will alert them through the Entity Conflict dialog box. 

If a resource is changed and committed to the Project File by one user, and 
another user has changed the same resource in their Working File, they will 
receive a notification either upon committing their Working File or refreshing their 
Working File. When this happens an Entity Conflict dialog box will appear. 

There are two types of conflicts that can occur. The first is a resource conflict. This 
is when a resource with the same name already exists in the Project File. This 
includes name conflicts with existing classes, levels, layers, or stories.  An Entity 
Name Conflict dialog box will appear and give you the option to either rename the 
resource you are attempting to commit or to discard the resource (FIGURE 29).



FIGURE 30 
Entity Conflict

FIGURE 31 
Refresh Icon
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The second type of conflict that can occur is a resource concurrency issue. This occurs when 
someone before you has committed a change to an existing resource to the Project File. In 
this instance you will have three options (FIGURE 30). The first is to override the change that was 
committed before your change. The second option is to rename the resource you have changed in 
order to keep both resources in the Project File. And the third option is to accept the changes that 
have already been committed and discard the changes that you have made. 

When a resource concurrency dialog box appears, it will report who has committed changes 
to the same resource as you and when the commit to the Project File occurred. Always 
communicate with your team members before making decisions to discard others’ changes.

 
If you have the Layers and Resources permission level or higher, you have the ability to 
create, edit, or delete resources without checking out layers. For example, if a symbol 
is placed on a particular layer, a user with the appropriate permissions can edit both 
data and geometry information of that symbol without checking out the layer on which 
it is placed. Once the symbol is edited and the change is committed back to the Project 
File, all other Working Files will be prompted to be refreshed with the refresh icon 
(FIGURE 31). Once refreshed, Working Files will reflect the changes in the symbol. 



FIGURE 32 
Alert for Uncommitted Changes 
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There are some resources that are exceptions to this behavior. These include wall styles, 
slab styles, and roof styles. If an existing wall style that is being used in the model needs 
to be edited, it will not only require the appropriate permission, but will also require any 
instance where the wall style is used to be checked out. This means that if a wall of this wall 
style is checked out by another user (i.e. is unavailable), the wall style cannot be edited. 

If symbols or resources have been edited, created, or deleted without checking 
out any layers, upon saving and closing your Working File, a dialog box will appear 
notifying you that your Working File contains uncommitted changes (FIGURE 32). 

USING PROJECT SHARING [CONT’D]
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REFERENCING
In the Project Sharing environment, references of various file types and references 
of resources are created in a manner similar to that of a regular Vectorworks file. 
There are a few rules to keep in mind including the fact that certain permissions 
are required to create different types of references within your Working File.

The file that is being referenced must be placed in a location that is accessible by 
both the Project File and by all team members on the project. This means that 
it must be kept on the same server volume as the Project File where all team 
members have the appropriate permissions to read and write to the volume.

 
If you choose for the reference to follow a Relative reference path rather than an absolute reference 
path, then that path will be relative to the Project File. The reference should also be on the same 
server volume as the Project file, or within the same project folder if using cloud-based storage. 

 
Project Files can be referenced into other Project Files and into regular Vectorworks files. For 
example, if you have a regular Vectorworks file for a site model and a Project File for your building 
model, you can reference the Project File of the building into the regular Vectorworks file of the site.  

 
You cannot reference a Working File. You will have to navigate to, and reference the Project File itself. This is 
because the Working File is considered a temporary file. 

Regular Vectorworks files can be referenced into Project Files. From our previous 
example, the regular Vectorworks file of the site model can be referenced into your 
Project File. Because you do not open the Project File itself, the reference is created 
by referencing the site model into your Working File (assuming you have the proper 
permission level – see below) and then committing the Working File to the Project File. 

The permissions required for referencing are as follows:

∙∙ Layers – Restricted permission level or above is required to create, edit, 
and delete references to PDF’s, image files, and DWG Files.

∙∙ Project permission level or above is required to create, edit, and delete 
references to Vectorworks files both regular files and Project Files.

 
If you are using Layer Import Referencing (also known as old style referencing), project permission 
level or higher may be required to update the reference as well. This is because if the update will 
import new classes, the user must have a permission level that permits creating new classes.
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Something to keep in mind is that when a reference is updated in a Working file, it is 
recognized as a change to the Working file and will be committed to the Project file. This also 
means that the reference update will be part of a Working file refresh. If you have multiple 
references it is best to only update the references that are currently needed in the Working 
file rather than updating all references. This will cut back on commit and refresh times. 

CREATING DRAWINGS AND SCHEDULES
Creating drawings in Vectorworks is achieved by using Vectorworks’ sheet layers in conjunction with 
viewports. This ensures coordination between drawings and better management of change. In the 
Project Sharing environment, the creation of drawings such as plans, sections, and details through 
the various Create Viewport commands, remains the same as in a regular Vectorworks file.

 
When the Create Section Viewport command is used to create a section, the Section Style class 
is automatically created (if it does not already exist in the current file). Anyone with permissions 
above Read Only can create a section viewport and therefore, create this class. However, the 
class can only be edited or deleted by a team member with Project permission or above. 

 
If a project team member has the Layers-Restricted permission level, they will only be able to 
create viewports on sheet layers that already exist in the file. If a new sheet layer needs to be 
created, it must be created by a team member with Layers-Unrestricted permissions or higher. 

To move viewports between layers or to rename or renumber a drawing, work in 
annotation space, or to edit the crop of a viewport, the viewport must be checked out.   

Schedules, or Worksheets in Vectorworks, are a resource, but do not require 
Layers and Resources permission level. This means that project team members 
with a Layers-Restricted permission will be able to create, edit, and delete 
worksheets. They can also place schedules on existing sheet layers. 

Because worksheets in Vectorworks are bi-directional (i.e. making a change in the worksheet 
will change the geometry or data of the object that is being scheduled), any changes in a 
worksheet that will affect an object will require the checkout of that object. For example, 
if a select number of doors in the schedule needs to be changed to reflect the proper fire 
rating, these doors can only be changed via the schedule if the doors and the walls they 
are hosted in, are checked out. As with all aspects of a project, it is recommended that a 
protocol for communicating changes and updates to a schedule should be put into place.  



FIGURE 33 
Recalculate Worksheet
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It is important to note that a viewport does not need to be checked out to update it. The 
same is true for recalculating worksheets. Also, any project team member can update 
viewports or recalculate worksheets in their Working File regardless of their permission 
level. This means that a user with Read Only permission can update all viewports and 
worksheets to view up-to-date information and to publish or plot drawings. 

 
When a Working File is first opened you may find that worksheets placed on sheets no longer appear or only 
show the header information. Worksheets need to be recalculated to correct this. This can be done by  
right-clicking on the worksheet and choosing Recalculate (SEE FIGURE 33).  

If you need to add revisions and issuances to the the titleblock, these can be done 
on a per sheet basis with the Edit Revision Data and Edit Issue Data found in the 
Object Information Palette when the titleblock is selected. This can be done with any 
permission level higher than Read Only. However, if issuances are to be added on 
multiple sheets using the Issue Manager, Project permission or higher is required.
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WORKING IN VIEWPORTS
When working in viewports it is important to note that entering into annotation space or 
the viewport crop, will not check out the viewport. This means that two users can enter the 
annotation space of a viewport and add information. The information that is added, such as a 
dimension, note, or other type of annotation will be checked out or owned by you. Viewports can 
be thought of as containers. All team members can enter the container, and the information 
within the container can be checked out individually. This flexibility allows for multiple tasks 
to be done concurrently without locking out other team members. If there is a need to limit 
work in a viewport to a single team member, that team member can check out the viewport.  

 
Much like Viewports, Groups behave as containers. Each team member can enter the group 
and edit individual objects within the group or add new objects. Those individual objects will be 
checked out to the user who has created or edited it. Just like viewports, this can be bypassed by 
checking out the group itself, thereby creating exclusive access to the objects in the group. 

COMMITTING CHANGES
Once you have made changes to your Working File, you will have to commit 
those changes back to the Project File. In order to commit changes to the 
Project File you will also have to save your Working File in its local location. 
For this reason, the command to commit is both a save and a commit. 

TO COMMIT YOUR WORKING FILE 

1.	 Go to File → Save and Commit. 

 
When a Working File is committed, the entire file is committed. If you have 
multiple layers that contain changes, all of the changes will be committed. You 
cannot selectively commit information on just some of the layers. 

 
If you have made changes to your Working File, but are not yet ready to commit them to the Project 
File for the entire team to access, you can save your Working File locally through the typical save 
command.  After saving your Working File, upon closing the file you will be alerted through a dialog 
box that your Working File changes have not been committed (FIGURE 32). This dialog box is a good 
reminder of whether or not you have committed any changes in your Working File. It is highly 
recommended that this alert not be dismissed through the Don’t show this dialog box again. 

If more than one team member attempts to commit their Working File at the same time, there 
will be a longer wait time to commit to the Project File. To understand and make this situation 
more manageable, it is highly recommended to establish a team protocol for when to commit 
your Working Files. This protocol should include what time of day that commits should occur and 
after what type of operations or changes in the Working File have been executed should a person 



FIGURE 34 
Commit Dialog Box
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commit to the Project File. Communication among the team is vital. Not only should the established 
protocol be followed, but there should always be constant communication amongst the team.

 
Your office’s Project Sharing protocol should include an established rule that all team 
members perform a Save and Commit as well as, a Close and Release of all objects 
and layers every evening before leaving the office. To ensure that objects and layers are 
released after committing the Commit dialog box includes a checkbox to Automatically 
release checked out layers and objects (FIGURE 34). This box is checked by default.

The only time objects and layers should not be released at the end of the day 
is if the team member intends to continue working in offline mode.

If there are changes that are not ready to be committed to the Project File and 
the objects and layers must remain checked out by a team member, this must 
be communicated to the team, especially to the project administrator.  



FIGURE 35 
Release Uncommitted Changes
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RELEASING CHECKED OUT OBJECTS AND LAYERS
When one team member checks out an object or layer, it remains locked and is unavailable to 
other team members. It must be released before others can access it. Because the Working 
File cannot store uncommitted changes without having the object or layer checked out, it 
can only be released after the changes have been committed back to the Project File. 

TO RELEASE OBJECTS AND LAYERS:

1.	 Go to File → Close and Release.

2.	 This will locally close the Working File and release all checked out information.  

TO RELEASE OBJECTS:

1.	 Right-click on the object, or selected objects, and select Release (FIGURE 19).

OR 

With the objects selected, go to Modify → Release (FIGURE 20).

OR

A Custom Release can also be performed. See the Object Check Out section.

If the Working File has not been committed, you will be prompted to either commit 
the changes or discard the changes before releasing the layers (FIGURE 35). 

A release can be done on a per-layer basis as long as the layer does not 
contain any uncommitted changes or the object hasn’t been modified. 



FIGURE 36 
Release Layers
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TO RELEASE A SPECIFIC LAYER:

1.	 Go to File → Project Sharing.

2.	 In the Layers tab of the Project Sharing Dialog box, select the layers that 
you want to release (you select multiple layers at once).

3.	 Click on the Release button (FIGURE 36).

 

Once you have released an object or layer, it will be available to other 
members of the team. It is not necessary to save and commit your Working 
file for the layer release to be reflected in the Project File.

 
The project Administrator can perform a force release of an object or layer. This 
should only be done in extreme circumstances. This will be discussed in the Project 
Sharing Administrative Responsibilities section of this document.
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REFRESHING A WORKING FILE
As you are working, you will need to refresh your Working File to see the most current 
changes that other project team members have committed to the Project File. You will know 
that your Working File needs to be updated when a yellow exclamation point appears on the 
refresh shortcut in the top left hand corner (FIGURE 31). You can also see more specifically 
which layers need to be updated by going to the Project Sharing dialog box and clicking 
on the Layers tab. Out-of-date layers will have the same yellow exclamation point icon 
to indicate that changes to these layers have been committed to the Project File. 

THERE ARE TWO WAYS TO UPDATE YOUR WORKING FILE. 

1.	 Go to File → Project Sharing.

2.	 Select Refresh.

Or simply click the refresh shortcut in the top, left-hand corner 
of your Vectorworks drawing window (FIGURE 31).

 
A refresh of a Working File will update the entire file. There is no option to update only specific layers.



FIGURE 37 
Opening a Backup Working File
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ACCESSING A BACKUP FILE AND WHEN TO CREATE A NEW WORKING FILE
There are some instances when an existing Working File should be discarded and 
a new Working File created from the Project File. These instances include: 

∙∙ You’re unable to commit changes to the Project File
∙∙ When there’s been an event or error that has caused the Administrator 

to force release your layers or change your permission levels
∙∙ The backup of the Working File needs to be accessed for a number of different reasons 

Any of the instances listed above can lead to the need to access a backup file of your 
Working File. A backup file is connected to the Project File since it is a copy of the 
Working File (this means that the backup file and the Working File share the same 
file ID number – a number that is assigned in the background by Vectorworks). 

TO REPLACE A CURRENT WORKING FILE WITH A BACKUP FILE:

1.	 Release all objects and layers in the current Working File.

a.	If there are changes in the current Working File that should not be 
committed to the Project File: discard all the changes.

b.	If there are changes in the current Working File that should be committed to the Project 
File, but cannot be committed or is causing errors or crashes upon committing:  

i.	 Go to File → Save a Copy As.

ii.	 Save the Working File as a regular .vwx file and with a new, descriptive name.

iii.	 Release all objects and layers and discard the changes in your Working File 
(your changes should be retained in the copy you have saved). 

2.	 Communicate with your team that though you have released these objects and 
layers, they should not be checked out by anyone else. You will need to check 
these objects or layers out again and they need to be available to you.

3.	 Open the most recent backup of the Working File.

4.	 You will receive a message indicating that refreshing this file will cause 
uncommitted changes to be lost (FIGURE 37). Click on Open Anyway.
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5.	 This backup file will not have any layers or objects checked out. 

a.	If there are uncommitted changes in this backup file that need to be committed: You must first check 
out the layers on which these changes occur. There is no need to check out the objects. You will be 
able to commit the changes to the Project File once the corresponding layers have been checked out.

b.	If there are uncommitted changes in this back file that do not need to 
be committed: Refresh the file and discard the changes.

6.	 Save and close the backup file. This is now your most current Working File.

7.	 DELETE the original Working File (with the .vwxw file extension).

8.	 Move the backup file to where your Working File should be saved.

9.	 Rename the backup file to remove the appended timestamp from the file name.

10.	Open and use the file as your typical Working File.

11.	 If you have done a Save a Copy As to retain uncommitted changes, these changes 
will have to be copied and pasted into your new Working File. 

If you are saving multiple backups it is important to know that once a backup file 
is used, the remaining backups should be archived and not used again. 

TO REPLACE A WORKING FILE WITH A NEW WORKING FILE:

1.	 Go to File → Save a Copy As.

2.	 Save the Working File as a regular .vwx file and with a new, descriptive name.

3.	 Release all layers by discarding the changes in your Working File (your 
changes should be retained in the copy you have saved). 

4.	 Communicate with your team that though you have released these layers, they should not be checked 
out by anyone else. You will need to check these layers out again and they need to be available to you.

5.	 DELETE the original Working File.

6.	 Double click on the Project File to create a new Working File.

7.	 Check out the layers that were previously checked out.

8.	 Open the regular Vectorworks file that was Saved from your old Working File.

9.	 Copy and Paste changes from the regular Vectorworks file to the new Working File.
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WORKING OVER VPN
When working over a VPN (Virtual Private Network) it is important to note that when 
performing certain operations that require the Working File to access the Project File 
(committing or refreshing a Working File), there will be a significant slow down in the 
performance of your file (see the Location of the Project File section of this document). 
For this reason, it is highly recommended that both committing and refreshing a Working 
File be done more sparingly than when working while directly connected to the server. 

A protocol for committing and refreshing should be put into place for working with 
remote team members who are accessing the server via a VPN connection.

WORKING OVER THE CLOUD
When working with a Project File stored in a cloud-based storage system, your 
Working File should be saved on your local machine. Because your Working File will 
communicate with the Project File over the internet, the speed of performing Commits 
and Refreshes will be dependent on the bandwidth of your internet connection.



FIGURE 38 
Model Files are Referenced into a Production File

FIGURE 39 
Project Files for Modeling Information are Referenced into Project Files for 
Production
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PUBLISHING OR PLOTTING A DRAWING SET

Publishing or plotting a drawing set is done as you would with a regular Vectorworks 
file. All of the Project Sharing permission levels will have the ability to run the Publish 
command from their Working File. This includes the Read Only permission. 

Be sure that all Working Files have been committed to the Project File to ensure 
the most current information is reflected in the Project File. The Working File 
that is being used to plot or publish should be refreshed as well.

Generally, it is recommended to work within a singular file, however there may be some 
instances where a plot file should be created. A plot file or production file is a separate file used 
for the creation of drawings. It is distinct from a model file by the fact that all sheet layers are 
created in the plot file and all design layers are referenced from the model file (SEE FIGURE 38).

Both model file and plot file should be Project Files allowing multiple team members 
to access the two files through their own Working Files (FIGURE 39). Though this may 
add to the responsibilities of file management, this division can help ease file size 
and performance issues that may arise due to a large number of sheet layers.  
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USING PROJECT SHARING [CONT’D]

ARCHIVING

When it comes time to archive your project, it is recommended that the project not be 
archived as a Project File. This is especially important if a file is being archived in the 
middle of a project or at certain milestones during the project. The archive file should be 
disassociated with any existing Working Files. This means that when a project is being 
archived, the Project File should be changed back into a regular Vectorworks document. 

A PROJECT FILE IS MADE A REGULAR VECTORWORKS DOCUMENT BY:

1.	 Open your Working File – ensure that it is refreshed and contains the most 
current information or the information needed for the archive file.

2.	 Go to File → Save A Copy As.

3.	 Navigate to the appropriate folder where your archived file will be located. 

4.	 Name the archive file with the appropriate file naming convention.

5.	 Be sure to change the file type to Vectorworks Drawing (.vwx).

6.	 Click Save to complete the process.

This ensures that existing Working Files will maintain their connection with the Project File and not 
the archived file. Be sure to archive other information such as referenced files and back up files.



FIGURE 40 
Edit User Permission
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USING PROJECT SHARING [CONT’D]

PROJECT SHARING ADMINISTRATIVE RESPONSIBILITIES

As mentioned before, it is recommended that each Project File have two team members 
with the Administrative permission level. This is to ensure that the administrative 
capabilities are accessible regardless of specific team members’ availability. 

Though there are project and document settings that require Administrative permission, 
there are two main responsibilities that will require a more active role from the project 
administrator. These responsibilities include archiving the Project Files (discussed in the 
prior section) and managing the project team members.  Project team members may need to 
be added to a project or their permission levels changed. As mentioned before in the How to 
Create a Project File section, it is recommended that the default permission setting for any 
new team members should be set to Read Only. This means that any new team member that 
is added to the project creating a new Working File will have the Read Only permission. This is 
to protect against any unintentional changes by those who may simply want to open the file to 
review project progression or information. However, if a new team member needs to be able 
to check out and modify a layer or resource, they will need their permission level changed. 

TO CHANGE A USER’S PERMISSION LEVEL, THE PROJECT ADMINISTRATOR WILL:

1.	 Make sure that the user’s Working File is closed and all changes have been committed to the Project File.

2.	 The administrator will open their own Working File.

3.	 Go to File → Project Sharing.

4.	 Click on the Users tab.

5.	 Select the username whose permission needs 
to be changed. Click on the Edit button.

6.	 Select the desired permission level in the 
drop down menu (FIGURE 40).

7.	 Click Ok to exit the Edit User dialog box.

8.	 Click Ok to exit the Project Sharing dialog box.

 
The Working File does not need to be committed for 
this permission level change to take effect.

 
If a user’s Working File contains uncommitted changes and their permission level has been 
modified, they will not be able to commit to the Project File. It is essential that all changes 
to permissions be communicated appropriately to prevent the loss of information.



FIGURE 41 
Force Release

FIGURE 42 
Force Release Objects
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USING PROJECT SHARING [CONT’D]

Another responsibility of the project administrator includes the management of 
object and layer check outs. If a user has checked out an object or layer and has 
forgotten to release it, the administrator can perform a force release. 

TO FORCE RELEASE A LAYER THE PROJECT ADMINISTRATOR WILL:

1.	 Open their own Working File.

2.	 Go to File → Project Sharing.

3.	 In the Layers tab, select the layers that need to be released.

4.	 Click on the Release button. 

5.	 You will see a dialog box appear indicating that the layers are 
checked out by others and this will force the release (FIGURE 

41). Be cautious and ensure that all team members are aware 
of the force release and the possibility of loss of information.

6.	 To proceed with the force release, click on Release Anyway.

TO FORCE RELEASE OBJECTS, THE PROJECT ADMINISTRATOR WILL:

1.	 Select any object owned by the user whose objects need to be released.

2.	 Right-click and select Release.

OR 

Go to Modify → Release.

3.	 Click on Release Anyway (FIGURE 42). 



FIGURE 42B 
Custom Release of Objects
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USING PROJECT SHARING [CONT’D]

ANOTHER WAY TO FORCE RELEASE OBJECTS HELD BY A SPECIFIC 

USER, THE PROJECT ADMINISTRATOR WILL:

1.	 Go to Tools → Custom Release.

2.	 Under Selection Criteria there are three pull down menus. Select:

a.	Owner 

b.	is

c.	Then the username of the team member’s objects that need to be released (FIGURE 42B).

 
When force releasing, you are releasing all objects and layers owned by the user.  You cannot selectively 
force release a layer or object. The administrator does not need to commit their Working File for the layers 
to be available to the rest of the team. 

If the user from whom the force release was performed has uncommitted changes in their Working 
File, they should not refresh their Working File upon opening it. Instead they should perform a Save 
a Copy As and follow the steps outlined in the Accessing a Backup File section of this document. 

A force release should only be performed in extreme, last-resort cases. If a user has 
uncommitted changes in their Working File and a force release is performed, they will 
lose these changes. They will not longer be able to commit to the Project File. 

Generally, the project administrator should also be able to make decisions regarding 
referencing information versus importing information, file structure and archiving to match 
that of office standards and protocol. As such, Project Sharing will require little change to 
existing standards within an office and can be easily implemented on all new projects. 

For more information regarding Project Sharing refer to the Vectorworks Help, 
available online. Extensive information regarding permissions and the type of 
information and data that is committed to the Project File can found here.

For specific help or troubleshooting, call your Vectorworks Tech Support team. 

http://app-help.vectorworks.net/2016/eng/index.htm#t=VW2016_Guide%2FWelcome%2FWelcome.htm
http://app-help.vectorworks.net/2016/eng/index.htm#t=VW2016_Guide%2FProjectSharing%2FThe_Project_Sharing_Dialog_Box.htm%23XREF_47683_The_Project&rhsearch=project%20sharing%20permissions&rhsyns=%20


FIGURE 43 
History Tab of the Project Sharing Dialog Box
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ADDITIONAL INFORMATION

ADDITIONAL INFORMATION

THE PROJECT SHARING DIALOG BOX
The Project Sharing Dialog box can be accessed at anytime within a Working File. This 
dialog box will provide continuous, up-to-date information regarding the project.  You 
will be able to check on the status of the availability of layers, the permission levels of 
all project team members, the user colors, access the history of the Project File, and 
see the backup policy of the Project File itself. Depending on your permission level you 
will be able to either view the information in these tabs, or edit the information.

LAYERS TAB
The Layers Tab allows you to view all the layers of the project. You can see which layers are 
available, which layers are checked out by others (seen as gray text), and which layers you 
have checked out in your own working file (seen as blue text) (FIGURE 36). Unavailable layers 
will include the username of the team member that has exclusive access to the layer as well 
as the comment made upon checkout. You can also track the date and time when the layer 
check out was performed and when the layer was last committed to the Project File. 

The project administrator can designate layers as Master Layers within this tab. 

HISTORY TAB
Tracking changes and design options as they are added to and subtracted from the project 
can become difficult in a multiuser environment. The History tab of the Project Sharing 
dialog box contains a compilation of a change history of the Project File (FIGURE 43). 



FIGURE 44 
Users tab
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ADDITIONAL INFORMATION [CONT’D]

Information that is tracked and listed in the history tab include the name of the object, 
the type of entity (such as layers, classes, or resources), the user who has checked out or 
modified the entity, the action taken (check out, commit, release), and the date and time of 
the action. The information can be sorted on any column header. For example, all changes 
to a given layer or all changes made by a particular user. Additionally, a search of the history 
by keywords can be done using the search control option in the lower right (FIGURE 43).

The entire history of the project can be exported to a comma-separated file by 
clicking the Export button. This export will generate a CSV file that can then be 
imported into any data processing application such as Excel, Numbers, etc.

The project administrator will be able to clear all the project 
history by clicking the Clear all History button. 

USERS TAB
A list of the entire project team can be seen in the Users tab (FIGURE 44). Information 
found in this tab includes team members’ username, permission level, and color. 

The project administrator is able to add and delete team members, edit their permission 
level and username, and change the default permission level for new users. 

BACKUP TAB
The backup policy that has been established for the Project file can be seen 
in the Backup tab of the Project Sharing dialog box (FIGURE 45).

The project Administrator is able to change the backup policy for the Project File. 



FIGURE 45 
Backup Policy

 48 Introduction to Project Sharing: the Multiuser Environment in Vectorworks Architect

RESET DOCUMENT PREFERENCES
As mentioned before, the Vectorworks Document preferences can be modified within a Working 
File, but these modifications will only be committed to the Project File with the Project permission 
level or above. More information regarding Document Preferences can be found here. 

In the lower, left-hand of the Project Sharing dialog box is a Reset Document Preferences 
button (FIGURE 45). This will reset the Working File’s current document preferences to 
match those of the Project File. This means if a document preference change has been 
made by a project administrator, that change will be reflected in the Working File after 
resetting the document preferences through the Project Sharing dialog box. 

ADDITIONAL INFORMATION [CONT’D]

http://app-help.vectorworks.net/2016/eng/index.htm#t=VW2016_Guide%2FProjectSharing%2FPermission_Levels_for_Document_Preferences_and_Settings.htm%23XREF_74345_Permission_Levels&rhsearch=project%20sharing&rhsyns=%20
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GLOSSARY

PROJECT SHARING – the multiuser environment within Vectorworks. Project Sharing 
creates an environment that streamlines project organization and management by 
allowing design teams to work concurrently in the same Vectorworks document. 

PROJECT FILE – a single file that serves as the hub for sharing or collaborating 
on a project. All team members can access the Project File by way of their Working 
File. A Project File will be designated with the file extension .vwxp. When a Project 
File is opened, a Working File is created. This means that the Project File is always 
accessed through a Working File. The Project File should be kept either on a server 
or in a cloud-based storage folder that can be accessed by all team members.

WORKING FILE – a local copy of a Project File specific to the user who has created it. The 
Working File is used to add to, subtract from, or modify the Project File. In essence, all 
modeling and drawing creation is done in a Working File and then is committed back to the 
Project File. A Working File is designated with the file extension .vwxw. When a Working File is 
open, the title bar on the file will include WORKING FILE to indicate that you are currently in 
a Working File (FIGURE 2). The Working File is kept on the hard drive of your local computer. 

CHECK OUT – reserving an object(s), design layer(s) and sheet layer(s) for exclusive 
use. Once a person checks out an object or layer, they become the owner. That 
object or layer becomes unavailable to other team members until it is released 
– see below. Multiple objects and layers can be checked out at once.

COMMIT – saving changes made in a Working File back to the Project File.

RELEASE – relinquishing your reservation on, or exclusive access to, objects or layers that were 
previously checked out by you. This will make the objects and layers available for others to check 
out.

REFRESH – an update of all out-of-date parts of your Working File. A refresh is performed after 
another team member commits their changes to the Project File, which will make parts of your 
Working File out-of-date. A refresh does not commit your Working File; nor does it affect any of 
your uncommitted work. 
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GLOSSARY [CONT’D]

REVERT – discards any changes in the active Working File and reloads an exact copy 
of the Project File in its current state. This should be used only when changes to 
your Working File are to be discarded and not committed to the Project File. 

MASTER LAYER – a designated, special layer that changes infrequently over the 
life of a project. A Master Layer may contain critical information that should not be 
changed or overwritten. An example of such a layer may be a design layer that holds 
a project’s structural grid. You can have multiple Master Layers in a project.

OFFLINE MODE – when a Working File is disconnected from the Project File while 
maintaining exclusive access to the checked-out layers. Offline Mode allows you 
to continue working without access to the server where the Project File is saved. 
Layers must be checked out before using Offline Mode to maintain exclusive access 
to them. Once the Working File is reconnected to the server and the Project File, 
changes made in Offline Mode can be committed back to the Project File. 

PERMISSION LEVEL – one of the unique features of Vectorworks’ Project Sharing is 
the ability to assign a Permission level to each member of a project team. Permission 
levels range from Administrative to Read Only, and allow for greater control and 
management of resources and editing of the Project File. More about the various 
permission levels can be found in the How to Set Up for Project Sharing section.

FORCE RELEASE – when an administrator releases objects or layers that are checked  
out by another user. 

UNCOMMITTED CHANGES – changes that are made to a Working file but have not  
been committed to the Project file. 
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FREQUENTLY ASKED QUESTIONS

1.	 WHEN SHOULD I SET  UP MY VECTORWORKS FILE FOR PROJECT SHARING?
Because Project Sharing does not change any fundamental aspects of 
Vectorworks, it can be implemented at any time during a project using 
any Vectorworks document that will require multiple users.

There are no preset rules or requirements for changing a Vectorworks 
document to a Project File and therefore requires no special setup.

2. 	 CAN I STILL USE LAYER AND RESOURCE REFERENCING?
Yes. 

When you share project files and use referencing, keep in mind the following rules:

∙∙ Project files can be referenced into other project files and regular Vectorworks files; resources 
referenced from the file cannot be modified.

∙∙ Regular Vectorworks files can be referenced into project files. For example, a symbol library 
can be referenced into a project file; resources referenced from the file can be modified.

∙∙ Working files cannot be referenced into any other files since they are considered temporary files 
that can be deleted at any time.

∙∙ Place the reference file in a location accessible by the project file and all users working on the 
project.

∙∙ Relative reference paths are relative to the location of the project file, and the referenced file 
must be on the same volume as the project file. 
 

3. 	 WHAT IF I NEED TO LEAVE THE NETWORK THAT THE PROJECT 
IS ON? CAN I STILL WORK ON THE PROJECT?
Yes, Project Sharing includes a Work Offline mode in case you need to take a laptop on a 
trip or you temporarily lose access to the network containing the project file. When in this 
mode, changes will ONLY be saved to the working file directly and any layers or objects 
you have checked out will not be available to other users until you reconnect to the project 
file and release them. Offline mode will also prevent you from accessing the Project file 
to check out new objects or to release objects. So be sure to check out all information 
that you want to work on before disconnecting from the server or the internet.

 If Vectorworks detects a loss of connection to the server, it 
will prompt you to begin working in offline mode.
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FREQUENTLY ASKED QUESTIONS [CONT’D]

4. 	 WHAT IF I WANT TO SEE WHO MADE CERTAIN CHANGES TO A PROJECT?
The History feature within the Project Sharing dialog box will let you search not only for 
users, but by specific layers to either focus on ALL of a specific user’s changes, or to focus 
on which users made a change to a particular layer. Since you can add comments when 
checking out layers and objects, or when editing or releasing layers and objects, you can 
also search the comment history. So including useful keywords in the comment is advised.

5. 	 WHAT SHOULD I DO IF MY WORKING FILE HAS BECOME CORRUPTED 	
       OR I CAN NO LONGER COMMIT TO THE PROJECT FILE? 

∙∙ Do a Save A Copy As (not just Save As) of the working file 
and turn it into a regular Vectorworks file.

∙∙ Have the administrator force release the objects or layers that were checked out.
∙∙ Delete your working file (you should have your changes in the saved as  

regular Vectorworks file).
∙∙ Create a new working file from the project file.
∙∙ Check out the necessary objects and/or layers.	
∙∙ Copy and paste the changed elements from the regular Vectorworks file to the new working file.
∙∙ Commit the changes to the Project File.

6. 	 CAN I SEE CHANGES MADE BY OTHER USERS LIVE, IN REAL-TIME?
Not yet. Currently only after another user Commits changes to the project and 
you Refresh your working file will you see their new changes.	

7. 	 CAN A USER WITH FUNDAMENTALS USE PROJECT SHARING?
No.  Project Sharing is only available in Architect, Landmark, Spotlight or Designer. 

8. 	 CAN I CONVERT A PROJECT FILE BACK TO A REGULAR VECTORWORKS FILE?
Yes. You can use File → Save a Copy As (not just Save As) in order to 
change your Working file, into a regular Vectorworks file. The original 
project can then simply be archived or removed at your discretion.

 
Make sure that when using Save a Copy As, you then select the vwx file format to save as, not the default 
vwxw format. 

9. 	 CAN I STORE AND SHARE THE PROJECT FILE ON CLOUD STORAGE? 
Yes, you can put project files (.vwxp) in Google Drive, Dropbox, OneDrive, or Box folders.
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10. HOW DO I DECIDE IF I SHOULD USE A CLOUD-BASED STORAGE FOR PROJECT 
SHARING OR VPN TO CONNECT TO MY PROJECT FILE ON MY SERVER?
Even though a cloud-based storage folder and VPN are both dependent on your 
internet speed, connecting to a server via VPN is much slower in general. 

11. CAN I CREATE A PROJECT FILE ON THE SERVER AND THEN MOVE IT TO  
CLOUD STORAGE FOR OTHERS TO ACCESS? 
Yes. You can move (not copy) your Project File to cloud-based storage for sharing with others. 
You should share a Project File either on the server or on a cloud-based storage system – not 
both. 

12.	CAN I CHANGE THE PERMISSIONS FOR USERS THAT CURRENTLY HAVE  
LAYERS CHECKED OUT?
Yes, but you should ALWAYS make sure that a user releases any objects or layers and commits 
any changes before their permissions are altered to prevent a situation where a user is 
attempting to commit a change in an area they no longer have access to.

13.	WHAT HAPPENS WHEN I CHANGE THE PERMISSION 
LEVEL OF A PROJECT TEAM MEMBER?
If a user’s Working File contains uncommitted changes and their permission level has been 
modified, they will not be able to commit to the Project File. It is essential that all changes 
to permissions be communicated appropriately to prevent the loss of information.

14. 	WHAT HAPPENS WHEN I DELETE A USER WHO HAS OBJECTS OR LAYERS CHECKED OUT?
�Nothing. The objects and layers will remain checked out. If there are uncommitted changes in 
the user’s original Working file, they will have to open a new Working file (which will add them 
back to the project), return to their original Working file and commit changes and release all 
information.   

As with all other administrative responsibilities that include forced changes for users, 
communication is key.

15. 	CAN A USER HAVE MORE THAN ONE WORKING FILE AT ONCE?
�Yes.  However, it is not recommended for a single user to create and use more than 
one working file at a time. The objects or layers you have checked out are restricted 
to the working file that you have checked out in. You will not be able to modify any of 
those objects in your second working file. This can lead to confusion and problems. 

FREQUENTLY ASKED QUESTIONS [CONT’D]
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16. HOW IS MY USERNAME DETERMINED?
The Project Sharing user name is determined by your computer’s login name.

17. CAN THERE BE IDENTICAL USERNAMES?
No. If your office is utilizing a generic computer login such as User or
Architect, this will create identical or duplicate usernames since the username
is determined by the computer login name.  Office protocol will have to
change to give each computer a unique login to avoid this problem.

18. WHAT NETWORK PERMISSIONS ARE REQUIRED FOR USERS TO
ACCESS THE LOCATION WHERE A PROJECT FILE RESIDES?
Users should have Full access. Read, Write, Rename, Delete, Create, etc.

Vectorworks uses a safe save technique for saving files, in which the previous version of the
destination file is maintained until the last possible moment, to avoid potential file damage
during save, such as by a hardware or network failure. To support this in a networked
environment, permissions must be correctly set to handle the required file operations.

IN PARTICULAR, THE FOLLOWING TWO CONDITIONS MUST BE FULFILLED: 

1. The user must have permission to delete files in the destination folder. This is usually the case when the 

user has write access to the folder. However, some network server configurations using fine-grained control 

(e.g. with Access Control Lists) may need to be specifically configured to allow this, by assigning delete_ 

child permission to the folder. See (https://support.apple.com/en-us/HT201416) for more information. 

2. Files created in the destination folder must inherit the permissions of the folder itself. 
Server installations that use Access Control Lists may need to ensure that file_inherit 
permission is set on the destination folder. (Note: On OSX Server, ACLs may need 
to be explicitly enabled. See (https://support.apple.com/en-us/HT203574) 

19. WHAT ARE THE SYSTEM REQUIREMENTS FOR USING PROJECT SHARING?
The system requirements for Project Sharing are the same for your regular
Vectorworks use.  The most current System Requirements can be found here.

Project Sharing does have Network requirements for both LAN sharing and Cloud
sharing. These requirements can be found with the system requirements.

20. WILL CHECKING OUT A LAYER AFFECT FILE PERFORMANCE
DIFFERENTLY THAN CHECKING OUT AN OBJECT?
Working in the project sharing environment is the same as working in a regular
Vectorworks file. The only time your working file transfers data to the project file is

FREQUENTLY ASKED QUESTIONS [CONT’D]

https://support.apple.com/en-us/HT201416
https://support.apple.com/en-us/HT203574
http://www.vectorworks.net/sysreq
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when you are committing changes or you are refreshing your working file. Checking 
out objects or layers or releasing them does requires only a small amount of data to 
transfer. It does connect to the project file, but generally these actions don’t require 
much time, regardless of how many objects or layers you are checking out.  This 
is true for working over a server or through a cloud-based storage folder.

If you check out an entire layer but only modify one object on that layer and then commit the 
changes to the project file, that is the only object whose data gets transferred to the project 
file. Not the entire layer. So whether you check out the entire layer or that one particular 
object, it will still take the same amount of time to commit the changes to the project file. 
In terms of performance, there’s no real difference between the types of check out. 

21.	HOW DO I DECIDE IF I WANT TO CHECK OUT AN ENTIRE LAYER OR JUST A FEW OBJECTS?
	� It’s a matter of management. The main reason that you may want to check out a whole 

layer rather than just objects, is to lock the layer and prevent anyone else from checking 
out any related objects on that layer.  This is recommended if you are making large, 
sweeping changes that may require manipulation of objects related to those changes.

22. SHOULD I CHECK OUT THE OBJECTS I NEED AHEAD OF TIME, OR 
SHOULD I CHECK THEM OUT “ON THE FLY” AS I NEED THEM? 
Project Sharing supports both an explicit upfront check out and an on-demand or on-the-fly 
check out. There is no real recommendation for one over the other, but it is highly encouraged 
that teams set a protocol for check outs in order to avoid repeated alerts of unavailable objects.

23. HOW DO I DECIDE IF I SHOULD USE THE SMB OR AFP NETWORK PROTOCOL? 
If you are using a Mac OSX server, you should use the AFP protocol and should turn off SMB on 
your server.

If you are using a Windows-based server, you should use SMB.

You should never mix SMB with AFP – meaning each user should be using the same network 
protocol. More information can be found here.

24. HOW OFTEN SHOULD I COMMIT MY WORKING FILE TO THE PROJECT FILE?
Each office should set their own standards or protocols for when to commit changes 
from a Working file and when to Refresh their Working files. It is highly recommended 
that for large projects with many users, a schedule should be created for committing and 
refreshing Working files Committing should only take place after significant changes have 
been made or milestones met. All other work should be saved locally to the Working file. 

FREQUENTLY ASKED QUESTIONS [CONT’D]

https://forum.vectorworks.net/index.php?/articles.html/articles/project-sharing-network-protocol-when-using-smb-on-mac-osx-r501/
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25. HOW OFTEN SHOULD I REFRESH MY WORKING FILE?
Working files should be refreshed when any new and significant information has been 
committed to the Project file by other team members.

As with committing, for large projects with many users, a schedule for refreshing  
Working files should be created.

26. WHY DOES COMMITTING OR REFRESHING MY WORKING FILE 
SEEM TO TAKE LONGER WHEN I HAVE REFERENCES? 
When you refresh references in your Working file, this is committed back to the Project 
file as a change.  If there are a lot of references that have all been updated, your 
commit to the Project file will take longer.  Since the updated references are recognized 
as changes, a refresh of a Working file will also take longer.  It is recommended 
that references should only be updated when needed in a Working file.

27. WHAT HAPPENS WHEN TWO PEOPLE TRY TO COMMIT 
THEIR WORKING FILES AT THE SAME TIME?
Only one person can commit their Working file at a time. The second person 
will receive an alert and will have to wait to commit their Working file.

28. HOW DO I DETERMINE WHAT PERMISSION LEVEL TO ASSIGN 
TO DIFFERENT PROJECT TEAM MEMBERS?
Implementing Project Sharing will mean a few new responsibilities for the project 
team. These responsibilities include the creation of the Project File itself as well as 
management of the Project File and its shared information. This and other tasks that 
need to be completed for a project should help inform the Permission level that each 
team member will require. Understanding the Permission levels and what tasks they 
allow you to complete, will help you understand how they can coincide with project 
tasks and roles.  More information the on Permission Levels can be found here.

29. CAN I HAVE MORE THAN ONE PROJECT ADMINISTRATOR? 
Yes.  As a matter of fact, we highly recommend that there should be two or more  
users with Administrator permission levels. 

FREQUENTLY ASKED QUESTIONS [CONT’D]

http://app-help.vectorworks.net/2018/eng/index.htm#t=VW2018_Guide%2FProjectSharing%2FPermission_Levels_for_Resources_and_Other_Global_Data.htm%23XREF_65271_Permission_Levels&rhsearch=project%20sharing%20permissions&rhsyns=%20


LEARN MORE 
about how Vectorworks can help you maintain a 
more collaborative BIM process with IFC.

Email us at hello@vectorworks.net.

VECTORWORKS, INC.

7150 Riverwood Drive, Columbia, MD 21046-1295 USA

VECTORWORKS.NET

T 410.290.5114

©2017 Vectorworks, Inc. All rights reserved.




